~paelzer/ubuntu/+source/nut:cosmic-merge-2.7.4-7

Last commit made on 2018-05-30
Get this branch:
git clone -b cosmic-merge-2.7.4-7 https://git.launchpad.net/~paelzer/ubuntu/+source/nut
Only Christian Ehrhardt  can upload to this branch. If you are Christian Ehrhardt  please log in for upload directions.

Branch merges

Branch information

Name:
cosmic-merge-2.7.4-7
Repository:
lp:~paelzer/ubuntu/+source/nut

Recent commits

d95daa1... by Christian Ehrhardt  on 2018-05-30

changelog: re-add debian/libnutclient0.symbols: Correct symbols file for ppc64el

Signed-off-by: Christian Ehrhardt <email address hidden>

4d91926... by Nish Aravamudan on 2017-11-03

    - debian/libnutclient0.symbols: Correct symbols file for ppc64el.

d88f6cc... by Christian Ehrhardt  on 2018-05-30

update-maintainer

90c5c11... by Christian Ehrhardt  on 2018-05-30

reconstruct-changelog

Signed-off-by: Christian Ehrhardt <email address hidden>

a8c130e... by Louis Bouchard on 2016-11-21

    - debian/tests/control : Fix dep8 test failures:
       + Drop python-unit from dep8 dependencies since the python-test
         package has now been removed. The unittest module has shipped with
  Python since 2.1.
       + Add dep8 test dependency on python, since Python 2 is required and
         is not necessarily installed by default any more.

19275dd... by Louis Bouchard on 2016-11-21

    - debian/tests/test-nut.py: in the CVE_2012_2944 test, give nut at most
      + 5 seconds to shut down, instead of expecting it to be shut down
        immediately after sending the killall.
      + Additional indication on how to run tests for xenial+

f829fc4... by Louis Bouchard on 2016-11-21

    - debian/source_nut.py, debian/{nut,nut-server,nut-client}.install,
      debian/rules: Install apport hooks for all top-level nut packages.

ffb6702... by Christian Ehrhardt  on 2018-05-30

    - d/nut-server.postinst, d/nut-cgi.postinst: ensure nut is member of group dialout

Signed-off-by: Christian Ehrhardt <email address hidden>

fb2ed3e... by Christian Ehrhardt  on 2018-05-30

    - remove nut-powerman-pdu
      + debian/control: remove nut-powerman-pdu package
      + debian/nut-powerman-pdu.{install,manpages}: dropped for now

Signed-off-by: Christian Ehrhardt <email address hidden>

619ad07... by Louis Bouchard on 2016-11-21

    - remove Build-Depends on libpowerman0-dev