~paelzer/ubuntu/+source/ntp:merge-disco-4.2.8p12-2-lp1806382

Last commit made on 2018-12-03
Get this branch:
git clone -b merge-disco-4.2.8p12-2-lp1806382 https://git.launchpad.net/~paelzer/ubuntu/+source/ntp
Only Christian Ehrhardt  can upload to this branch. If you are Christian Ehrhardt  please log in for upload directions.

Branch merges

Branch information

Name:
merge-disco-4.2.8p12-2-lp1806382
Repository:
lp:~paelzer/ubuntu/+source/ntp

Recent commits

ab2e6f5... by Christian Ehrhardt  on 2018-12-03

changelog: mention dropped changes

Signed-off-by: Christian Ehrhardt <email address hidden>

c616844... by Christian Ehrhardt  on 2018-12-03

update-maintainer

fbde1da... by Christian Ehrhardt  on 2018-12-03

reconstruct-changelog

d7cc8ea... by Christian Ehrhardt  on 2018-12-03

merge-changelogs

6e84caa... by Christian Ehrhardt  on 2018-05-29

* d/ntp.dhcp add support for parsing systemd networkd lease files LP: #1717983

Signed-off-by: Christian Ehrhardt <email address hidden>

aa39fed... by Christian Ehrhardt  on 2018-05-29

    - d/ntp.conf, d/ntpdate.default: Change default server to ntp.ubuntu.com.

Signed-off-by: Christian Ehrhardt <email address hidden>

b4066aa... by Bernhard Schmidt <email address hidden> on 2018-09-14

Import patches-unapplied version 1:4.2.8p12+dfsg-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 23318cf02f37cf5c1bf021dd1254d55c3c576574

New changelog entries:
  * Treat testsuite errors as non-fatal on some architectures
    Fixes FTBFS on ppc64el, ia64, powerpc, ppc64

23318cf... by Bernhard Schmidt <email address hidden> on 2018-09-13

Import patches-unapplied version 1:4.2.8p12+dfsg-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9b66874a88689f5254d22edb7f385f0943ca6e2b

New changelog entries:
  * Drop ntpdate ifupdown hooks (Closes: #908286)
    These have been a constant source of problems and one-shot syncs
    are not a proper solution for timekeeping. See ntpdate.NEWS for
    details
  * Do not install /var/lib/ntpdate, not used anymore
  * Drop maintscript snippets for upgrading from versions prior to Jessie
  * Reenable unittest
    - disable always failing test-decodenetnum with a patch
  * Set Rules-Requires-Root: no

9b66874... by Bernhard Schmidt <email address hidden> on 2018-08-16

Import patches-unapplied version 1:4.2.8p12+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6a69d5ceddb098f49362ef53180da7bbd9a1e4ac

New changelog entries:
  [ Bernhard Schmidt ]
  * New upstream version 4.2.8p12
  * Update Maintainer address to <email address hidden> (Closes: #899940)
  * Update ntpdate.8 from ntpdate.html (Closes: #476491, #515246)
  [ Peter Eisentraut ]
  * Remove Peter Eisentraut from Uploaders

6a69d5c... by Bernhard Schmidt <email address hidden> on 2018-03-25

Import patches-unapplied version 1:4.2.8p11+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1c4f041925ae0a6391ca02a43e75807398d73fb3

New changelog entries:
  * New upstream version 4.2.8p11+dfsg (Closes: #851096)
    - Refresh patches
    - Drop ntpd-increase-stack-size included upstream
    - CVE-2018-7185: Unauthenticated packet can reset authenticated
      interleaved association (LOW/MED)
    - CVE-2018-7184: Interleaved symmetric mode cannot recover from bad state
      (LOW/MED)
    - CVE-2018-7170 / CVE-2016-1549: Provide a way to prevent authenticated
      symmetric passive peering (LOW)
    - CVE-2018-7183: decodearr() can write beyond its 'buf' limits (Medium)
    - CVE-2018-7182: ctl_getitem(): buffer read overrun leads to undefined
      behavior and information leak (Info/Medium)
    - CVE-2016-1549: Sybil vulnerability: ephemeral association attack
      (mitigated in 4.2.8p7)
  * convert dfsg.sh into mk-origtargz script
  * Run wrap-and-sort
  * Sync AppArmor profile changes from Ubuntu, including a fix for a
    harmless AppArmor denial in /usr/local (Closes: #883022)
  * Don't chown in postinst recursively.
    Thanks to Daniel Kahn Gillmor (Closes: #889488)
  * Build sntp against system libevent
  * Drop versioned build-deps already fulfilled by oldoldstable