Code review comment for lp:~osomon/unity-2d/drag-from-dash

Revision history for this message
Olivier Tilloy (osomon) wrote :

> - a Component should be passed as DragItemWithUrl's delegate as to not create
> Image instances unless necessary. Instead of:

Thanks for pointing this out. I had originally tried to write it this way, but I had failed to do so. I tackled the problem again, this time successfully. This is revision 570.

> - DeclarativeDragItem::drop signal name should have a better name, for example
> 'dragInitiated'

Nope, it’s called 'drop' because it’s actually emitted upon dropping the dragged item, not when the drag action is initiated.

> - The workaround that has been added to AbstractButton could use a link to qt
> bug report 13007 that if I am right should remove the need for it in the
> future (

You’re right. Added at revision 571.

« Back to merge proposal