Code review comment for lp:~osomon/unity-2d/drag-from-dash

Revision history for this message
Florian Boucault (fboucault) wrote :

Overall the code is nice and simple.
A few comments:

- a Component should be passed as DragItemWithUrl's delegate as to not create Image instances unless necessary. Instead of:

  DragItemWithUrl {
    delegate: Image {...}


  DragItemWithUrl {
    delegate: imageComponentId

  Component {
    id: imageComponentId
    Image {...}

- DeclarativeDragItem::drop signal name should have a better name, for example 'dragInitiated'

- The workaround that has been added to AbstractButton could use a link to qt bug report 13007 that if I am right should remove the need for it in the future (

review: Needs Fixing (code)

« Back to merge proposal