lp:openshot/build-wizard

Created by Jonathan Thomas on 2009-05-27 and last modified on 2010-01-07
Get this branch:
bzr branch lp:openshot/build-wizard
Members of OpenShot Developers can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
OpenShot Developers
Project:
OpenShot Video Editor
Status:
Mature

Recent revisions

10. By Jonathan Thomas <jonathan@jonathan64> on 2010-01-07

Update the build wizard to work with Ubuntu 9.10.

9. By Jonathan Thomas <jonathan@jonathan64> on 2009-09-08

updating the build wizard to support the new re-structured
OpenShot code base.

bumping version to 1.0.7

8. By Jonathan Thomas <jonathan@jonathan64> on 2009-07-24

I've added much better support for 32 bit CPUs, and better
support for Ubuntu 8.04, which lacks a recent version of yasm.

Also, all packages are installed with CheckInstall, so users
can remove any installations caused by this wizard.

7. By Jonathan Thomas <jonathan@jonathan64> on 2009-07-21

I've made lots of changes to the build wizard. It now
uses "checkinstall" to install all of the dependencies,
which makes .deb files for each dependency. All of the
.deb file start with the name "openshot-". They are
listed in Synaptic as local packages, and can be removed
(i.e. uninstalled).

Also, I've made some bug fixes for Ubuntu 8.04, which
should make this wizard work on more computers.

6. By Jonathan Thomas <jonathan@jonathan64> on 2009-07-17

Added the ability to upgrade just the source code of OpenShot,
without having to re-install everything. This will dramatically
speed up users trying to upgrade to the newest version.

And it will prevent them from screwing up their MLT / FFmpeg
installations... once they get it working.

5. By Jonathan Thomas <jonathan@jonathan64> on 2009-06-29

Added x264 project to the Build Wizard. Also added
2 new packages to the install: libfaac-dev and yasm.

Tested with Ubuntu 8.04, 8.10, 9.04

Bumped the version to 1.0.3

If you use ffmpeg option 3, it will add support for
AVCHD (which is mpeg4, h.264, and aac)

4. By Jonathan Thomas <jonathan@jonathan64> on 2009-05-28

Updated the version to 1.0.2.

3. By Jonathan Thomas <jonathan@jonathan64> on 2009-05-28

Added a check to the beginning of the installer to be sure
it is running in a folder named ~/openshot_wizard. This
will prevent many errors.

Also, added some additional error checking, fixed a bug
with the launcher not being created, and improved the
FFmpeg support. FFmpeg support now has 3 options:

1) keep default OS version of FFmpeg
2) Let MLT install a static version of FFmpeg
3) Download the newest GIT version of FFmpeg and replace
   the OS version

2. By Jonathan Thomas <jonathan@jonathan64> on 2009-05-27

Fixed a small bug with creating a launcher at the end of the install script.
Also, added the version number to the output of install script.

1. By Jonathan Thomas <jonathan@jonathan64> on 2009-05-27

Initial checkin of the openshot build wizard. I am very excited about
this program. It should make it easy to install OpenShot on the following
versions of Ubuntu:

1) Ubuntu 8.04
2) Ubuntu 8.10
3) Ubuntu 9.04

This program will download and install all the depenencies, including
MLT, ffmpeg, Frei0r, and many more. It also, creates the Python
bindings, and creates a Launcher on the Desktop of Gnome.

Branch metadata

Branch format:
Branch format 6
Repository format:
Bazaar pack repository format 1 (needs bzr 0.92)
This branch contains Public information 
Everyone can see this information.

Subscribers