Merge lp:~noskcaj/vte/ubuntu into lp:~ubuntu-desktop/vte/ubuntu-vte2.91

Proposed by Jackson Doak on 2016-02-06
Status: Merged
Merge reported by: Tim Lunn
Merged at revision: not available
Proposed branch: lp:~noskcaj/vte/ubuntu
Merge into: lp:~ubuntu-desktop/vte/ubuntu-vte2.91
Diff against target: 234 lines (+79/-16)
9 files modified
debian/changelog (+47/-0)
debian/compat (+1/-1)
debian/control (+8/-3)
debian/control.in (+7/-2)
debian/gir1.2-vte-2.91.install (+1/-1)
debian/libvte-2.91-0.install (+1/-1)
debian/libvte-2.91-0.lintian-overrides (+0/-2)
debian/libvte-2.91-dev.install (+3/-3)
debian/rules (+11/-3)
To merge this branch: bzr merge lp:~noskcaj/vte/ubuntu
Reviewer Review Type Date Requested Status
Tim Lunn 2016-02-06 Needs Fixing on 2016-02-12
Review via email: mp+285283@code.launchpad.net

Description of the change

Merge bugfix release from debian

To post a comment you must log in.
Tim Lunn (darkxst) wrote :

latest debian is now 0.42.4-1, can you update merge to that version

review: Needs Fixing
lp:~noskcaj/vte/ubuntu updated on 2016-02-12
121. By Jackson Doak on 2016-02-12

New upstream release.

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== modified file 'debian/changelog'
2--- debian/changelog 2016-01-04 09:09:44 +0000
3+++ debian/changelog 2016-02-12 07:24:20 +0000
4@@ -1,3 +1,49 @@
5+vte2.91 (0.42.4-1ubuntu1) xenial; urgency=low
6+
7+ * Merge from Debian unstable. Remaining changes:
8+ * debian/control:
9+ - Depend on libgnutls-dev instead of obsolete libgnutls28-dev
10+ * debian/patches/0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
11+ - Keep as it is require for the Ubuntu theming
12+ * debian/patches/91_keep_fds.patch:
13+ - Keep file descriptors open on vte_fork_pty()
14+
15+ -- Jackson Doak <noskcaj@ubuntu.com> Fri, 12 Feb 2016 18:20:17 +1100
16+
17+vte2.91 (0.42.4-1) unstable; urgency=medium
18+
19+ * New upstream release.
20+
21+ -- Andreas Henriksson <andreas@fatal.se> Thu, 11 Feb 2016 20:25:23 +0100
22+
23+vte2.91 (0.42.3-1) unstable; urgency=medium
24+
25+ * New upstream release.
26+
27+ -- Andreas Henriksson <andreas@fatal.se> Wed, 03 Feb 2016 10:56:48 +0100
28+
29+vte2.91 (0.42.1-2ubuntu1) xenial; urgency=low
30+
31+ * Merge from Debian unstable (LP: #1508636). Remaining changes:
32+ * debian/control:
33+ - Depend on libgnutls-dev instead of obsolete libgnutls28-dev
34+ * debian/patches/0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
35+ - Keep as it is require for the Ubuntu theming
36+ * debian/patches/91_keep_fds.patch:
37+ - Keep file descriptors open on vte_fork_pty()
38+
39+ -- Jackson Doak <noskcaj@ubuntu.com> Sun, 20 Dec 2015 07:10:18 +1100
40+
41+vte2.91 (0.42.1-2) unstable; urgency=medium
42+
43+ * Bump debhelper version to 9
44+ * Add multi-arch support (LP: #1508636)
45+ * Remove remaining bits related to gnome-pty-helper
46+ * Pass --as-needed to dh_autoreconf and to the linker to reduce runtime
47+ dependencies
48+
49+ -- Laurent Bigonville <bigon@debian.org> Fri, 13 Nov 2015 15:26:04 +0100
50+
51 vte2.91 (0.42.1-1ubuntu2) xenial; urgency=medium
52
53 * debian/patches/0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
54@@ -1683,3 +1729,4 @@
55 * Initial Release (Closes: #153740)
56
57 -- Christian Marillat <marillat@debian.org> Sun, 21 Jul 2002 16:30:57 +0200
58+
59
60=== modified file 'debian/compat'
61--- debian/compat 2011-05-17 10:19:47 +0000
62+++ debian/compat 2016-02-12 07:24:20 +0000
63@@ -1,1 +1,1 @@
64-8
65+9
66
67=== modified file 'debian/control'
68--- debian/control 2016-01-04 09:09:44 +0000
69+++ debian/control 2016-02-12 07:24:20 +0000
70@@ -7,10 +7,10 @@
71 Priority: optional
72 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
73 XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
74-Uploaders: Andreas Henriksson <andreas@fatal.se>, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Michael Biebl <biebl@debian.org>
75+Uploaders: Andreas Henriksson <andreas@fatal.se>, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Laurent Bigonville <bigon@debian.org>, Michael Biebl <biebl@debian.org>
76 Standards-Version: 3.9.6
77-Build-Depends: cdbs (>= 0.4.90),
78- debhelper (>= 8),
79+Build-Depends: cdbs (>= 0.4.93~),
80+ debhelper (>= 9),
81 gnome-pkg-tools (>= 0.10),
82 dh-autoreconf,
83 libglib2.0-dev (>= 2.40.0),
84@@ -35,6 +35,8 @@
85 Depends: ${misc:Depends},
86 ${shlibs:Depends},
87 libvte-2.91-common (= ${source:Version})
88+Pre-Depends: ${misc:Pre-Depends}
89+Multi-Arch: same
90 Description: Terminal emulator widget for GTK+ 3.0 - runtime files
91 The VTE library provides a terminal emulator widget VteTerminal for
92 applications using the GTK+ toolkit. It also provides the VtePTY object
93@@ -65,6 +67,7 @@
94 Section: introspection
95 Depends: ${gir:Depends},
96 ${misc:Depends}
97+Multi-Arch: same
98 Description: GObject introspection data for the VTE library
99 This package contains introspection data for VTE, a terminal emulator
100 widget for GTK+.
101@@ -86,6 +89,7 @@
102 libvte-2.91-common
103 Recommends: libvte-2.91-doc
104 Conflicts: libvte-2.90-dev
105+Multi-Arch: same
106 Description: Terminal emulator widget for GTK+ 3.0 - development files
107 The VTE library provides a terminal emulator widget VteTerminal for
108 applications using the GTK+ toolkit. It also provides the VtePTY object
109@@ -99,6 +103,7 @@
110 Package: libvte-2.91-common
111 Architecture: all
112 Depends: ${misc:Depends}
113+Multi-Arch: foreign
114 Description: Terminal emulator widget for GTK+ 3.0 - common files
115 The VTE library provides a terminal emulator widget VteTerminal for
116 applications using the GTK+ toolkit. It also provides the VtePTY object
117
118=== modified file 'debian/control.in'
119--- debian/control.in 2016-01-04 09:09:44 +0000
120+++ debian/control.in 2016-02-12 07:24:20 +0000
121@@ -5,8 +5,8 @@
122 XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
123 Uploaders: @GNOME_TEAM@
124 Standards-Version: 3.9.6
125-Build-Depends: cdbs (>= 0.4.90),
126- debhelper (>= 8),
127+Build-Depends: cdbs (>= 0.4.93~),
128+ debhelper (>= 9),
129 gnome-pkg-tools (>= 0.10),
130 dh-autoreconf,
131 libglib2.0-dev (>= 2.40.0),
132@@ -31,6 +31,8 @@
133 Depends: ${misc:Depends},
134 ${shlibs:Depends},
135 libvte-2.91-common (= ${source:Version})
136+Pre-Depends: ${misc:Pre-Depends}
137+Multi-Arch: same
138 Description: Terminal emulator widget for GTK+ 3.0 - runtime files
139 The VTE library provides a terminal emulator widget VteTerminal for
140 applications using the GTK+ toolkit. It also provides the VtePTY object
141@@ -61,6 +63,7 @@
142 Section: introspection
143 Depends: ${gir:Depends},
144 ${misc:Depends}
145+Multi-Arch: same
146 Description: GObject introspection data for the VTE library
147 This package contains introspection data for VTE, a terminal emulator
148 widget for GTK+.
149@@ -82,6 +85,7 @@
150 libvte-2.91-common
151 Recommends: libvte-2.91-doc
152 Conflicts: libvte-2.90-dev
153+Multi-Arch: same
154 Description: Terminal emulator widget for GTK+ 3.0 - development files
155 The VTE library provides a terminal emulator widget VteTerminal for
156 applications using the GTK+ toolkit. It also provides the VtePTY object
157@@ -95,6 +99,7 @@
158 Package: libvte-2.91-common
159 Architecture: all
160 Depends: ${misc:Depends}
161+Multi-Arch: foreign
162 Description: Terminal emulator widget for GTK+ 3.0 - common files
163 The VTE library provides a terminal emulator widget VteTerminal for
164 applications using the GTK+ toolkit. It also provides the VtePTY object
165
166=== modified file 'debian/gir1.2-vte-2.91.install'
167--- debian/gir1.2-vte-2.91.install 2016-01-04 09:09:44 +0000
168+++ debian/gir1.2-vte-2.91.install 2016-02-12 07:24:20 +0000
169@@ -1,1 +1,1 @@
170-usr/lib/girepository-1.0/Vte-2.91.typelib
171+usr/lib/*/girepository-1.0/Vte-2.91.typelib
172
173=== modified file 'debian/libvte-2.91-0.install'
174--- debian/libvte-2.91-0.install 2016-01-04 09:09:44 +0000
175+++ debian/libvte-2.91-0.install 2016-02-12 07:24:20 +0000
176@@ -1,1 +1,1 @@
177-usr/lib/libvte-2.91.so.*
178+usr/lib/*/libvte-2.91.so.*
179
180=== removed file 'debian/libvte-2.91-0.lintian-overrides'
181--- debian/libvte-2.91-0.lintian-overrides 2016-01-04 09:09:44 +0000
182+++ debian/libvte-2.91-0.lintian-overrides 1970-01-01 00:00:00 +0000
183@@ -1,2 +0,0 @@
184-# Setgid on purpose to write the utmp file
185-libvte-2.91-0: setgid-binary usr/lib/libvte-2.91-0/gnome-pty-helper 2755 root/utmp
186
187=== modified file 'debian/libvte-2.91-dev.install'
188--- debian/libvte-2.91-dev.install 2016-01-04 09:09:44 +0000
189+++ debian/libvte-2.91-dev.install 2016-02-12 07:24:20 +0000
190@@ -1,7 +1,7 @@
191 usr/include/vte-2.91
192-usr/lib/pkgconfig/vte-2.91.pc
193-usr/lib/libvte-2.91.a
194-usr/lib/libvte-2.91.so
195+usr/lib/*/pkgconfig/vte-2.91.pc
196+usr/lib/*/libvte-2.91.a
197+usr/lib/*/libvte-2.91.so
198 usr/share/gir-1.0
199 usr/share/glade
200 usr/share/vala/vapi
201
202=== modified file 'debian/rules'
203--- debian/rules 2016-01-04 09:09:44 +0000
204+++ debian/rules 2016-02-12 07:24:20 +0000
205@@ -14,19 +14,27 @@
206 include /usr/share/gnome-pkg-tools/1/rules/uploaders.mk
207 include /usr/share/gnome-pkg-tools/1/rules/gnome-get-source.mk
208
209+DEB_DH_AUTORECONF_ARGS = --as-needed
210+
211+# Ensure at build time that the library has no dependencies on undefined
212+# symbols, and speed up loading.
213+DEB_LDFLAGS_MAINT_APPEND=-Wl,-z,defs -Wl,-O1 -Wl,--as-needed
214+include /usr/share/dpkg/default.mk
215+
216 DEB_CONFIGURE_LIBEXECDIR := \$${prefix}/lib/$(libvte2.91N)
217-DEB_FIXPERMS_EXCLUDE += gnome-pty-helper
218 DEB_DH_MAKESHLIBS_ARGS_$(libvte2.91N) += --add-udeb=$(udeb) -- -c4
219
220 DEB_CONFIGURE_FLAGS_main += \
221- --enable-gnome-pty-helper \
222+ --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
223 --enable-glade-catalogue \
224 --enable-gtk-doc \
225 --enable-introspection \
226 --with-gnutls
227
228+# FIXME: not honoured
229+#DEB_CONFIGURE_EXTRA_FLAGS_main += --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH)
230+
231 DEB_CONFIGURE_FLAGS_udeb += \
232- --disable-gnome-pty-helper \
233 --disable-gtk-doc \
234 --without-gnutls
235

Subscribers

People subscribed via source and target branches

to all changes: