lp:~noskcaj/ubuntu/vivid/xfce4-mpc-plugin/0.4.5

Created by Jackson Doak on 2015-03-05 and last modified on 2015-03-05
Get this branch:
bzr branch lp:~noskcaj/ubuntu/vivid/xfce4-mpc-plugin/0.4.5
Only Jackson Doak can upload to this branch. If you are Jackson Doak please log in for upload directions.

Related bugs

Related blueprints

Branch information

Owner:
Jackson Doak
Status:
Development

Recent revisions

13. By Jackson Doak on 2015-03-05

New upstream bugfix release.

12. By Yves-Alexis Perez on 2014-10-15

[ Evgeni Golov ]
* Correct Vcs-* URLs to point to anonscm.debian.org

[ Yves-Alexis Perez ]
* debian/control:
  - update standards version to 3.9.6.
  - add build-dep on xfce4-dev-tools, automake and libtool.
* debian/rules:
  - run xdt-autogen before configure to regenerate config.{guess,sub} in
    order to gain support for newer architectures. closes: #765270

11. By Yves-Alexis Perez on 2013-05-25

* debian/rules:
  - enable all hardening flags.
* debian/control:
  - update standards version to 3.9.4.
  - drop version on xfce4-panel-dev build-dep, stable has Xfce 4.8 now.
  - drop dpkg-dev build-dep, stable has a recent enough dpkg for hardening
    support.

10. By Yves-Alexis Perez on 2012-06-30

New upstream release.

9. By Yves-Alexis Perez on 2012-05-15

* New upstream release.
* debian/rules:
  - build with --parallel.

8. By Lionel Le Folgoc on 2012-03-03

[ Lionel Le Folgoc ]
* New upstream release.
  - fix non-transparent background with transparent panels. lp: #782540
* debian/rules:
  - use debhelper 9 hardening support.
* debian/compat bumped to 9.
* debian/control:
  - drop hardening-includes build-dep.
  - update debhelper build-dep to 9 for hardening support.
  - add dpkg-dev 1.16.1 build-dep for hardening support.
  - replace libxfcegui4-dev b-dep by libxfce4ui-1-dev.

[ Yves-Alexis Perez ]
* debian/rules:
  - don't install la file.
  - force disable static build.
* debian/control:
  - build-dep on autotools-dev to get rid of outdated autotools files.
  - update standards version to 3.9.3.

7. By Yves-Alexis Perez on 2011-05-06

* New upstream release.
* debian/patches:
  - 01_link-with-libxfcegui4, 02_use-exo-1 dropped, included upstream.
* debian/rules:
  - stop running xdt-autogen
  - switch to dh7 tiny rules
  - pick build flags from dpkg-buildflags.
  - add hardening flags to build flags.
  - add -O1, -z,defs and --as-needed to LDFLAGS.
* debian/control:
  - drop cdbs from build-deps, update debhelper build-dep for overrides.
  - drop xfce4-dev-tools and libtool from build-deps.
  - add build-dep on hardening-includes.
* debian/docs added.

6. By Yves-Alexis Perez on 2011-04-19

[ Yves-Alexis Perez ]
* debian/patches:
  - 01_link-with-libxfcegui4 added, link against libxfcegui4-dev now that
    xfce4-panel won't do it.
* Switch to 3.0 (quilt) source format.
* debian/control:
  - add build-dep on libxfcegui4-dev.
  - add build-dep on xfce4-dev-tools and libtool to run xdt-autogen after
    patching.
  - update standards version to 3.9.2.
* debian/rules:
  - run xdt-autogen after applying patches touching Makefile.am and
    configure.in.

[ Lionel Le Folgoc ]
* debian/rules: clean up autogenerated files changed by xdt-autogen.
* Port to exo 0.5.x:
  - debian/patches/02_use-exo-1.patch: added.
  - debian/patches/series: refreshed.
  - debian/control: change libexo-0.3-dev b-dep to libexo-1-dev.
* debian/control:
  - remove Simon and Emanuele from uploaders, thanks to them.
  - bump xfce4-panel-dev b-dep to (>= 4.8.0).

5. By Lionel Le Folgoc on 2010-05-30

* New upstream release.
* debian/compat: added, can't hurt.
* debian/control: bump Standards-Version to 3.8.4.

4. By Lionel Le Folgoc on 2009-11-30

[ Evgeni Golov ]
* Fix Vcs-* fields, they were missing 'trunk' in the path.

[ Yves-Alexis Perez ]
* debian/watch edited to track Xfce archive reorganisation.
* debian/control:
  - update build-dep on debhelper to 7.
  - remove versioned dependencies on exo and xfce4-panel since all version
    are available since oldstable.
  - add Lionel Le Folgoc to Uploaders.

[ Lionel Le Folgoc ]
* New upstream release.
* debian/patches/01_fix_buffer_overflows.diff: dropped, included upstream.
* debian/control:
  - add new build-deps on libexo-0.3-dev and intltool
  - update standards version to 3.8.3.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/vivid/xfce4-mpc-plugin
This branch contains Public information 
Everyone can see this information.

Subscribers