Merge lp:~noskcaj/gnome-themes-extra/316 into lp:~ubuntu-desktop/gnome-themes-extra/ubuntu

Proposed by Jackson Doak on 2015-06-05
Status: Merged
Merged at revision: 63
Proposed branch: lp:~noskcaj/gnome-themes-extra/316
Merge into: lp:~ubuntu-desktop/gnome-themes-extra/ubuntu
Diff against target: 110 lines (+42/-9)
3 files modified
debian/changelog (+27/-0)
debian/control (+8/-5)
debian/control.in (+7/-4)
To merge this branch: bzr merge lp:~noskcaj/gnome-themes-extra/316
Reviewer Review Type Date Requested Status
Daniel Holbach 2015-06-05 Approve on 2015-06-07
Review via email: mp+261281@code.launchpad.net

Description of the change

Merge 3.16 from debian

To post a comment you must log in.
Daniel Holbach (dholbach) wrote :

Thanks. Uploaded.

review: Approve

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
=== modified file 'debian/changelog'
--- debian/changelog 2014-12-19 21:41:40 +0000
+++ debian/changelog 2015-06-05 20:02:56 +0000
@@ -1,3 +1,30 @@
1gnome-themes-standard (3.16.2-1ubuntu1) wily; urgency=medium
2
3 * Merge from debian. Remaining changes:
4 - debian/control.in:
5 + Have gnome-themes-standard recommend
6 adwaita-icon-theme-full | gnome-icon-theme-full
7 + Depend on adwaita-icon-theme | gnome-icon-theme over adwaita-icon-theme
8 + Use Ubuntu Vcs link
9 - debian/patches/ubuntu_a11y_fallback.patch:
10 + Also have HighContrast inheirit from the Humanity icon theme
11
12 -- Jackson Doak <noskcaj@ubuntu.com> Fri, 05 Jun 2015 19:29:58 +1000
13
14gnome-themes-standard (3.16.2-1) experimental; urgency=medium
15
16 * New upstream release.
17 - Drops the Metacity themes (new versions of both Mutter and Metacity
18 can use the Gtk+ theme for window decorations, in addition the
19 Adwaita and HighContrast themes will be shipped in metacity-common
20 package).
21 - Drops the HighContrast Gtk+ 3 theme (moved into gtk+3.0 itself).
22 * Make gnome-themes-standard-data break pre-3.16 versions of Mutter and
23 Metacity.
24 * Bump Standards-Version to 3.9.6, no changes needed.
25
26 -- Dmitry Shachnev <mitya57@debian.org> Mon, 01 Jun 2015 17:32:27 +0300
27
1gnome-themes-standard (3.14.2.3-0ubuntu1) vivid; urgency=medium28gnome-themes-standard (3.14.2.3-0ubuntu1) vivid; urgency=medium
229
3 * New upstream release. LP: #139904730 * New upstream release. LP: #1399047
431
=== modified file 'debian/control'
--- debian/control 2014-12-19 21:41:40 +0000
+++ debian/control 2015-06-05 20:02:56 +0000
@@ -7,8 +7,8 @@
7Priority: optional7Priority: optional
8Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>8Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
9XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>9XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
10Uploaders: Andreas Henriksson <andreas@fatal.se>, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Emilio Pozuelo Monfort <pochu@debian.org>, Josselin Mouette <joss@debian.org>10Uploaders: Andreas Henriksson <andreas@fatal.se>, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Dmitry Shachnev <mitya57@debian.org>, Emilio Pozuelo Monfort <pochu@debian.org>, Josselin Mouette <joss@debian.org>
11Standards-Version: 3.9.511Standards-Version: 3.9.6
12Build-Depends: debhelper (>= 8.1.3),12Build-Depends: debhelper (>= 8.1.3),
13 gnome-pkg-tools (>= 0.10),13 gnome-pkg-tools (>= 0.10),
14 cdbs (>= 0.4.93~),14 cdbs (>= 0.4.93~),
@@ -32,7 +32,7 @@
32 ${shlibs:Depends}32 ${shlibs:Depends}
33Recommends: gtk2-engines-pixbuf,33Recommends: gtk2-engines-pixbuf,
34 gnome-accessibility-themes,34 gnome-accessibility-themes,
35 gnome-icon-theme-full | adwaita-icon-theme35 adwaita-icon-theme-full | gnome-icon-theme-full
36Breaks: libmutter0 (<< 3.2),36Breaks: libmutter0 (<< 3.2),
37 libgtk2.0-0 (<< 2.24.13)37 libgtk2.0-0 (<< 2.24.13)
38Description: Standard GNOME themes38Description: Standard GNOME themes
@@ -41,9 +41,12 @@
41Package: gnome-themes-standard-data41Package: gnome-themes-standard-data
42Architecture: all42Architecture: all
43Multi-Arch: foreign43Multi-Arch: foreign
44Depends: ${misc:Depends}, gnome-icon-theme | adwaita-icon-theme44Depends: ${misc:Depends}, adwaita-icon-theme | gnome-icon-theme
45Replaces: gnome-themes-standard (<< 3.6.2-1)45Replaces: gnome-themes-standard (<< 3.6.2-1)
46Breaks: gnome-themes-standard (<< 3.6.2-1), libgtk-3-0 (<< 3.13)46Breaks: gnome-themes-standard (<< 3.6.2-1),
47 libgtk-3-0 (<< 3.13),
48 metacity (<< 3.16),
49 mutter (<< 3.15.4)
47Description: Data files for GNOME standard themes50Description: Data files for GNOME standard themes
48 This package contains data files for standard themes for the GNOME51 This package contains data files for standard themes for the GNOME
49 desktop environment.52 desktop environment.
5053
=== modified file 'debian/control.in'
--- debian/control.in 2014-12-19 21:41:40 +0000
+++ debian/control.in 2015-06-05 20:02:56 +0000
@@ -4,7 +4,7 @@
4Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>4Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
5XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>5XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
6Uploaders: @GNOME_TEAM@6Uploaders: @GNOME_TEAM@
7Standards-Version: 3.9.57Standards-Version: 3.9.6
8Build-Depends: debhelper (>= 8.1.3),8Build-Depends: debhelper (>= 8.1.3),
9 gnome-pkg-tools (>= 0.10),9 gnome-pkg-tools (>= 0.10),
10 cdbs (>= 0.4.93~),10 cdbs (>= 0.4.93~),
@@ -28,7 +28,7 @@
28 ${shlibs:Depends}28 ${shlibs:Depends}
29Recommends: gtk2-engines-pixbuf,29Recommends: gtk2-engines-pixbuf,
30 gnome-accessibility-themes,30 gnome-accessibility-themes,
31 gnome-icon-theme-full | adwaita-icon-theme31 adwaita-icon-theme-full | gnome-icon-theme-full
32Breaks: libmutter0 (<< 3.2),32Breaks: libmutter0 (<< 3.2),
33 libgtk2.0-0 (<< 2.24.13)33 libgtk2.0-0 (<< 2.24.13)
34Description: Standard GNOME themes34Description: Standard GNOME themes
@@ -37,9 +37,12 @@
37Package: gnome-themes-standard-data37Package: gnome-themes-standard-data
38Architecture: all38Architecture: all
39Multi-Arch: foreign39Multi-Arch: foreign
40Depends: ${misc:Depends}, gnome-icon-theme | adwaita-icon-theme40Depends: ${misc:Depends}, adwaita-icon-theme | gnome-icon-theme
41Replaces: gnome-themes-standard (<< 3.6.2-1)41Replaces: gnome-themes-standard (<< 3.6.2-1)
42Breaks: gnome-themes-standard (<< 3.6.2-1), libgtk-3-0 (<< 3.13)42Breaks: gnome-themes-standard (<< 3.6.2-1),
43 libgtk-3-0 (<< 3.13),
44 metacity (<< 3.16),
45 mutter (<< 3.15.4)
43Description: Data files for GNOME standard themes46Description: Data files for GNOME standard themes
44 This package contains data files for standard themes for the GNOME47 This package contains data files for standard themes for the GNOME
45 desktop environment.48 desktop environment.

Subscribers

People subscribed via source and target branches

to all changes: