kig

lp:~neon/kig/master

Created by Philip Muškovac on 2011-04-08 and last modified on 2019-11-30
Get this branch:
bzr branch lp:~neon/kig/master

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Deprecated Projected Neon
Project:
kig
Status:
Development

Import details

Import Status: Reviewed

This branch is an import of the HEAD branch of the Git repository at git://anongit.kde.org/kig.

The next import is scheduled to run in 1 hour.

Last successful import was 4 hours ago.

Import started 4 hours ago on alnitak and finished 4 hours ago taking 20 seconds — see the log
Import started 10 hours ago on alnitak and finished 10 hours ago taking 20 seconds — see the log
Import started 16 hours ago on alnitak and finished 16 hours ago taking 20 seconds — see the log
Import started 22 hours ago on izar and finished 22 hours ago taking 15 seconds — see the log
Import started on 2019-12-04 on izar and finished on 2019-12-04 taking 15 seconds — see the log
Import started on 2019-12-04 on alnitak and finished on 2019-12-04 taking 20 seconds — see the log
Import started on 2019-12-04 on alnitak and finished on 2019-12-04 taking 20 seconds — see the log
Import started on 2019-12-03 on izar and finished on 2019-12-03 taking 20 seconds — see the log
Import started on 2019-12-03 on alnitak and finished on 2019-12-03 taking 20 seconds — see the log
Import started on 2019-12-03 on izar and finished on 2019-12-03 taking 15 seconds — see the log

Recent revisions

2495. By David Faure on 2019-11-30

Merge remote-tracking branch 'origin/release/19.12'

2494. By l10n daemon script <email address hidden> on 2019-11-12

GIT_SILENT made messages (after extraction)

2493. By Yuri Chornoivan <email address hidden> on 2019-11-11

Use URLs with transport encryption

2492. By Albert Astals Cid on 2019-11-10

GIT_SILENT Upgrade KDE Applications version to 20.03.70.

2491. By Yuri Chornoivan <email address hidden> on 2019-10-25

Fix warnings "implicitly-declared Rect& Rect::operator=(const Rect&) is deprecated" from GCC 9

Summary:
GCC 9 warns about deprecation of implicit copy ctor:

https://build.kde.org/job/Applications/job/kig/job/kf5-qt5%20SUSEQt5.12/14/warnings30Result/

Test Plan: Compiles on my gcc 8.3.1. GCC 9 is not tested, the solution is stolen from Internet.

Reviewers: #kde_edu, aacid

Reviewed By: aacid

Subscribers: aacid, kde-edu

Tags: #kde_edu

Differential Revision: https://phabricator.kde.org/D24930

2490. By Laurent Montel <email address hidden> on 2019-10-24

GIT_SILENT: it compiles fine without deprecated method

2489. By Yuri Chornoivan <email address hidden> on 2019-10-22

Try to fix Python 3 build

2488. By Laurent Montel <email address hidden> on 2019-09-23

Port deprecated enum

2487. By Albert Astals Cid on 2019-09-21

Goniometry use default provided copy constructor and assignment operator

We had only one (which was doing the same as the default one) but not
the other, that makes newer gcc unhappy when using the non defined one

2486. By Albert Astals Cid on 2019-09-21

Remove unused HierarchyImp::setData

If ever used it would be wrong since the default provided operator= for
ObjectHierarchy would not copy the mnodes properly

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.