lp:~neon/kdnssd/master

Created by Philip Muškovac on 2013-06-06 and last modified on 2019-10-12
Get this branch:
bzr branch lp:~neon/kdnssd/master

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Deprecated Projected Neon
Project:
kdnssd
Status:
Development

Import details

Import Status: Reviewed

This branch is an import of the HEAD branch of the Git repository at git://anongit.kde.org/kdnssd.

The next import is scheduled to run in 3 hours.

Last successful import was 2 hours ago.

Import started 2 hours ago on alnitak and finished 2 hours ago taking 15 seconds — see the log
Import started 8 hours ago on izar and finished 8 hours ago taking 15 seconds — see the log
Import started 14 hours ago on izar and finished 14 hours ago taking 20 seconds — see the log
Import started 20 hours ago on alnitak and finished 20 hours ago taking 15 seconds — see the log
Import started on 2019-10-13 on izar and finished on 2019-10-13 taking 30 seconds — see the log
Import started on 2019-10-13 on alnitak and finished on 2019-10-13 taking 20 seconds — see the log
Import started on 2019-10-12 on alnitak and finished on 2019-10-12 taking 20 seconds — see the log
Import started on 2019-10-12 on izar and finished on 2019-10-12 taking 25 seconds — see the log
Import started on 2019-10-12 on alnitak and finished on 2019-10-12 taking 15 seconds — see the log
Import started on 2019-10-12 on alnitak and finished on 2019-10-12 taking 15 seconds — see the log

Recent revisions

231. By l10n daemon script <email address hidden> on 2019-10-12

GIT_SILENT Upgrade KF5 version to 5.64.0.

230. By Friedrich W. H. Kossebau <email address hidden> on 2019-10-12

Use ECMGenerateExportHeader to manage deprecated API better

Summary:
Allows
* projects linking to KDNSSD to hide deprecated API up to a
  given version or silence deprecation warnings after a given version,
  using
  * -DKDNSSD_DISABLE_DEPRECATED_BEFORE_AND_AT
  * -DKDNSSD_NO_DEPRECATED
  * -DKDNSSD_DEPRECATED_WARNINGS_SINCE
  * -DKDNSSD_NO_DEPRECATED_WARNINGS

  or
  * -DKF_DISABLE_DEPRECATED_BEFORE_AND_AT
  * -DKF_NO_DEPRECATED
  * -DKF_DEPRECATED_WARNINGS_SINCE
  * -DKF_NO_DEPRECATED_WARNINGS
* to build KDNSSD optionally with deprecated API excluded from
  the build, using "EXCLUDE_DEPRECATED_BEFORE_AND_AT" cmake argument.

Test Plan:
Builds with EXCLUDE_DEPRECATED_BEFORE_AND_AT set to 0, 4.0.0,
CURRENT.

229. By l10n daemon script <email address hidden> on 2019-10-06

GIT_SILENT Upgrade ECM and KF5 version requirements for 5.63.0 release.

228. By Friedrich W. H. Kossebau <email address hidden> on 2019-09-16

Use new INCLUDE_DIRS with ecm_add_qch, to have doxygen see more includes

GIT_SILENT

227. By l10n daemon script <email address hidden> on 2019-09-14

GIT_SILENT Upgrade KF5 version to 5.63.0.

226. By l10n daemon script <email address hidden> on 2019-09-07

GIT_SILENT Upgrade ECM and KF5 version requirements for 5.62.0 release.

225. By l10n daemon script <email address hidden> on 2019-08-11

GIT_SILENT Upgrade KF5 version to 5.62.0.

224. By l10n daemon script <email address hidden> on 2019-08-03

GIT_SILENT Upgrade ECM and KF5 version requirements for 5.61.0 release.

223. By Friedrich W. H. Kossebau <email address hidden> on 2019-08-02

Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH

GIT_SILENT

222. By l10n daemon script <email address hidden> on 2019-07-13

GIT_SILENT Upgrade KF5 version to 5.61.0.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.