lp:~myon/+junk/postgresql-8.2

Created by Christoph Berg and last modified
Get this branch:
bzr branch lp:~myon/+junk/postgresql-8.2
Only Christoph Berg can upload to this branch. If you are Christoph Berg please log in for upload directions.

Related bugs

Related blueprints

Branch information

Owner:
Christoph Berg
Status:
Development

Recent revisions

80. By Christoph Berg <email address hidden>

New upstream version.

79. By Christoph Berg <email address hidden>

* New upstream version.
* Backport packaging to 8.2.
* Final 9.1 release.
* 02-relax-sslkey-permscheck.patch, 50-per-version-dirs.patch: Refresh to
  apply cleanly.
* debian/control: Tighten the dependencies of the -pl* extensions/-contrib
  to postgresql-9.1 to the same binary version. (Closes: #640335)
* debian/watch: Fix for mangling ~rc, thanks Peter Eisentraut.
  (Closes: #639357)
* debian/control: Add versionless Provides: to the PL* extensions, as per
  request from Christoph Berg.
* debian/control: Add "Replaces: postgresql-9.0-dbg" to fix file conflict.
  (Closes: #639258)
* debian/control: Drop the versionless metapackages, they are built from
  postgresql-common now. This behaves better with backports. Thanks to
  Christoph Berg for the suggestion.
* debian/control: Build the versionless metapackages again, and point them
  to 9.1.
* New upstream release.
* Upload to unstable now that the final 9.1 release will come soon. 9.1 will
  most probably be the version supported in the Wheezy release.
* 54-debian-alternatives-for-external-tools.patch: Unfuzz for new release.
* debian/control: Suggest locales-all. (Closes: #629875)
* debian/control: Wrap dependencies.
* debian/control: Add explicit jade build dependency. (see #621492 for the
  corresponding 9.0 bug report)
  - Works around gcc 4.6.0 bug. (Closes: #633086)
  Note that this does not change the data format since Beta 2, so no need
  to dump/reload clusters.
* New upstream beta release.
* Drop 03-cmsgcred-size.patch, fixed upstream.
* debian/postgresql-9.1.install: Install new pg_basebackup translations.
* debian/control: Fix the server-dev dependency to p-common to also work for
  backports.
* debian/watch: Fix for beta versions.
* debian/copyright: Add pointers to GPL and Artistic licenses for the Perl
  terms.
* debian/postgresql-9.1.preinst: Fail the package upgrade early when
  upgrading from beta-1, as the DB format changed.
* debian/control: Add postgresql-common dependency to -server-dev, so that
  we get the pg_config diversion.
* 52-tutorial-README.patch: Fix server-dev version in comment.
* 51-default-sockets-in-var.patch: Move the pg_regress patching parts to
  debian/pg_regress-in-tmp.patch and temporarily apply it only for running
  the local checks. In the installed system it seems we actually do want it
  to use the /var/run/postgresql socket dir. (Closes: #554166)
* Move /usr/share/postgresql/9.1/extension/pl* from -contrib into the actual
  -pl* packages, and ship PL/pgsql in postgresql-9.1.
* debian/copyright: Convert to DEP-5.
* debian/copyright: Add current copyrights, thanks to Ansgar Burchardt for
  noticing.
* Add 03-cmsgcred-size.patch: Fix size of struct cmsgcred to fix ident
  authentication on kFreeBSD 64 bit. Thanks to Petr Salinger for the
  patch! (Closes: #627597)
* debian/control: Add missing ${misc:Depends} to -dbg.
* Bump Standards-Version to 3.9.2 (no changes necessary).
* debian/rules: Fix FTBFS with only-binary (-B) builds.
* First 9.1 beta release. Packaging based on 9.1 branch.
* debian/control: Do not build the versionless metapackages for now, as long
  as 9.0 is still the default.

78. By Martin Pitt

release as 8.2.7-2 to unstable

77. By Martin Pitt

* Bump build dependency libpq-dev to a version which depends on libpq5, to
  unbreak backports. Thanks to Gerfried Fuchs! (Closes: #474363)

76. By Martin Pitt

release as 8.2.7-1 to unstable

75. By Martin Pitt

new upstream release 8.2.7

74. By Martin Pitt

* debian/watch: Update for currently working mirror. (Closes: #462823)

73. By Martin Pitt

release as 8.2.6-2 to unstable

72. By Martin Pitt

* Add build dependency libpq-dev, so that dpkg-shlibdeps can find
  libpq.so.5.

71. By Martin Pitt

* Drop the client-side libraries, they are built from postgresql-8.3 now.

Branch metadata

Branch format:
Branch format 5
Repository format:
Bazaar-NG Knit Repository Format 1
This branch contains Public information 
Everyone can see this information.

Subscribers