lp:~mvo/aptdaemon/admin-group-fix

Created by Michael Vogt on 2012-02-28 and last modified on 2012-03-02
Get this branch:
bzr branch lp:~mvo/aptdaemon/admin-group-fix
Only Michael Vogt can upload to this branch. If you are Michael Vogt please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Michael Vogt
Project:
Aptdaemon
Status:
Development

Recent revisions

778. By Michael Vogt on 2012-03-02

skip the test is the user is not in the right group

777. By Michael Vogt on 2012-03-02

ensure mode is 0640 for protected source files

776. By Michael Vogt on 2012-02-28

user the transaction uid to figure out what group to use and add a test

775. By Michael Vogt on 2012-02-28

aptdaemon/worker.py: support both admin (if available) and sudo group

774. By Michael Vogt on 2012-02-28

aptdaemon/worker.py: use root.sudo instead of root.admin as the former is no longer used in ubuntu/debian

773. By Sebastian Heinlein on 2012-02-28

pkcompat: Add a note about the time outs of PK clients prior 0.7.3 (not yet released)

772. By Sebastian Heinlein on 2012-02-28

pkcompat: Completely adapt to the python-apt 0.8 API

771. By Sebastian Heinlein on 2012-02-17

pkcompat: Don't throw an error if we try to cancel a native pk transaction

770. By Sebastian Heinlein on 2012-02-17

Replace some obsolete APT api calls (apt.package.Package.isInstalled)

769. By Martin Pitt on 2012-02-02

Add plugin support to PackageKit compat layer

Support plugins for PackageKit's apt backend, to easily extend the
functionality of "what-provides".

This is a pretty straightforward port of the corresponding commit in
PackageKit:
https://gitorious.org/packagekit/packagekit/commit/b516f18e2

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:aptdaemon
This branch contains Public information 
Everyone can see this information.

Subscribers