lp:~mitya57/kubuntu-packaging/qt-lp1094360

Created by Dmitry Shachnev on 2013-03-13 and last modified on 2013-03-18
Get this branch:
bzr branch lp:~mitya57/kubuntu-packaging/qt-lp1094360
Only Dmitry Shachnev can upload to this branch. If you are Dmitry Shachnev please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Dmitry Shachnev
Project:
kubuntu-packaging
Status:
Merged

Recent revisions

356. By Dmitry Shachnev on 2013-03-18

Fix FTBFS which was caused by moved extract-messages.sh.

355. By Dmitry Shachnev on 2013-03-13

debian/patches/kubuntu_41_remove_gtk_theme_check.diff:
do not check that Gtk theme is not empty (LP: #1094360).

354. By Matthias Klose on 2013-03-13

Fix header file, causing build failure with GCC 4.8.

353. By Philip Muškovac on 2013-02-19

Cherry pick upstream commit 5b285845a3c3478a4008b7e3416c3912c69fd20b
as QTBUG-29082_Fix_call_to_QMetaObject_metaCall_from_updateProperty.patch
to fix a crash in QML to fix kde bug 311751.

352. By Philip Muškovac on 2013-02-19

add missing CVE patches from last upload

351. By Marc Deslauriers on 2013-02-14

* SECURITY UPDATE: incorrect errors with certificate verification
  - debian/patches/CVE-2012-6093.patch: use openssl access functions to
    properly handle layout changes in
    src/network/ssl/qsslsocket_openssl.cpp,
    src/network/ssl/qsslsocket_openssl_symbols.cpp,
    src/network/ssl/qsslsocket_openssl_symbols_p.h.
  - CVE-2012-6093
* SECURITY UPDATE: shared memory segments incorrect permissions
  - debian/patches/CVE-2013-0254.patch: set appropriate permissions in
    src/corelib/kernel/qsharedmemory_unix.cpp,
    src/corelib/kernel/qsystemsemaphore_unix.cpp,
    src/gui/image/qnativeimage.cpp,
    src/gui/image/qpixmap_x11.cpp,
    src/plugins/platforms/xcb/qxcbwindowsurface.cpp,
    src/plugins/platforms/xlib/qxlibwindowsurface.cpp,
    tools/qvfb/qvfbshmem.cpp.
  - CVE-2013-0254

350. By Didier Roche on 2013-02-08

releasing version 4:4.8.4+dfsg-0ubuntu4

349. By Didier Roche on 2013-02-08

* debian/control:
  - change the build-dep order the way around to get previous packages
    depending on libqt4-dev still building. libqt4-dev dep on
    qt4-default | qt-default to ensure at least one version of qmake & co
    is targetted. qt{4,5}-default will provide qt-default.

348. By Didier Roche on 2013-02-08

releasing version 4:4.8.4+dfsg-0ubuntu3

347. By Didier Roche on 2013-02-08

merge Timo's branch to be compatible with qtchooser for Qt4 and Qt5 being co-installable

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers