Merge lp:~milo/linaro-ci-dashboard/refactor-job-schedule into lp:linaro-ci-dashboard
Status: | Merged |
---|---|
Approved by: | Stevan Radaković |
Approved revision: | 31 |
Merged at revision: | 29 |
Proposed branch: | lp:~milo/linaro-ci-dashboard/refactor-job-schedule |
Merge into: | lp:linaro-ci-dashboard |
Diff against target: |
229 lines (+75/-21) 10 files modified
dashboard/frontend/android_build/models/android_loop.py (+0/-5) dashboard/frontend/integration_loop/models/integration_loop.py (+0/-2) dashboard/frontend/integration_loop/templates/integration_loop_detail.html (+1/-1) dashboard/frontend/integration_loop/urls.py (+8/-4) dashboard/frontend/integration_loop/views/integration_loop_build_view.py (+25/-0) dashboard/frontend/kernel_build/models/kernel_loop.py (+1/-7) dashboard/frontend/kernel_build/templates/kernel_loop_detail.html (+2/-2) dashboard/frontend/kernel_build/urls.py (+4/-0) dashboard/frontend/kernel_build/views/kernel_loop_build_view.py (+24/-0) dashboard/frontend/models/loop.py (+10/-0) |
To merge this branch: | bzr merge lp:~milo/linaro-ci-dashboard/refactor-job-schedule |
Related bugs: |
Reviewer | Review Type | Date Requested | Status |
---|---|---|---|
Stevan Radaković | code | Approve | |
Linaro Infrastructure | Pending | ||
Review via email:
|
Description of the change
This, as briefly discussed on a previous merge proposal, is the refactoring of the loops in order for them to really call the correct "schedule_build" method.
Previously, the overridden "schedule_build" was not call, due to the fact that the build is scheduled through a view that was created against the Loop class, and not the actual subclass. The "schedule_build" was in fact called inside the LoopBuildView class as "self.object.
The solution is to create personalized "build views" for each loop, inheriting from LoopBuildView, defining also the correct URL path and removing the "schedule_build" from inside each subclass, as long as they do not need to specialize it.
The proposed merge fixes all these.
Tnx for taking care of this Milo.
Good code.
Approve +1