lp:~micahg/gnome-python-extras/maverick

Created by Micah Gersten on 2011-01-07 and last modified on 2011-01-07
Get this branch:
bzr branch lp:~micahg/gnome-python-extras/maverick
Only Micah Gersten can upload to this branch. If you are Micah Gersten please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Micah Gersten
Project:
Gnome Python Extras
Status:
Development

Recent revisions

21. By Micah Gersten on 2011-01-07

* Have dh_xulrunner install a dependency on xulrunner for python-gtkmozembed
  again (LP: #695728)
  - update debian/rules

20. By Chris Coulson on 2010-11-25

releasing version 2.25.3-5ubuntu2

19. By Robert Ancell on 2010-06-11

* Merge with Debian unstable, remaining Ubuntu changes:
* debian/control:
  - Build-depends on gnome-common
  - Bump build-depends on python-gnome2-dev
  - Add Vcs-Bzr URL.
  - Remove stray comma from python-gtkmozembed depends
* debian/rules:
  - Run autotools on build
* debian/patches/04_use_PYTHON-config_check.patch:
  - Use python-config.
* debian/patches/70_autotools.patch:
  - Dropped, autotools now run on build

18. By Chris Coulson on 2010-03-10

releasing version 2.25.3-4.1ubuntu3

17. By Chris Coulson on 2010-03-10

Merge in the changes already in the archive. There was already a 2.25.3-4.1ubuntu2 release

16. By Chris Coulson on 2010-03-10

releasing version 2.25.3-4.1ubuntu2

15. By Chris Coulson on 2010-03-10

* Ensure that the 1.9.2 GRE is loaded and also make sure that
  it works correctly by calling gtk_moz_embed_push_startup when
  the module is loaded
  - Update debian/patches/01_xul19.patch

14. By Chris Coulson on 2010-03-10

* debian/control:
  - Bump xulrunner depends and build-depends to xulrunner-1.9.2
* Automatically add correct xulrunner binary depends:
  - debian/rules: Call dh_xulrunner
  - debian/control: Don't specify explicit binary depends on
    xulrunner

13. By Chris Coulson on 2009-12-15

releasing version 2.25.3-4.1ubuntu1

12. By Chris Coulson on 2009-12-15

* Sync on Debian unstable.
* debian/control:
  - Add Vcs-Bzr URL.
  - Build-dep on python-all-dbg for debug packages,
    python-gnome2-dev (>= 2.22.3-0ubuntu3), xvfb and libgl1-mesa-dri.
  - Add python-gnome2-extras-dbg package.
  - Add explicit xulrunner-1.9.1 dependency on python-gtkmozembed,
    as there is no dh_xulrunner to populate this.
* debian/rules:
  - dbg-* targets and tricks.
  - Move dh_pysupport call and use xvfb.
  - Don't call dh_xulrunner, as this doesn't seem to exist in
    Ubuntu yet.
* Adapt python-gda.install, python-gtkhtml2.install,
  python-eggtrayicon.install to python 2.6 new package layout.
* debian/patches/01_xul19.patch:
  - Add AC_PROG_CXX because you can't push C++ tests before detecting it.
* debian/patches/04_use_PYTHON-config_check.patch:
  - Use python-config.
* Regenerate debian/patches/70_autotools.patch.

* Non-maintainer upload for transition to xulrunner 1.9.1.
  (Closes: #548676)
* debian/rules: Use dh_xulrunner.
* debian/control, debian/control.in:
  - Build-depend on a xulrunner-dev that provides dh_xulrunner.
  - Let dh_xulrunner fill shlibs:Depends with the proper xulrunner
    dependency.
* debian/patches/01_xul19.patch: Tighten the GREVersionRange.
* 04_gdl_2.28.patch: stolen from upstream. Port to GDL 2.28.
  Closes: #549748.
* 70_autotools.patch: regenerated.
* Update build-dependencies accordingly.
* 05_gdl_2.28_more.patch: remove a pair of symbols that were forgotten
  upstream.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers