lp:~medibuntu-maintainers/mplayer/medibuntu.maverick

Created by Gauvain Pocentek and last modified
Get this branch:
bzr branch lp:~medibuntu-maintainers/mplayer/medibuntu.maverick
Members of Medibuntu Packaging Team can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Medibuntu Packaging Team
Project:
MPlayer
Status:
Development

Recent revisions

72. By Gauvain Pocentek <gauvain@images> on 2010-09-25

release 2:1.0~rc4~try1.dsfg1-1ubuntu1+medibuntu1 for maverick

71. By Gauvain Pocentek <gauvain@images> on 2010-09-25

Add myself to uploaders

70. By Gauvain Pocentek <gauvain@images> on 2010-09-25

* Merge from Ubuntu:
  - put back faac support
  - recommends apport-hooks-medibuntu
  - change Maintainer, Uploaders & Vcs-* fields.
* merge from debian, remaining changes:
  - build depend against, lame, x264, xvid
* debian/patches/60eval-api.patch, backport patch from upstream to
  unbreak compilation for eval.h move not yet in 0.6
* gmplayer is gone now, please see smplayer as alternative frontend.
  LP: #503537, #493088, #467534, #467524, #460326, #390399, #285570,
      #208680, #118709, #513065, #459595, #455913, #179918, #65165.
* enable the mencoder package
* sort build depends alphabetically
* enable dvdnav support, Closes: #582508, #488226, LP: #611749
* prepare new upload
* no longer build mplayer-gui, it doesn't build anymore with shared
  swscale
* merge from debian/experimental, remaining changes:
  - build depend against, lame, x264, xvid
  - enable mencoder and mplayer-gui
* ensure that quilt patches are actually applied
* New Upstream Version, LP: #539315
* Build (against) again the System FFmpeg
* tighten dependency on FFmpeg 0.6
* remove patches merged upstream
* remove 22disable-xscreensaver.patch
* refresh patches
* readd x264, xvid and mp3lame support, LP: #606125
* remove old parallel building mechanism, fixes FTBFS
* New upstream version
* compile against internal ffmpeg for now, LP: #587203, #588097
* recompile for directfb transtion, LP: #587163
* remove patches that were merged upstream
* avoid removing DOCS/html directory. it is included in release
  tarball
* convert to source Format: 3.0 (quilt)
* refreshed patches
* remove files that are included in upstream tarball
* rework debian/rules file
  - support parallel building
  - merge build rules for mplayer and mencoder package
  - remove unreferenced COMMON_CONFIGURE_FLAGS macro
  - rename DEB_BUILD_CONFIGURE -> CONFIGURE_FLAGS
  - don't build documentation - release tarballs have them prebuilt
  - build HTML documentation only if not already avaiable in the build
    tree
  - remove remaining references to debian/strip.sh from debian/rules
* remove copied vdpau headers
* copy in mencoder.c from upstream
* enable mplayer-gui (Closes: #579925) and mencoder packages.
  (Closes: #396954, #400940, #580168)
* Fix rtsp vulnerability. Patch applied by DSA. Closes: #581245
* Fix another integer overflow, Closes: #524805
* prepare new upload
* sync libao2/ao_pulse.c with svn r30062, Closes: #558196, #580113
* make configure use pkg-config for fribidi checks. Closes: #582784,
  LP: #556200
* document 23mplayer-debug-printf.patch
* avoid mentioning of GTK frontend in mplayer description
* improve package descriptions of mplayer-doc and mplayer-dbg
* medium urgency because of fixed security issue
* fix SVN_VERION regex in debian rules to unbreak get-orig-source
  target. Closes: #582369
* forcefully disable arts support. Closes: #581225
* Remove mencoder from Depends in mplayer-dbg package.
* new upstream snapshot from rc3 branch.
* remove patches applied upstream:

  - 24_enable_fontconfig_by_default.diff
  - 30_add_gmplayer_man_rules.diff
  - 40_improve_desktop_file.patch
  - 41_fix_forcedsubsonly.patch
  - 50_fix_crashes_with_invalid_SDPs.patch
  - 50_fix_initial_volume_setting_pulse_output.patch
  - 61-malloc-bsd.patch
  - 62-disable-vidix-on-kfreebsd-amd64.patch
  - 63-sys-kd-include.patch
* don't install apport hook
* gross hack to avoid building mplayer-nogui and mplayer-gui packages
* add md5sum to remove to avoid spurious conffile prompt, Closes: #568272
* Make mplayer build on kFreeBSD (backports from upstream), Closes: #578622
  - Revert obscure hack that disables the malloc.h check on certain BSD
    platforms.
  - disable vidix on kFreeBSD-amd64
  - rename 'struct keypad' -> 'struct m_keypad' to avoid FTBFS on
    kFreeBSD/amd64
* enable fontconfig by default. (Closes: #573257)

69. By Lionel Le Folgoc on 2010-04-23

releasing version 2:1.0~rc3+svn20090426-1ubuntu16+medibuntu1

68. By Lionel Le Folgoc on 2010-04-23

oops, typo

67. By Lionel Le Folgoc on 2010-04-23

* Merge from Ubuntu:
  - put back faac support
  - recommends apport-hooks-medibuntu
  - change Maintainer, Uploaders & Vcs-* fields.

66. By Reinhard Tartler on 2010-03-31

* move config file and apport hook 'mplayer-nogui'->'mplayer'
  LP: #540491, #549613
* improve mplayer version output
* no longer build depend on libfaac, see LP #374900 for details
* attach alsa_information in the apport hook

65. By Reinhard Tartler on 2010-03-17

backport newer libx264 wrapper, LP: #539555

64. By Reinhard Tartler on 2010-03-11

* cleanup --configure flags
* drop VDPAU build hacks, Closes: #566868, LP: #530481, #532007
* enable musepack support
* enable libaa support, LP: #502767, #455535
* enable enca support, LP: #115519
* remove DEB_BUILD_CONFIGURE override hack
* fix weird permission bits for mplayer.desktop and mplayer.xpm
* reorganize binary packages to no longer install the gui version by
  default
* refactor debian/rules to avoid sub makes
* add patch to allow compilation with newer x264
* use mp_msg instead of printf in debug help message
* bump standards version
* as no longer used, remove dependencies on debconf
* Fix possible crashes with invalid SDPs, LP: #519579
* add missing replaces
* install manpages in the 'mplayer' package. and only there

63. By Reinhard Tartler on 2010-01-19

rebuild for ffmpeg versioned symbols

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.