lp:~medibuntu-maintainers/libav/medibuntu.quantal

Created by Gauvain Pocentek on 2012-10-07 and last modified on 2013-05-02
Get this branch:
bzr branch lp:~medibuntu-maintainers/libav/medibuntu.quantal
Members of Medibuntu Packaging Team can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Medibuntu Packaging Team
Project:
libav
Status:
Development

Recent revisions

18. By Gauvain Pocentek on 2013-05-02

* Merge with ubuntu:
* debian/control:
  - update maintainer and uploaders
  - use our addresses in Vcs-* fields
  - build-depends on libfaac-dev
  - recommends apport-hooks-medibuntu for lib*-extra-* to catch all bug
    reports.
* Rebuild against new libav
  - debian/control: bump Build-Depends

17. By Gauvain Pocentek on 2013-05-02

* Merge with ubuntu:
* debian/control:
  - update maintainer and uploaders
  - use our addresses in Vcs-* fields
  - build-depends on libfaac-dev
  - recommends apport-hooks-medibuntu for lib*-extra-* to catch all bug
    reports.
* Rebuild against new libav
  - debian/control: bump Build-Depends

16. By Gauvain Pocentek on 2012-11-18

fix distro target

15. By Gauvain Pocentek on 2012-11-18

* Merge with ubuntu:
* debian/control:
  - update maintainer and uploaders
  - use our addresses in Vcs-* fields
  - build-depends on libfaac-dev
  - recommends apport-hooks-medibuntu for lib*-extra-* to catch all bug
    reports.
* Rebuild against libav security update

14. By Gauvain Pocentek on 2012-10-07

* Merge with ubuntu:
* debian/control:
  - update maintainer and uploaders
  - use our addresses in Vcs-* fields
  - build-depends on libfaac-dev
  - recommends apport-hooks-medibuntu for lib*-extra-* to catch all bug
    reports.
* Merge from 'libav' package in main.
  - build against dirac, libopenjpeg, x264, mp3lame, librtmp and xvidcore,
    opencv, opencore (for AMR wb&nb and vo-aacenc)
* Merge from debian, remaining changes:
  - don't build against libdirac, lame, libopenjpeg, librtmp, frei0r,
    vo-aacenc, vo-amrenc, x264, and xvid (all in universe)
  - do not build libav-extra-dbg, it is build from the libav-extra source
    package in ubuntu.
  - drop libav-regular-dbg, not necessary in ubuntu
  - Adjust LIB_PKGS/LIB_PKGS2 lists in debian/rules
  - several ifdefs in debian/rules that allow the use of the same file
    in libav and libav-extra (most of this can be merged into the debian
    package)
  - several dependency fixups in debian/control
* Clarify the changes in the 6:0.8.3-5 upload, as discussed in bug
  #683247.
* Make ffmpeg-dbg 'arch: all' for consistency with the libav-extra-dbg
  package.
* Fix generation of shlibs file. (Closes: #679542)
  Wrong make variables where used for the shlibs generation.

* Bug fix: "Multi-Arch: foreign libraries", thanks to Stepan Golosunov.
  Make the transitional libavfoo-extra-NN packages 'arch: all' and
  remove the 'Multi-Arch: foreign' fields to avoid that the dependency
  can be satisfied by packages of other architectures, which would break
  applications. Closes: #680613
* Make libav-extra-dbg 'arch: all'. As empty, transitional package
  without strict dependencies, we can safely ship it as arch:all
  package.
* Mention qt-faststart in the long description (Closes: #681491).
* Install all debug symbols into libav-dbg (Closes: #680602).
* Do not run doxygen if it is not installed. This does not change anything
  for regular builds, but helps with bootstrapping the package to new
  architectures that may not have doxygen available yet.
* Fix up debian/changelog and tighten dependencies.
* Do not declare "ffmpeg" as virtual package (provided by libav-tools).
  Instead, we provide it as transitional package for libav-tools. Note
  the next upstream version will no longer provide neither an 'ffmpeg'
  package, nor a /usr/bin/ffmpeg binary. This means that front-end
  applications in Debian that previously used this binary needs to be
  ported to /usr/bin/avconv for jessie.
* Declare a 'Breaks' relationship against mplayer, Closes: #671934
* Install the shared flavor last; the binaries from the optimized flavor(s)
  would overwrite the ones from the shared baseline flavor causing SIGILL;
  closes: #657885.
* control/Uploaders: update my email address
* Clarify relations between libavcodec53 and libavcodec-extra-53
  in debian/control.
* Use the cond_enable() macro for all additional features in debian/confflags.
* Tidy up and sort configuration flags.
* Add a debian/README.source file that describes how to rebuild libav
  with a reduced feature set in order to avoid circular build-dependencies
  for bootstrapping.
* Restrict Build-Depends to "yasm [any-amd64 any-i386]"
  and explicitly disable it if not found.
* add patch from upstream to fix playback of Canon AVHCD movies.
  (Fixes: LP: #937561)
* fix location in ffmpeg.NEWS file
* add dependency on libavcodec53 to libav-dbg
* add Pre-Depend on dpkg to libav-tools to ensure smooth updates
* {ffmpeg,libav-tools}.install: make files to install more explicit
* Update libav-doc doc base. (Closes: #674139)
* New upstream release 0.8.3:
  - Several bugs and crashes have been fixed in the following codecs: PNG,
    Electronic Arts TQI, H.264 (CVE-2012-0851) and H.263 (CVE-2011-3937)
* Raising severity because of security issues.
* Revert "temporarily disable opencv to work around dependency troubles"
* Simplify internal dependencies (Closes: #672791)
* New upstream release:
  - Several bugs and crashes have been fixed in the following codecs: AAC,
    APE, H.263, H.264, Indeo 4, Mimic, MJPEG, Motion Pixels Video, RAW,
    TTA, VC1, VQA, WMA Voice, vqavideo (CVE-2012-0947).
  - Several bugs and crashes have been fixed in the following formats:
    ASF, ID3v2, MOV, xWMA
  - This release additionally updates the following codecs to the
    bytestream2 API, and therefore benefit from additional overflow
    checks: truemotion2, utvideo, vqavideo
* drop 02-fix-avpreset-extension.patch, applied upstream
* Revert "Revert "temporarily disable opencv to work around dependency
         troubles"" (Closes: #671302)
* Bumped urgency because of security issue.
* Fix build for hurd. Thanks to Samuel Thibault for patch. (Closes: #613034)
  (Closes: #671038)
* Properly migrate /etc/ffserver.conf to /etc/avserver.conf.
  (Closes: #660786)
* Renable opencv support.
* Fix epoch in strict internal dependencies. Closes: #670861
* Temporarily disable opencv to work around dependency trouble
* Fix issue with file not being multiarch compatible. (Closes: #669988)
* Bump epoch to fix messed upload to unstable (Closes: #670762)
* Use a Provides field to provide transitional packages instead of Conflicts.
  (Closes: #666401)
* Have both libavcodec and libavcodec-extra package conflict with each other.
* Separate the ffmpeg program into the transitional package.
* Change ffmpeg warning so that it's clearer the program is
  deprecated (LP: #939863)
* Merge libav-extra packages to libav. (Closes: #658084)
* Provide only libavcodec-extra package, the other packages are unnecessary.
* Remove libav-source package. No longer necessary.
* Remove dependencies and suggests of FAAD, no longer needed.
* Set Enhances field and update package description for libavcodec-extra
  package. (Closes: #653451)
* Fix issue with installation of debug symbols. (Closes: #642798)
* Mention license impact in libavcodec-extra-53's package description.
* merge from 'main' package. Changes:
  - build against dirac, libopenjpeg, x264, mp3lame, librtmp and xvidcore,
    opencv, opencore (for AMR wb&nb),
* debian/patches/05-H264-AVCodecContext-cropping.patch: Added patch from
  Måns Rullgård to fix H264 video size from Canon DSLR cameras (LP: #937561)
* debian/control:
  - Prefer libtiff5-dev
* New Upstream releases:
    + version 0.8.3:
      - Several bugs and crashes have been fixed in the following codecs: PNG,
        Electronic Arts TQI, H.264 (CVE-2012-0851) and H.263 (CVE-2011-3937)
    + version 0.8.2:
      - Several bugs and crashes have been fixed in the following codecs: AAC,
        APE, H.263, H.264, Indeo 4, Mimic, MJPEG, Motion Pixels Video, RAW,
        TTA, VC1, VQA, WMA Voice, vqavideo (CVE-2012-0947). LP: #980963
      - Several bugs and crashes have been fixed in the following formats:
        ASF, ID3v2, MOV, xWMA
      - This release additionally updates the following codecs to the
        bytestream2 API, and therefore benefit from additional overflow
        checks: truemotion2, utvideo, vqavideo
* libav-tools: add pre-depends on dpkg
* ffmpeg: update Conflict/Replaces relationships

* debian/ffmpeg.install and debian/libav-tools.install:
  - Moved all ffmpeg binaries and manpages to ffmpeg package (LP: #1011136)

* Bump shlibs (Closes: #662793)
* force upgrades of older libavcodec-extra-53 packages
* drop all post-0.8 patches, applied upstream
* bump standards version, no changes needed
* Imported Upstream version 0.8.1
* Bumped urgency to medium because of included security fixes:
  CVE-2012-0848, CVE-2012-0853, CVE-2012-0858, CVE-2011-3929,
  CVE-2011-3936, CVE-2011-3937, CVE-2011-3940, CVE-2011-3945,
  CVE-2011-3947, CVE-2011-3951, CVE-2011-3952
* Enable frei0r support.
* Enable tls support through gnutls.
* Enable libcdio support.
* Enable opencv support.
* Enable pulse support.
* Enable vaapi for all architectures.
* Install manpage for qt-faststart in the correct package.
* bump standards version, no changes needed
* Remove dependencies and suggests of FAAD, no longer needed.
* Enable frei0r support.
* drop build-dep on frei0r-plugins-dev
* Enable tls support through gnutls.
* Enable libcdio support.
* Enable opencv support.
* drop build-dep on libcv-dev and libopencv-dev
* Enable pulse support.
* Include conditional enablers for vo-aacenc and vo-amrwbenc.
* Update comment about GPLv3 features.
* Make clear that is FAAC that's considered non-free, not AAC.
* Enable jack support for all architectures.
* Enable hardened build flags through dpkg-buildflags (Closes: #658929).
* Filter out system-wide setting of -Bsymbolic-functions to avoid FTBFS.
* Set CPPFLAGS separately.
* Don't override -g or -O3 flags set by libav's build system.
* confflags: use --enable-pic instead of manually messing with cflags
* Separate the ffmpeg program into the transitional package.
* Add NEWS entry for ffmpeg deprecation.
* add conflicts/replaces for ffmpeg transitional package
* Properly migrate /etc/ffserver.conf to /etc/avserver.conf. (Closes: #660786)
* Don't ignore errors in maintainer scripts.
* Fix build for hurd. Thanks to Samuel Thibault for patch.
* Cherry pick the mentioned changes above to the ubuntu branch
* Update warning to make clearer the deprecation of ffmpeg binary.
  (LP: #939863)
* New upstream bug and security fix release (FFe: LP: #960949)
  - fixes the following CVEs:
    CVE-2012-0848, CVE-2012-0853, CVE-2012-0858, CVE-2011-3929,
    CVE-2011-3936, CVE-2011-3937, CVE-2011-3940, CVE-2011-3945,
    CVE-2011-3947, CVE-2011-3951, CVE-2011-3952
* Pull fix from Debian git to fix installation of avserver.conf and
  recordshow.sh into libav-tools; Thanks to Julien Cristau for spotting this!
  - update debian/rules
* confflags: use --enable-pic instead of manually messing with cflags
* Import post 0.8 patches
* Bugfix: expects wrong preset file extension (Closes: #660978)
  Thanks to Laurento <email address hidden> for spotting this.
* Fix maintainer's name.
* Enable hardened build flags through dpkg-buildflags (Closes: #658929).
* Fix format string vulnerability detected by -Wformat-security.
* Filter out system-wide setting of -Bsymbolic-functions to avoid FTBFS.
* Set CPPFLAGS separately.
* No-change rebuild to pick libvpx's new shlibs. (LP: #926580)
* Merge from debian, remaining changes:
  - don't build against libdirac, lame, libopenjpeg, librtmp,
    x264, and xvid (all in universe)
* Remove the last remainders of explicit quilt usage in
  pre-3.0 source formats.
* Urgency bumped to medium because of RC bugs and unfixed security
  issues in testing.
* Imported Upstream version 0.8
  - Bug fix: "Segfaults when using vaapi", thanks to Andrey Rahmatullin
    (Closes: #656572). That crash is most likely caused by auto-enabling
    multi-threading. This behavior got reverted just before this release.
* Drop post-0.8b2 patches
* Bump shlibs for addition of new audio encoding API
* Extend package descriptions to include a note what libav actually is
* debian/watch: fix mangling of '_' characters.
* drop unused lintian override in debian/control
* provide compatibility links for ffserver, ffplay and ffprobe
  (Closes: #655683)
* Merge from debian, remaining changes:
  - don't build against libdirac, lame, libopenjpeg, librtmp,
    x264, and xvid (all in universe)
* Fix debian/*.install file generation on archs (e.g. armel) that build
  more than only one optimized shared library (Closes: #656184).
* add additional post-0.8b2 patches
* Properly set the library paths for multiarch and shared libs in
  debian/*.install instead of using brace expansion and asterisks.
* Fix upgrade path from earlier versions of the 'ffmpeg' package
  (Closes: #655917)
* Sync post v0.8b2 commits
* extend package description to include a note what libav actuall is
* place transitional packages in oldlibs/extra section to assist package
  managers
* drop unused lintian override in debian/control
* Merge from debian, remaining changes:
  - don't build against libdirac, lame, libopenjpeg, librtmp,
    x264, and xvid (all in universe)
* New Upstream version 0.8~beta2:
  - Confirm that this release does not inhibit the following security issues:
    - DoS in MKV demuxer,
      - CVE-2011-3893, Closes: #654572
    - Double free vuln in the Theora decoder,
      - CVE-2011-3892, Closes: #654571
    - heap-based buffer overflow in vorbis decoder:
      - CVE-2011-3895, Closes: #654573
    - Closes: #654534
  - Bug fix: "libswscale crashes when upscaling pictures using
    hyscale_fast2, MMX variant on amd64 with gcc-4.6 and later",
    thanks to Harald Dunkel (Closes: #647824).
  - Clarify that libavutil/avutil.h doesn't include mathematics.h any more in
    APIchanges documentation. Thanks: Jonathan Nieder <email address hidden>,
    Closes: #654303
* Disable configuration mismatch warnings (Closes: #619530)
* Rename package libav to libav-tools (Closes: #654984)
* Refresh patches
* fix build failures by dropping unnecessary configure flags
* New upstream release.
  - too many changes to list, please refer to upstream's Changelog file
  for details
* Merge from debian, remaining changes:
  - don't build against libdirac, lame, libopenjpeg, librtmp,
    x264, and xvid (all in universe)
* Install libraries in multi-arch directories.
* forcefully disable v4l on kfreebsd, fixes an FTBFS on kFreeBSD
* New upstream version. Includes fixes for:
   - VP3 decoder (CVE-2011-4352)
   - svq1 decoder (CVE-2011-4579)
   - DoS in the VP5/VP6 decoders (CVE-2011-4353)
   - QDM2 decoder (CVE-2011-4351)
   - Sierra VMD decoder (CVE-2011-4364)
* Bumped urgency.
* Enable drawtext filter (Closes: #647132)
* Imported Upstream version 0.7.3
* Bump shlibs for backported avcodec_open2() API
* Merge from debian, remaining changes:
  - don't build against libfaad, libdirac, librtmp and libopenjpeg,
    lame, xvid, x264 (all in universe)
  - not installing into multiarch directories
* This new upstream release has basically merged in all 70 patches that
  are present in 4:0.7.1-7ubuntu2, plus some additional, similarily
  focused ones.
* New upstream release: 0.7.2
  - Security focused release
  - Includes Matroska reallocation checks, Closes: #643859
* Drop all post 0.7.1 patches, included upstream.
* Revert "Convert package to include multiarch support."
* Merge from debian/unstable
  - don't build against libfaad, libdirac, librtmp and libopenjpeg,
    lame, xvid, x264 (all in universe)
  - Introduces Security fix for CVE-2011-3362
  - Fixes LP: #835903
* post-0.7.1/0070-Fix-memory-re-allocation-in-matroskadec.c-related-to.patch:
  - fix memory (re)allocation in matroskadec.c, related to MSVR-11-0080

* Add 63 (!) additional post 0.7.1 patches
  - all scheduled for next upstream point release
  - Fix missing CAVS boundary checks, Closes: #641478, Fixes: CVE-2011-3362
* Medium urgency for fixing a security issue
* Drop debian/patches/03-fix-movrel.patch, better patch upstream
* prefer libtiff4 over libtiff5 for now
* Convert package to include multiarch support.
* sync patches with upstream release branch
* Fix segmentation fault on ppc32, Closes: #639948
* upload to unstable

* Merge from debian/unstable
  - don't build against libfaad, libdirac, librtmp and libopenjpeg,
    lame, xvid, x264 (all in universe)
* Drop extra conflicts on libswscale-extra-1
* add post 0.7.1 patches
* make MAP_ANONYMOUS available on Linux and the Hurd, Closes: #637516
* libpostproc: filter name needs to be double 0 terminated
* relax dependencies in the shlibs file to accomodate
  the new versioning scheme in libav-extra. Fixes LP: #818619
* libswscale-dev: fix alternate on libswscale-extra-2, Fixes LP: #829857
* Build against libx264. Closes: #418228, #440681
* Build against libmp3lame, Closes: #587904
* Build against xvidcore to enable xvid encoding
* use yasm on every architecture. Should allow building on the Hurd
* libswscale-dev: fix alternate on libswscale-extra-2, Fixes LP: #829857
* relax dependencies in the shlibs file to accomodate the new versioning
  scheme in libav-extra. Fixes LP: #818619
* Merge from debian/unstable
  - don't build against libfaad, libdirac, librtmp and libopenjpeg
    (all in universe)
  - Extra conflicts on libswscale-extra-1 (can be dropped after natty release)
* Update to my @debian.org email.
* Pass --arch to configure
* no longer generate 'snapshot_version'
* disable jackd output support on the hurd
* Use proper architecture wildcards for Linux-only dependencies,
  Closes: #634460
* Drop "backported patches"
* Imported Upstream version 0.7.1
* Fix installation of codecs.txt and formats.txt
* libavformat-dev depends on libavutil-dev
* Add backported patches for 0.7.1

13. By Gauvain Pocentek on 2012-06-29

* Merge with ubuntu:
* debian/control:
  - update maintainer and uploaders
  - use our addresses in Vcs-* fields
  - build-depends on libfaac-dev, libopencore-amrnb-dev and
    libopencore-amrwb-dev to add aac encoding and amr support (LP: #490227)
  - recommends apport-hooks-medibuntu for lib*-extra-* to catch all bug
    reports.
* debian/confflags:
  - explicitly enable AMR-NB and AMR-WB support with
    --enable-libopencore-amrnb, --enable-libopencore-amrwb and
    --enable-version3
* Rebuild against libav security update

12. By Gauvain Pocentek on 2012-03-30

* Merge with ubuntu:
* debian/control:
  - update maintainer and uploaders
  - use our addresses in Vcs-* fields
  - build-depends on libfaac-dev, libopencore-amrnb-dev and
    libopencore-amrwb-dev to add aac encoding and amr support (LP: #490227)
  - recommends apport-hooks-medibuntu for lib*-extra-* to catch all bug
    reports.
* debian/confflags:
  - explicitly enable AMR-NB and AMR-WB support with
    --enable-libopencore-amrnb, --enable-libopencore-amrwb and
    --enable-version3
* New upstream libav bug and security fix release (FFe: LP: #960949)
  - fixes the following CVEs:
    CVE-2012-0848, CVE-2012-0853, CVE-2012-0858, CVE-2011-3929,
    CVE-2011-3936, CVE-2011-3937, CVE-2011-3940, CVE-2011-3945,
    CVE-2011-3947, CVE-2011-3951, CVE-2011-3952
* Bump dependency on libav-source to >= 4:0.8.1 for new upstream version
  - update debian/control

11. By Gauvain Pocentek on 2012-03-06

fix VCS URLs

10. By Gauvain Pocentek on 2012-03-06

restore lost multiarch settings lost during merge

9. By Gauvain Pocentek on 2012-03-06

* Merge with ubuntu:
* debian/control:
  - update maintainer and uploaders
  - use our addresses in Vcs-* fields
  - build-depends on libfaac-dev, libopencore-amrnb-dev and
    libopencore-amrwb-dev to add aac encoding and amr support (LP: #490227)
  - recommends apport-hooks-medibuntu for lib*-extra-* to catch all bug
    reports.
* debian/confflags:
  - explicitly enable AMR-NB and AMR-WB support with
    --enable-libopencore-amrnb, --enable-libopencore-amrwb and
    --enable-version3
* No-change rebuild to pick libvpx's new shlib. (LP: #926580)
* Properly set the library paths for multiarch and shared libs in
  debian/*.install instead of using brace expansion and asterisks.
* Fix debian/*.install file generation on archs (e.g. armel) that build
  more than only one optimized shared library (Closes: #656184).
* Add breaks on old mplayer versions (Closes: #657326)
* extend package description to include a note what libav actually is
* Urgency medium because new upstream releases fixes security issues
* Rebuild against libav 0.8
* Tighten build dependency on libav-source (>= 0.8-1~)
* Enable drawtext filter (Closes: #647132)
* fix build failures by dropping unnecessary configure flags
* bump shlibs version
* rename the package 'ffmpeg' -> 'libav'
* Rename package libav to libav-tools (Closes: #654984)
* bump dependency on libav-source
* don't try to install CREDITS and TODO files
* Rebuild against libav 0.7.3
* Tighten build dependency on libav-source (>= 4:0.7.3-2)
* Bump shlibs (technically unnecessary, but added for completeness)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:libav
This branch contains Public information 
Everyone can see this information.