Merge lp:~mc-return/compiz/compiz0.9.9.merge-plugin-startup into lp:compiz/0.9.10
Status: | Work in progress | ||||
---|---|---|---|---|---|
Proposed branch: | lp:~mc-return/compiz/compiz0.9.9.merge-plugin-startup | ||||
Merge into: | lp:compiz/0.9.10 | ||||
Diff against target: |
450 lines (+418/-0) 5 files modified
debian/compiz-plugins.install (+1/-0) plugins/startup/CMakeLists.txt (+5/-0) plugins/startup/src/startup.cpp (+286/-0) plugins/startup/src/startup.h (+81/-0) plugins/startup/startup.xml.in (+45/-0) |
||||
To merge this branch: | bzr merge lp:~mc-return/compiz/compiz0.9.9.merge-plugin-startup | ||||
Related bugs: |
|
Reviewer | Review Type | Date Requested | Status |
---|---|---|---|
MC Return | Needs Information | ||
Compiz Maintainers | Pending | ||
Review via email: mp+156684@code.launchpad.net |
This proposal supersedes a proposal from 2013-01-08.
Description of the change
Another useful plugin lost in the realms of the git repo :)
What can this be used for, one might ask...
Example 1:
You want to autostart some widgets, which should use Compiz' widget layer plugin and reside on their own layer.
To achieve this you have to ensure those widgets start after Compiz (Best option: First Time).
Example 2:
You want to ensure some OpenGL program starts after Compiz, like a GL-dock for example.
Unmerged revisions
- 3306. By MC Return
-
Merged latest lp:compiz
- 3305. By MC Return
-
Improved/harmonized ABI check
- 3304. By MC Return
-
Merged latest lp:compiz
- 3303. By MC Return
-
Minor additional .xml improvements
(indentation, better tooltip) - 3302. By MC Return
-
Added . to comment
- 3301. By MC Return
-
C++ style for comments
Fixed compilation (macro) - 3300. By MC Return
-
Fixed typo
- 3299. By MC Return
-
Merged latest lp:compiz
- 3298. By MC Return
-
Fixed indentation
Use prefix instead of postfix increments
if (i == 0) -> if (!i)
C++ style for comments
Added newlines to improve readability - 3297. By MC Return
-
Merged latest lp:compiz
I guess the only thing that is missing here now is to replace this macro:
267 +#define GET_ENV_VAR(ourvar, envvar, error) \ BUS_ADDRESS, error)
268 + ourvar = getenv(#envvar); \
269 + if (ourvar == NULL) \
270 + { \
271 + compLogMessage ("startup", CompLogLevelError, \
272 + "Environment variable " #envvar " is not set"); \
273 + error = true; \
274 + return; \
275 +}
276 +GET_ENV_VAR (dbus_env_var, DBUS_SESSION_
277 +GET_ENV_VAR (dsp, DISPLAY, error)
278 +GET_ENV_VAR (home, HOME, error)
279 +#undef GET_ENV_VAR
- but I fear this could blow up my computer and I would be pleased if someone could help with this or give me some good tips on how best to replace this...