lp:~mc-return/compiz/compiz.merge-fix771875-screenshot-overlay-on-screenshots-with-enabled-fbos

Created by MC Return and last modified
Get this branch:
bzr branch lp:~mc-return/compiz/compiz.merge-fix771875-screenshot-overlay-on-screenshots-with-enabled-fbos
Only MC Return can upload to this branch. If you are MC Return please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
MC Return
Project:
Compiz
Status:
Merged

Recent revisions

3669. By MC Return

Merged
lp:~smspillaz/compiz/merge.fix771875-screenshot-overlay-on-screenshots-with-enabled-fbos.read_draw_buffer

Refactor screenshot code to make it clearer and also to allow us to take
screenshots in glPaintOutput as opposed to paint ().

Taking screenshots in paint () was probably correct pre-GLES, but isn't
really correct now - we want to be able to read off of the currently
bound scratch framebuffer where we last painted the frame. Reading off
the frontbuffer is an imprecise operation because the contents of both
buffers are really undefined after a swap. In the case where we are
not painting to a scratch framebuffer object, we'll just end up reading
from the backbuffer anyways, which would be correct to do mid-frame.

Also added the new static const GLenums DRAW_FRAMEBUFFER_BINDING and
READ_FRAMEBUFFER_BINDING to opengl.h.

3668. By MC Return

*Screenshot, code:

If we have FBOs enabled we need to call glReadBuffer (GL_FRONT); before
we call glReadPixels

(LP: #771875)

3667. By MC Return

*Screenshot, xml:

Better plugin summary.
Added option to disable the drawing of the screenshot
selection indicator.
Added options to change color and opacity of the outline
and the inside of the rectangle indicator, default colors
have not been changed.
Other minor improvements.

*Screenshot, code:

Introduced the new variable bool selectionSizeChanged,
which is true if the size of the selection has changed.

We just want to draw the screenshot selection box, if
we are grabbed, the size has changed and the CCSM
option to draw it is enabled.
Do not render anything if indicator is disabled.

Indicator colors are now configurable.
Increased indicator box outline line width to 2.0.

Only damage the full screen once, if the grab gets
terminated, during grab just damage the region painted,
which is the screenshot selection box (LP: #1172234).

*SCreenshot, cleanup:

Minor cleanup in the rendering code.
Removed redundant #ifndef USE_GLES compiler option,
GLES can cope with enabling and disabling GL_BLEND.
Use prefix- instead of postfix increments.
Declaration and assignment of local variables in one line.
Reduced the scope of the variables x1, y1, x2 and y2.
Replaced magic number 65535.0f with const float MaxUShortFloat =
std::numeric_limits <unsigned short>::max ();.
Indentation fixes.
C++ style for comments, added comments.

(LP: #1169353, LP: #1172234). Fixes: https://bugs.launchpad.net/bugs/1169353, https://bugs.launchpad.net/bugs/1172234.

Approved by PS Jenkins bot, Sam Spilsbury.

3666. By MC Return

*Workspacenames:

New Feature:
Implemented option to adjust vertical offset for
top and bottom of screen workspacename placement.
Set the default offset to 50 pixel.

Cleanup:
Added brackets to for loop.
Use prefix increments.
Indentation fixes.
Added and removed newlines for better readability.
Added comment.
Removed TEXT_BORDER constant.
Improved tooltips.

(LP: #1172063). Fixes: https://bugs.launchpad.net/bugs/1172063.

Approved by PS Jenkins bot, Sam Spilsbury.

3665. By MC Return

*Showmouse code cleanup:

Assignment and declaration of local variables in one line.
Removed redundant brackets.
Fixed indentation.
Removed and added newlines for better readability.

*Showmouse code changes:

Removed these redundant gl calls:
glEnable (GL_TEXTURE_2D);
glDisable (GL_TEXTURE_2D);

(partially fixes LP: #1051290 and LP: #1051295).

Approved by PS Jenkins bot, Sam Spilsbury.

3664. By MC Return

*Cube Gears:

Added glDepthMask (GL_TRUE); and glDepthFunc (GL_LESS); to void
GearsScreen::cubePaintInside (...) to fix the culling on multimonitor
systems (green gear was always rendered in front).

Also fixed indentation and removed some redundant newlines.

(LP: #1168919). Fixes: https://bugs.launchpad.net/bugs/1168919.

Approved by PS Jenkins bot, Sam Spilsbury.

3663. By MC Return

*Grid code:

Simplified bool GridScreen::restoreWindow (...):
If Grid has not touched the window we return false and let core do the
dirty work.
(Thanks go to Sam Spilsbury for suggesting this solution.)

*Grid xml:

Improved the CCSM Grid put_restore_key tooltip.

(LP: #1116538). Fixes: https://bugs.launchpad.net/bugs/1116538.

Approved by PS Jenkins bot, Sam Spilsbury.

3662. By MC Return

Composite code cleanup:

Merged a few if-if condition checks.
Declaration and assignment of local variables in one line.
Removed redundant brackets.
Added and removed newlines to improve readability.
Fixed indentation.

Approved by PS Jenkins bot, Sam Spilsbury.

3661. By MC Return

Shift Switcher code cleanup:

Merged a few if-if condition checks.
Declaration and assignment of local variables in one line.
Removed redundant brackets.
Added and removed newlines to improve readability.
Fixed indentation.

Approved by PS Jenkins bot, Sam Spilsbury.

3660. By MC Return

*Move xml:

Slightly improved long description of the move plugin.
Implemented option to change the key move increment size.
Removed <precision> settings as they just work for floats.

*Move code:

Removed hardcoded KEY_MOVE_INC variable.
Introduced int moveIncrement to not have to execute
optionGetKeyMoveInc () to get the value twice.

(LP: #1167933, part 2). Fixes: https://bugs.launchpad.net/bugs/1167933.

Approved by PS Jenkins bot, Sam Spilsbury.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:compiz/0.9.10
This branch contains Public information 
Everyone can see this information.

Subscribers