Merge lp:~mc-return/compiz/compiz.merge-added-qtcreator-config-file-for-contributors into lp:compiz/0.9.10

Proposed by Sam Spilsbury
Status: Merged
Approved by: MC Return
Approved revision: 3734
Merged at revision: 3748
Proposed branch: lp:~mc-return/compiz/compiz.merge-added-qtcreator-config-file-for-contributors
Merge into: lp:compiz/0.9.10
Diff against target: 44 lines (+39/-0)
1 file modified
contribute/QtCreatorConfig.xml (+39/-0)
To merge this branch: bzr merge lp:~mc-return/compiz/compiz.merge-added-qtcreator-config-file-for-contributors
Reviewer Review Type Date Requested Status
PS Jenkins bot (community) continuous-integration Needs Fixing
MC Return Approve
Sam Spilsbury Pending
Review via email: mp+171948@code.launchpad.net

This proposal supersedes a proposal from 2013-06-01.

Commit message

Added contribute directory.
Added QtCreatorConfig.xml, a configuration file for Qt Creator, which
adjusts Qt Creator's C++ indentation style to be the same that is used
in the Compiz project (X11, mixed spaces and tabs).

Description of the change

Added contribute directory.
Added QtCreatorConfig.xml, a configuration file for Qt Creator, which
adjusts Qt Creator's C++ indentation style to be the same that is used
in the Compiz project (X11, mixed spaces and tabs).
Should be very helpful for contributors. :)

TODO: Add html or text coding style files.

To post a comment you must log in.
Revision history for this message
Sam Spilsbury (smspillaz) wrote : Posted in a previous version of this proposal

Should QtCreatorConfig.xml be in the for_contributors directory? (perhaps that could be renamed to tools/ too)

review: Needs Information
Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal

> Should QtCreatorConfig.xml be in the for_contributors directory? (perhaps that
> could be renamed to tools/ too)

Well, this directory should contain helpful files and documentation (Compiz coding style information, compilation/test HOWTOs & so on) for contributors in the future, so I do not think that "tools" would be a appropriate name for it...

Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal

If you do not like the underscore in "for_contributors", another suggestion would be simply "contribute"...

review: Needs Information
Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal

Maybe camelCase ? -> forContributors ?

Revision history for this message
Sam Spilsbury (smspillaz) wrote : Posted in a previous version of this proposal

contribute/ would work fine, yes.

Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal

> contribute/ would work fine, yes.

Done in r3733.

review: Needs Resubmitting
Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal

More than 2 weeks to get 1 small file landing...
Sad :(

Revision history for this message
Sam Spilsbury (smspillaz) wrote : Posted in a previous version of this proposal

Didn't I say this should have been in contribute/ ?

Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal
Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal

> > contribute/ would work fine, yes.
>
> Done in r3733.

> > Didn't I say this should have been in contribute/ ?
>
> Yes you did, and this is where it now resides.

Revision history for this message
Sam Spilsbury (smspillaz) wrote : Posted in a previous version of this proposal

smspillaz@INTERPOL ~/Source/compiz> ls
AUTHORS compiz.pc.in debian libdecoration README
build config.h.core.in Doxyfile metadata RELEASING
ChangeLog contribute gtk NEWS scripts
cmake COPYING images plugins src
CMakeLists.txt COPYING.GPL include po tests
CMakeLists.txt.user COPYING.LGPL INSTALL postinst VERSION
compizconfig COPYING.MIT kde QtCreatorConfig.xml xslt

Um, QtCreatorConfig.xml is still in the root dir.

review: Needs Fixing
Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal

Urgh - sorry -> my fault.
Do not know how that happened ?! but should be fixed now.

review: Needs Resubmitting
Revision history for this message
Sam Spilsbury (smspillaz) wrote : Posted in a previous version of this proposal

Coolio.

We'll put this in after the freeze.

review: Approve
Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal

Ping ?

Revision history for this message
PS Jenkins bot (ps-jenkins) wrote : Posted in a previous version of this proposal
review: Needs Fixing (continuous-integration)
Revision history for this message
MC Return (mc-return) wrote : Posted in a previous version of this proposal

ps-jenkins, try harder -> this MP has no potential to crash you at all ;)

Revision history for this message
MC Return (mc-return) : Posted in a previous version of this proposal
review: Needs Resubmitting
Revision history for this message
MC Return (mc-return) wrote :

Well, approve from me. :)
(Do not know what exactly happened here, but LGTM.)

review: Approve
Revision history for this message
MC Return (mc-return) wrote :

It is approved by you and me, let's get it off the table and make it land...

Revision history for this message
PS Jenkins bot (ps-jenkins) :
review: Approve (continuous-integration)
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :
review: Needs Fixing (continuous-integration)

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== added directory 'contribute'
2=== added file 'contribute/QtCreatorConfig.xml'
3--- contribute/QtCreatorConfig.xml 1970-01-01 00:00:00 +0000
4+++ contribute/QtCreatorConfig.xml 2013-06-28 01:47:34 +0000
5@@ -0,0 +1,39 @@
6+<?xml version="1.0" encoding="UTF-8"?>
7+<!DOCTYPE QtCreatorCodeStyle>
8+<!-- Written by QtCreator 2.7.1, 2013-06-01T14:35:39. -->
9+<qtcreator>
10+ <data>
11+ <variable>CodeStyleData</variable>
12+ <valuemap type="QVariantMap">
13+ <value type="bool" key="AlignAssignments">true</value>
14+ <value type="bool" key="AutoSpacesForTabs">false</value>
15+ <value type="bool" key="BindStarToIdentifier">true</value>
16+ <value type="bool" key="BindStarToLeftSpecifier">false</value>
17+ <value type="bool" key="BindStarToRightSpecifier">false</value>
18+ <value type="bool" key="BindStarToTypeName">false</value>
19+ <value type="bool" key="ExtraPaddingForConditionsIfConfusingAlign">false</value>
20+ <value type="bool" key="IndentAccessSpecifiers">true</value>
21+ <value type="bool" key="IndentBlockBody">true</value>
22+ <value type="bool" key="IndentBlockBraces">false</value>
23+ <value type="bool" key="IndentBlocksRelativeToSwitchLabels">false</value>
24+ <value type="bool" key="IndentClassBraces">false</value>
25+ <value type="bool" key="IndentControlFlowRelativeToSwitchLabels">true</value>
26+ <value type="bool" key="IndentDeclarationsRelativeToAccessSpecifiers">true</value>
27+ <value type="bool" key="IndentEnumBraces">false</value>
28+ <value type="bool" key="IndentFunctionBody">true</value>
29+ <value type="bool" key="IndentFunctionBraces">false</value>
30+ <value type="bool" key="IndentNamespaceBody">false</value>
31+ <value type="bool" key="IndentNamespaceBraces">false</value>
32+ <value type="int" key="IndentSize">4</value>
33+ <value type="bool" key="IndentStatementsRelativeToSwitchLabels">true</value>
34+ <value type="bool" key="IndentSwitchLabels">true</value>
35+ <value type="int" key="PaddingMode">2</value>
36+ <value type="bool" key="SpacesForTabs">false</value>
37+ <value type="int" key="TabSize">8</value>
38+ </valuemap>
39+ </data>
40+ <data>
41+ <variable>DisplayName</variable>
42+ <value type="QString">X11</value>
43+ </data>
44+</qtcreator>

Subscribers

People subscribed via source and target branches

to all changes: