maxima:DebianPackaging

Last commit made on 2018-09-24
Get this branch:
git clone -b DebianPackaging https://git.launchpad.net/maxima

Branch merges

Branch information

Name:
DebianPackaging
Repository:
lp:maxima

Recent commits

5374020... by PeterPall on 2018-09-24

An ugly workaround for clisp requiring something between libffi1...libffi6, depending on the Ubuntu version:

libffi-dev pulls in the right libffi.

f98ee76... by PeterPall on 2018-06-20

We will start to build-depend on gnuplot when we do automatic tests for draw.

1611e35... by PeterPall on 2018-06-13

"maxima" is better off being a purely virtual package.

5f1e45f... by PeterPall on 2018-05-06

This was why the fallback to the installed maxima didn't work.

7967165... by PeterPall on 2018-05-05

Another try to clean up the depends during install.

4095028... by PeterPall on 2018-05-03

Another try to repair the debian/control file.

fa190ec... by PeterPall on 2018-05-02

Corrected my last commit: Seems like dpkg does understand = and >, but not >=.

1b8ef0b... by PeterPall on 2018-05-02

Make sure we on install uninstall the maxima version that comes with Ubuntu.

37f0b7a... by PeterPall on 2018-04-23

Enabling ECL again: A test was marked as "expected to fail on ecl".

This reverts commit 7ed2e6489c3aceec3ead4d650860baeb0102bb08.

b5d4d85... by PeterPall on 2018-04-20

Now maxima automatically tells gcl to limit itself to a reasonable amount of memory, if possible => dropped the commands that manually do so during "make check" whilst creating the debian package.