Code review comment for lp:~matzipan/scratch/folder-manager-improvement

Revision history for this message
Zisu Andrei (matzipan) wrote :

> One of the revisions added the "new" keyword. Is there a reason you did this rather than mark the corresponding function in the abstract class "Item" as virtual?

Initially I used "override", however, it seems "override" in Vala is not the same as in Java, so I removed it, and then the compiler noticed my declaration is shadowing a function in the parent class, and suggested I add "new" if this is intentional.

« Back to merge proposal