lp:~maria-captains/ourdelta/ourdelta-aria

Created by Sergei Golubchik on 2010-09-07 and last modified on 2012-04-27
Get this branch:
bzr branch lp:~maria-captains/ourdelta/ourdelta-aria
Members of Maria-captains can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Maria-captains
Project:
OurDelta
Status:
Development

Recent revisions

116. By Sergei Golubchik on 2012-04-27

mariadb-server-dev package with private server headers

115. By Kristian Nielsen on 2012-03-05

Fix grep syntax error in preinst script.

114. By Sergey Petrunia on 2012-02-29

BUG#905712: rpm upgrade from 5.2.9 broken
- Add a mysql_vendor variable that has the vendor, "MariaDB"
- When checking whether the package we are upgrading from is
  from the same vendor, compare *vendors*, not previous vendor
  vs. current *packager*.

- Re upgrades from older releases:
  = Vendor was "MariaDB" for all MariaDB releases
  = Packager was changed from "OurDelta" to "Monty Program".
  Since we now compare *vendor*, upgrades from older releases should work now.

113. By Kristian Nielsen on 2012-02-24

Enable innodb_plugin building for .rpm.

112. By Kristian Nielsen on 2012-02-23

Include innodb plugin in .deb packages in 5.3.

111. By Kristian Nielsen on 2012-01-09

Having libhsclient.so in package libmariadbclient16 is wrong (it will conflict with eg. libmariadbclient18). Put it instead in the mariadb-server-5.3 package.

110. By Kristian Nielsen on 2012-01-09

Revert previous commit. It is broken; we cannot put dialog.so in libmariadbclient16, as that will conflict with e.g libmariadbclient18 from 5.5.

109. By Kristian Nielsen on 2011-12-21

Attempt to fix PAM plugin for .deb packaging.

 - Move the dialog.so client plugin into package libmariadbclient16, so
   it can be used without installing (and running) the server.

 - Add a conflicts: dependency with earlier versions of the server
   package that has the dialog.so plugin, to try and avoid upgrade
   problems.

108. By Kristian Nielsen on 2011-12-16

Fix libreadline Build-dependency in control file, to ensure we use GPLv2 version of readline on all distro versions

107. By Kristian Nielsen on 2011-11-15

Now that we have the feedback plugin in 5.1, we need to fix distributing plugin
.so files also in 5.1 .debs.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:~maria-captains/ourdelta/ourdelta-montyprogram-fixes
This branch contains Public information 
Everyone can see this information.

Subscribers