lp:~lubuntu-dev/lxde/libfm-qt-debian-git

Created by Julien Lavergne on 2016-01-23 and last modified on 2017-12-13
Get this branch:
bzr branch lp:~lubuntu-dev/lxde/libfm-qt-debian-git

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Lubuntu Developers
Project:
LXDE
Status:
Development

Import details

Import Status: Failed

This branch is an import of the HEAD branch of the Git repository at git://anonscm.debian.org/pkg-lxqt/libfm-qt.git,branch=debian/sid.

The import has been suspended because it failed 5 or more times in succession.

Last successful import was on 2018-01-06.

Import started on 2018-01-10 on pear and finished on 2018-01-10 taking 20 seconds — see the log
Import started on 2018-01-08 on russkaya and finished on 2018-01-08 taking 20 seconds — see the log
Import started on 2018-01-07 on pear and finished on 2018-01-07 taking 10 seconds — see the log
Import started on 2018-01-07 on russkaya and finished on 2018-01-07 taking 25 seconds — see the log

Recent revisions

25. By Alf Gaida on 2017-12-13

Some cleanup

* Bumped Standards to 4.1.2, no changes needed
* Removed branch from VCS fields
* Removed debian/gbp.conf
* Removed trailing whitespaces

24. By Alf Gaida on 2017-12-04

Transition to unstable

23. By Alf Gaida on 2017-12-04

Merge branch 'debian/experimental' into debian/sid

22. By Alf Gaida on 2017-12-04

Prepared transiton to sid

21. By Alf Gaida on 2017-07-02

Improve debian/control

* Bumped Standards to 4.0.0
* Added dependency shared-mime-info (Closes: #866901)

20. By Alf Gaida on 2016-12-22

Cherry-picking upstream release 0.11.2

* Added new symbols
* Removed build dependencies:
  - cmake
  - liblxqt0-dev
  - libqt5xdg-dev
  - pkg-config
  - qttools5-dev
  - qttools5-dev-tools
* Added build dependency lxqt-build-tools
* Added build dependency libfm-dev to libfm-qt-dev
* Removed models.patch, applied upstream

19. By Alf Gaida on 2016-10-20

Backported a upstream fix for Icon Emblem Support.

Added needed Symbols

18. By Alf Gaida on 2016-10-17

Cherry-picking upstream release 0.11.1.

* Syncded debian foo with experimental
* Bump compat to 10
* Removed --parallel from rules, standard compat 10
* Bumped Standards to 3.9.8, no changes needed
* Bump minimum version debhelper (>= 10)
* Bump minimum version libqt5xdg-dev (>= 2.0.0)
* Re-introduce build dependency liblxqt0-dev (>= 0.11.0)
* Added build dependency libqt5svg5-dev
* Added Recommends libfm-qt-l10n
* Exported LC_ALL=C.UTF-8 - define language settings for reproducible
  builds
* Hard override translation control
* Use DCMAKE_BUILD_TYPE=RelWithDebInfo
* Fixed copyright Format field, using https
* Fixed copyrights, removed obsolete files
* Fixed libfm-qt3.install, don't install translations

17. By Alf Gaida on 2016-03-31

Merged changes into unstable

Added five new symbols, leave the rest untouched
Removed not needed build dependency liblxqt0-dev
Removed not needed patches (libfm-qt contains no desktop files,
    so the desktop translation must not be patched)
Fixed VCS-* fields

16. By Alf Gaida on 2016-03-31

Manual merge the new release 0.11.0 from debian/experimental

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.