~lubuntu-dev/lxde/+git/lxqt-powermanagement-debian:stretch-backports

Last commit made on 2018-01-28
Get this branch:
git clone -b stretch-backports https://git.launchpad.net/~lubuntu-dev/lxde/+git/lxqt-powermanagement-debian

Branch merges

Branch information

Name:
stretch-backports
Repository:
lp:~lubuntu-dev/lxde/+git/lxqt-powermanagement-debian

Recent commits

493fd1d... by Alf Gaida on 2018-01-28

Rebuild for stretch-backports.

* No changes needed.

3db02b4... by Alf Gaida on 2017-12-14

Cleanup debian/*

* Bumped Standards to 4.1.2, no changes needed
* Removed debian/gbp.conf
* Removed branch from VCS fields

8d84225... by Alf Gaida on 2017-12-04

Transition to unstable

68389ff... by Alf Gaida on 2017-12-04

Merge branch 'debian/experimental' into debian/sid

fd201e3... by Alf Gaida on 2017-12-04

Cherry-picking upstream version 0.12.0.

ee233e5... by Alf Gaida on 2017-10-27

Added missed breaks and replaces for lxqt-common << 0.12.0

* (Closes: #879911) - Thanks Andreas Beckmann <email address hidden>

20d1c95... by Alf Gaida on 2017-10-24

Cherry-picking upstream release 0.12.0.

* Switched to experimental
* Bumped liblxqt0-dev to >= 0.12.0
* Bumped Standards to 4.1.1 - no changes needed

a65e8a4... by Alf Gaida on 2017-07-02

Rework dependencies and recommends

* Bumped standards to 4.0.0 - no changes needed
* Depends on lxqt-policykit
* Make upower a dependency instead of recommend it
* Recommend lxqt-qtplugin and lxqt-session
  (Closes: #866256)

b55a93d... by Alf Gaida on 2017-01-02

Cherry-picking upstream release 0.11.1.

* Removed some build dependencies:
  -cmake
  -libqt5xdg-dev
  -libqt5xdgiconloader-dev
  -pkg-config
  -qttools5-dev
  -qttools5-dev-tools
* Bumped build dependency liblxqt0-dev (>= 0.11.1)
* Bumped years in d/copyright

c280183... by Alf Gaida on 2016-10-18

Cherry-picking upstream release 0.11.0

* Synced debian foo with experimental
* Bumped compat to 10
* Removed --parallel from rules, standard in compat 10
* Bumped minimum version debhelper to />= 10)
* Bumped minimum version liblxqt0-dev (>= 0.11.0)
* Bumped minimum version libqt5xdg-dev (>= 2.0.0)
* Added build dependency libkf5idletime-dev
* Added build dependency libqt5svg5-dev
* Added Recommends lxqt-powermanagement-l10n
* Added build dependency libqt5xdgiconloader-dev (>= 2.0.0)
* Removed build dependency libx11-xcb-dev
* Removed build dependency libxcb-dpms0-dev
* Removed build dependency libxcb-screensaver0-dev
* Added translation control to rules
* Set CMAKE_BUILD_TYPE=RelWithDebInfo
* Exported LC_ALL=C.UTF-8, make builds reproducible