lp:~louis/ubuntu/wily/ifenslave/merge-debian-2.7

Created by Louis Bouchard on 2015-07-24 and last modified on 2015-07-24
Get this branch:
bzr branch lp:~louis/ubuntu/wily/ifenslave/merge-debian-2.7
Only Louis Bouchard can upload to this branch. If you are Louis Bouchard please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Louis Bouchard
Status:
Development

Recent revisions

10. By Louis Bouchard on 2015-07-24

* Merge from Debian unstable. Remaining changes:
  - Upstart event based bond bringup:
    + Drop ethernet+wifi example
    + Drop two_ethernet example
    + Update ethernet+hotplug_wifi example
    + Update two_hotplug_ethernet example
    + Update pre-up and post-down scripts for event bringup
    + Update README.Debian examples
  - Update scripts to use /run/network/ifstate instead of
    /etc/network/run/ifstate
  (LP: #1477928)
* Fix change in /sys/class/net/{bond}/slave_ naming after k3.13
  (Closes: #791906). Thanks, Louis Bouchard.
* Standards-Version: 3.9.6.
* Added support for "packets_per_slave" option in interface stanza
  (Closes: #758913); Thanks, John Holland.
* README.Debian:
  + added note regarding "udev renaming issue".
  + added "see also" note with link to "Bonding" section of wiki.

9. By St├ęphane Graber on 2014-05-02

* Merge from Debian unstable. Remaining changes:
  - Upstart event based bond bringup:
    + Drop ethernet+wifi example
    + Drop two_ethernet example
    + Update ethernet+hotplug_wifi example
    + Update two_hotplug_ethernet example
    + Update pre-up and post-down scripts for event bringup
    + Update README.Debian examples
  - Update scripts to use /run/network/ifstate instead of
    /etc/network/run/ifstate

8. By St├ęphane Graber on 2014-03-03

Re-apply Ubuntu delta to new source.

7. By Dmitry Smirnov <email address hidden> on 2014-02-11

Added "ifenslave-2.6.prerm" to remove dangling alternatives
(Closes: #736668).
Thanks to Andreas Beckmann.

6. By Dmitry Smirnov <email address hidden> on 2014-01-17

Added transitional package "ifenslave-2.6" and corresponding
Breaks/Replaces (Closes: #735614).
Thanks, Andreas Beckmann.

5. By Dmitry Smirnov <email address hidden> on 2014-01-12

* Rebase on top of "ifenslave-2.6 (1.1.0-21)".
* Added retrospective changelog entry.
* Removed obsolete lintian-override.
* Removed "${shlibs:Depends}" from Depends.

4. By Dmitry Smirnov <email address hidden> on 2013-11-10

[ Dmitry Smirnov ]
* Package and binary renamed to "ifenslave"
* No longer provide alternatives but still ship ifenslave-2.6
  (symlink) for backward compatibility.
* Converted to native package; added lintian-override.
* Updated package description.
* "debian/copyright" to copyright-format-1.0.
* Debhelper & compat to version 9.
* Standards to 3.9.5.
* Source package compression to ".xz".
* Removed obsolete ifenslave-2.4 from Conflicts.
* Depend on "iproute2" instead of transitional "iproute" (Closes: #715382).
* Added "ifupdown" to Depends.
* Multi-Arch: foreign.
* Added VCS links.
* Added myself to Uploaders.

[ Guus Sliepen ]
* Replace ifenslave binary with a tiny shell script.
* Let dh_installifupdown install the if-up/down scripts.
* Conflict with ifenslave-2.6.
* Change license of everything to GPL-3+.

3. By Guus Sliepen <email address hidden> on 2004-05-16

Reduce this package to an empty one that depends on ifenslave-2.4 |
ifenslave-2.6. See also #247844.

2. By Guus Sliepen <email address hidden> on 2001-06-13

* Initial release. Closes: #100760
* Merged with several patched versions of the same source.
* Created manpage.

1. By Guus Sliepen <email address hidden> on 2001-06-13

Import upstream version 0.07

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/wily/ifenslave
This branch contains Public information 
Everyone can see this information.

Subscribers