Merge lp:~laney/ubuntu-wallpapers/ubuntu-wallpapers-extra-transitional into lp:ubuntu-wallpapers

Proposed by Iain Lane on 2012-04-07
Status: Merged
Merged at revision: 85
Proposed branch: lp:~laney/ubuntu-wallpapers/ubuntu-wallpapers-extra-transitional
Merge into: lp:ubuntu-wallpapers
Diff against target: 62 lines (+24/-3) 2 files modified
To merge this branch: bzr merge lp:~laney/ubuntu-wallpapers/ubuntu-wallpapers-extra-transitional
Reviewer Review Type Date Requested Status
Ubuntu Artwork Packagers 2012-04-07 Pending
Review via email: mp+101190@code.launchpad.net

Description of the Change

Add a transitional package to properly fix the attached bug.

To post a comment you must log in.
86. By Iain Lane on 2012-04-07

Put ubuntu-wallpapers (the package) in Section: metapackages as
dependencies of packages in this section are considered "manual" by apt
and therefore will not be removed on upgrades. This means that users
will keep wallpapers from old releases when upgrading. Thanks to James
Westby for pointing this out to me. (LP: #863509)

Iain Lane (laney) wrote :

I pushed another commit to hopefully fix bug #863509 by using the fact that "metapackages" is in apt's Never-MarkAuto-Sections.

Preview Diff

1=== modified file 'debian/changelog'
2--- debian/changelog 2012-04-05 17:20:30 +0000
3+++ debian/changelog 2012-04-07 23:12:18 +0000
4@@ -1,9 +1,21 @@
5 ubuntu-wallpapers (0.34.1) UNRELEASED; urgency=low
6
7+ [ Ken VanDine ]
8 * debian/control
9 - dropped build depends for xsltproc
10
11- -- Ken VanDine <ken.vandine@canonical.com> Thu, 05 Apr 2012 13:19:36 -0400
12+ [ Iain Lane ]
13+ * debian/control
14+ - Provide transitional package for ubuntu-wallpapers-extra, an old package
15+ which was providing the Karmic wallpapers and thus shared files with
16+ ubuntu-wallpapers-karmic. (LP: #975778)
17+ - Put ubuntu-wallpapers (the package) in Section: metapackages as
18+ dependencies of packages in this section are considered "manual" by apt
19+ and therefore will not be removed on upgrades. This means that users
20+ will keep wallpapers from old releases when upgrading. Thanks to James
21+ Westby for pointing this out to me. (LP: #863509)
22+
23+ -- Iain Lane <laney@ubuntu.com> Sat, 07 Apr 2012 21:36:50 +0100
24
25 ubuntu-wallpapers (0.34.0) precise; urgency=low
26
27
28=== modified file 'debian/control'
29--- debian/control 2012-04-05 17:20:30 +0000
30+++ debian/control 2012-04-07 23:12:18 +0000
31@@ -9,6 +9,7 @@
32
33 Package: ubuntu-wallpapers
34 Architecture: all
35+Section: metapackages
36 Depends: ${misc:Depends},
37 ubuntu-wallpapers-precise
38 Suggests: ubuntu-wallpapers-oneiric,
39@@ -21,13 +22,21 @@
40 other default wallpapers for the current Ubuntu release.
41
42 Package: ubuntu-wallpapers-karmic
43-Conflicts: ubuntu-wallpapers (<< 0.34.0)
44-Replaces: ubuntu-wallpapers (<< 0.34.0)
45+Conflicts: ubuntu-wallpapers (<< 0.34.0), ubuntu-wallpapers-extra (<< 0.34.1~)
46+Replaces: ubuntu-wallpapers (<< 0.34.0), ubuntu-wallpapers-extra (<< 0.34.1~)
47 Architecture: all
48 Depends: ${misc:Depends}
49 Description: Ubuntu 9.10 Wallpapers
50 Wallpapers from the Ubuntu 9.10 community contest
51
52+Package: ubuntu-wallpapers-extra
53+Depends: ubuntu-wallpapers-karmic, ${misc:Depends}
54+Architecture: all
55+Section: oldlibs
56+Description: transitional dummy package for ubuntu-wallpapers-karmic
57+ This package is a transitional package to facilitate upgrades from
58+ ubuntu-wallpapers-extra to ubuntu-wallpapers-karmic. It can be safely removed.
59+
60 Package: ubuntu-wallpapers-lucid
61 Conflicts: ubuntu-wallpapers (<< 0.34.0)
62 Replaces: ubuntu-wallpapers (<< 0.34.0)