lp:~kubuntu-packagers/kubuntu-packaging/kdevelop-qt4

Created by Scarlett Gately Moore on 2015-11-10 and last modified on 2015-11-16
Get this branch:
bzr branch lp:~kubuntu-packagers/kubuntu-packaging/kdevelop-qt4
Members of Kubuntu Packagers can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Kubuntu Packagers
Project:
kubuntu-packaging
Status:
Development

Recent revisions

3. By Scarlett Gately Moore on 2015-11-16

Update kdevplatform version requirement.

2. By Scarlett Gately Moore on 2015-11-11

Fix version cruft.

1. By Scarlett Gately Moore on 2015-11-10

* Final 4 series upstream bugfix release.
* Wrong bug. Fix (LP: #1431965)
* Wrap and sort.
* Add missing library. (LP: #1417659)
* Release to Archive
* New upstream release (LP: #1417659)
* Build without okteta-dev which has moved to KF5
* Remove kde-workspace-dev build-depend, it's removed from archive
* New upstream release (LP: #1362107)
* Add cmake to recommends as it is needed for cmake projects and kdevelop
  will fail with an excitingly pointless error message if it is not found.
  Kdevelop can technically also be used without cmake, so cmake
  certainly does not qualify as Dependency.
  LP: #807386
* Promote kdevelop-l10n from Suggests to Recommends to ensure people
  get localization.
  + Add kdevelop-php-docs-l10n, kdevelop-php-l10n as Recommends
* Recommend libqtwebkit-qmlwebkitplugin, required for 'learn kdevelop'
  feature on the overview LP: #1264663
  (Not depending because this is a purely optional dependency, much
   like khelpcenter)
* New upstream release (LP: #1259220)
* Update install files
* New upstream release
* Bump required version of kdevplatform-dev to 1.5.2
* Rebuild against new okteta 4.11
* Fix typo in kdevelop depends: kata-data -> kate-data.
  Thanks Ladislav Bonita. (LP: #1191916)
* Add depends on kate-data, fixes https://bugs.kde.org/318188
  "Adding snippet repository fails with clean install"
* Don't build okteta plugin on powerpc or install in
  kdevelop-data.install and edit debian/rules to install on !powerpc
* New upstream release
* Merge with Debian git packaging, remaining changes
 - replaces/conflucts kdevelop-custom-buildsystem, now build into KDevelop
* Make kdevelop-data break/replace kdevelop-doc << 4.3 (it was part of
  kdevelop 3.5).
* Bump build dependency for kdevplatform-dev to 1.5.1.
* Remove patch for compile switch for Okteta structure tool since
  BIG_ENDIAN compile switch implemented by upstream
  (remove patch okteta_optional_structures_tool.diff)
* Add libqjson-dev build dependency.
* New upstream release:
  - fixes parsing of libc header files (Closes: #707215)
* Bump Standards-Version to 3.9.4: no changes needed.
* Update copyright.
* replaces/conflucts kdevelop-custom-buildsystem, now build into KDevelop
* New upstream release LP: #1175273
* Add kubuntu_no_test.diff to disable broken test
* New upstream release (LP: #1074875)
  - Drop okteta_optional_structures_tool.diff
    + Use upstream's solution
* New upstream release
* New upstream beta release
* Remove kubuntu_01_appmenu_fix.diff now upstream
* Don't apply compileWithOkteta0.9.diff no longer needed
* Add compileWithOkteta0.9.diff from upstream to enable building against
  Okteta 0.9 with KDevelop 4.3.x.
* Merge with Debian, remaining changes:
  - Keep kubuntu_01_appmenu_fix.diff
  - kdevelop-l10n replaces/breaks kdevelop-data (<< 4:4.3.1-3ubuntu1) due
    to file moves from this merge. Can be dropped next LTS.
  - Keep suggestion of kdevelop-custom-buildsystem by kdevelop
* Drop kdevelop-custom-buildsystem from a recommendation to a suggestion.
  Being a recommends seems a bit strict for a very optional plugin.
* Team upload.
* Fix parallel building; patch fix-parallel.diff.
* Team upload. Upload to unstable.
* Slightly improve the description of kdevelop-l10n.
* Team upload.
* New upstream release:
  - fixes building with GCC 4.7. (Closes: #672065)
* Bump build dependency kdevplatform-dev to version 1.3.1
* Update build dependency from kdebase-workspace-dev to kde-workspace-dev.
* Update debian/copyright.
* Update patch.
* Bump Standards-Version to 3.9.3, no changes required.
* New upstream release
* Add watch file
* New upstream release
* Team upload.
* Detect whether the Okteta structure tool is compiled, and if it is not
  do not use it in the Okteta plugin; this fixes compilation on architectures
  with no structures tool, i.e. big endian ones.
  (patch okteta_optional_structures_tool.diff)
* Set urgency=medium as it fixes a FTBFS, and to avoid blocking the KDE 4.7
  transition too much.
* New upstream release
* Disable StructureToolsView on BIG_ENDIAN since it is disabled in kdesdk
  as well. Fixes FTBFS on powerpc.
* New upstream release
  - Bump kdevplatform-dev requirement
  - Refresh install files
  - Install KDevelop documentation
  - Recommend new package kdevelop-custom-buildsystem
* Add kubuntu_02_okteta_kde_48_libraries.diff from upstream to build with
  Okteta from KDE SC 4.8
* Recompile for KDE SC 4.8, okteta libraries changed remove okteta kpart files
* Rebuild against libsublime3.
* New upstream release.
* Bump the kdevplatform-dev build dependency to 1.2.3.
* No-change rebuild against liboktetakastencontrollers4abi1.
* New upstream release
  - Add libqtwebkit-dev as a build dep
  - kdebase-workspace-dev is now kde-workspace-dev
* Add cdbs back to build deps
  - Add a lintian override for cdbs
* New upstream release (Closes: #603063):
  - correctly parse CMake FILE command with GLOB or GLOB_RECURSE.
    (Closes: #609674)
* Bump build dependency kdevplatform-dev to version 1.2.0
* Bump build dependency kdebase-workspace-dev to version 4:4.5.0
* Merged localization files into one package
  - includes: Catalan (ca), Southern Catalan (cavalencia), Danish (da),
    German (de), British English (engb), Spanish (es), Estonian (et),
    French (fr), Italian (it), Norwegian Bookmal (nb),
    Low Saxon (nds), Dutch (nl), Brazilian Portuguese (ptbr),
    Portuguese (pt), Russian (ru), Slovenian (sl), Swedish (sv),
    Thai (th), Ukrainian (uk), Chinese Simplified (zh_CN),
    Chinese Traditional (zh_TW)
  - add Breaks for all kdevelop-l10n-* packages
  - add Replaces for all kdevelop-l10n-* packages
  - change Recommends to kdevplatform-l10n
* Add build-dependency for okteta-dev.
* Add myself to Uploaders.
* Add debian/watch file to track upstream versions.
* Add kdevelop-dbg package with KDevelop debugging symbols. (Closes: #593634)
* Add myself to uploaders.
* Drop quilt build dependency and build-depend on pkg-kde-tools 0.9.0
  to be able to build without it.
* Bump build dependency on kdevplatform-dev to version 1.1.0.
* Change the Vcs-* fields in debian/control to point to git.
* Disable the french localization package; not shipped in this release.
* Update installed files.
* Bump Standards-Version to 3.9.2 (no changes needed).
* Modify depends, recommends and suggests for kdevelop:
  - recommend gcc, g++, make. (Closes: #597642)
  - suggest kapptemplate
  - remove lcov, valgrind
* Add libqtwebkit-dev build dependency. (Closes: #618052)
* Remove kdevelop-l10n from Suggests, since it
  does not exist anymore
* New upstream release
  - Build dep on kdevplatform >= 1.2.2
  - refresh kdevelop-data.install
* Bump up kdevplatform-dev dep
* New upstream release
* New upstream release
  - Build-dep on kdevplatform-dev >= 1.1.90
  - Build depend on okteta-dev
  - Refresh kdevelop-data.install
* New upstream release
  - Bump kdevplatform-dev build dependency
* Removed localization packages
* New upstream release
  - Disable kdevelop-l10n-fr, removed upstream
* New upstream release
  - Bump build-dependencies
  - Refresh kubuntu_01_appmenu_fix.diff
  - Disable kdevelop-l10n-fr, is empty
  - Update kdevelop.install
* Add kubuntu_01_appmenu_fix.diff by Aurélien Gâteau to make KDevelop work
  with appmenu.
* New upstream release
  - Bump kdevplatform-dev build dependency
  - Add localization package: Russian (ru)
* Remove unused dependency on lcov
* Disable parallel building to fix FTBFS.
* Set export KUBUNTU_DESKTOP_POT=extragear-sdk_kdevelop
* New upstream release.
* Add localization packages: Finnish (fi), Dutch (nl), Slovenian (sl) and
  Thai (th).
* Update debian/control:
  - bump Standards-Version to 3.9.0 (no changes needed).
  - bump kdevplatform-dev and kdebase-workspace-dev build dependency version.
  - add shared-mime-info build dependency.
  - comment turkish localization package, not shipped in this release.
* Update debian/rules: remove workaround for FindKDE4Internal.cmake default
  rpath value, fixed in kdelibs5-dev 4.4.1.
* Upload to unstable (Closes: #579947, #481832).
* Acknowledge obsolete NMU fixes (Closes: #562410, #546961).
* New upstream release (Closes: #579947, #481832).
* Update debian/control:
  - Bump kdevplatform-dev build dependency version.
* Acknowledge obsolete NMU fixes (Closes: #562410, #546961).
* New upstream release.
* Add localizations packages.
* New upstream release.
* Switch to dpkg-source 3.0 (quilt) format.
* Update debian/copyright: update authors list.
* Add debian/kdevelop.lintian-overrides: override postinst/postrm errors.
* New upstream release.
* Update debian/control:
  - Suggests cmake package. (Closes: #561507)
  - Bump kdevplatform-dev build dependency version.
* New upstream release.
* Remove 10_private_libs_soversion.diff patch.
* Update debian/control:
  - Bump build dependencies versions (debhelper, pkg-kde-tools and
    kdevplatform-dev).
  - Bump Standards-Version to 3.8.4 (no changes needed).
* Update debian/kdevelop-dev.install file.
* Update debian/kdevelop.install file.
* Add debian/kdevelop.lintian-overrides file.
* Update debian/rules: pass -DCMAKE_SKIP_RPATH=ON
  to workaround FindKDE4Internal.cmake default rpath value.
* Fix Vcs-Browser URL.
* New upstream release.
* Drop 01_kdevelop_r1044086.diff and 02_kdevelop_r1044721.diff patches.
* Update debian/kdevelop-data.install: remove valgrind plugin.
* New upstream release.
* Add 01_kdevelop_r1044086.diff and 02_kdevelop_r1044721.diff patches.
* Remove kdevelop version fix.
* Update debian/kdevelop-data.install: re-add usr/share/icons/* entry and
  update installed files.
* Add patch to fix kdevelop version.
* New upstream release (beta 5).
* Update debian/kdevelop-data.install: remove usr/share/icons/* entry.
* Bump Standards-Version to 3.8.3 (no changes needed).
* New snapshot from svn revision 1010123.
+++ Changes by Frederik Schwarzer:
* Fix typos and casing in packages descriptions.
* New upstream release.
* Add Recommends on:
  - gdb >= 6.8.50. It is the minimal requirement.
  - valgrind
* Bump Standards-Version to 3.8.2 (no changes needed).
* New upstream release.
* Add kdebase-workspace-dev build dependency.
  It's needed for ksysguard widget.
* Bump kdevplatform build dependency from 0.9.92 to 0.9.93.
* Refresh 10_private_libs_soversion.diff patch:
  qmake project manager is removed upstream.
* Update debian/kdevelop-data.install:
  qmake builder and qtdesigner are removed upstream.
* Initial upload of kdevelop 4 to experimental (Closes: #481832).
* New upstream release.
* Remove patches included upstream:
  + 02_fix_build_output_view.diff
* Remove obsolete Conflicts / Replaces on kdevelop3-*.
* Update to Standards-Version 3.8.0 (no changes).
* Revert automake (>= 1:1.10) to automake1.9.
* New upstream release.
* Remove patches included upstream:
  + 02_fix_desktop_entries.diff
  + 03_fix_user_interface_lag.diff
  + 04_fix_click_on_error.diff
* Add patch for lines disappearing from build output view.
* Fix watch file (Closes: #462822).
* Replace Build-Depends on libdb4.4-dev by libdb-dev (Closes: #461193).
* Apply patch for jumping to code from error messages (Closes: #331659).
* Move homepage from description to Homepage field.
* Update Standards-Version to 3.7.3.
* Apply patch for user interface lag on large projects.
* New upstream release.
* Replace Build-Depends on automake1.9 by automake (>= 1:1.10)
* Remove patches included upstream:
  + 09_fix_gdb_focus.diff
* Update menu entry to use the Applications section
* Make kdevelop binNMU safe using Michael Biebl's patch (Closes: #431360).
* Apply patch to prevent integrated debugger losing focus (Closes: #427949).
* New upstream release.
* Update ltmain.sh in application templates (Closes: #351358).
* Suggest kdebase-kio-plugins to view documentation (Closes: #412108).
* Add Build-Depends on libsvn-dev to build KDevelop's SVN ioslave,
  drop Suggests on kdesdk-kio-plugins | kdesvn-kio-plugins.
* Replace Build-Depends on libdb4.3 by libdb4.4.
* Remove patches applied upstream:
  + 01_kofficepart_template.diff
  + 04_cppcurses_template.diff
  + 06_kicker_template.diff
  + 07_qmake_parser.diff
  + 08_fix_gcc43_ftbfs.diff
* Add new docs files to kdevelop-doc.install.
* Apply patch from Martin Michlmayr for GCC 4.3 FTBFS (Closes: #417343).
* Add note about Persistent Class Store in README.Debian (Closes: #409364).
* Rework Suggests and Recommends:
  + Move Suggests on kdbg, a2ps, enscript and gv.
  + Add Suggests on cmake, ruby and python.
  + Make gdb (>= 6.4) a Recommends.
* Fix kicker application template (Closes: #235867).
* Fix qmake manager parser bug introduced in 3.4.0.
* New upstream release.
  + Reformat code works after creating a new project (Closes: #330028).
  + Launching debug rebuilds the project (Closes: #375109).
  + Update application templates (Closes: #396986, #353415).
  + Fix crashes with Subversion plugin (Closes: #354158).
  + Improved breakpoints (Closes: #399870, #361860).
  + Toolbar settings are saved/restored (Closes: #246893).
* Exclude *.cdbs-orig files from application templates.
* Compile without --enable-final otherwise the build fails.
* Remove patches included upstream:
  + 02_pcsimporter_plugins_path.diff
  + 03_buildtools_plugins_path.diff
* Suggest konsole (Closes: #408628).
* Silence some lintian warnings.
* New upstream release.
  + Contains up-to-date KDE admin dir in application templates.
* Remove patches included upstream:
  + 05_support_autoconf26.diff
  + 06_xim_crash_caused_by_qt.diff
  + 07_documentation_plugins_path.diff
* Fix not-binnmuable-any-depends-all kdevelop -> kdevelop-data.
* Add Build-depends on groff-base for manpage generation
* Remove reference to kdevelop3 in README.Debian
* Add manpages for all binaries (Closes: #215250)
* Do not install /usr/bin/r++, it is useless and unusable
* Remove ${misc:Depends} from kdevelop's Depends, debconf is no longer used
* Update versioned Build-Depends on libcvsservice-dev to >= 3.5.4
* Remove unnecessary Build-Depends on po-debconf
* Add debian/patches/common to update admin/* (Closes: #345121)
* New upstream release
* Suggest khelpcenter (Closes: #273664)
* Clean up kdevelop-doc dependencies
* No longer remove X-KDE-KDevelopIDE from *.desktop files
* Fix C++ curses template project (Closes: #378336)
* Add support for autoconf 2.6 in KDE templates (Closes: #378762)
* Fix "Qt XIM bug that breaks kdevelop" (Closes: #369291)
* Fix documentation plugins installation directory (Closes: #353421, #235126)
* Remove circular dependencies (Closes: #368474)
* Merge kdevelop-plugins into kdevelop
* Add Recommends on libtool (Closes: #284694)
* Update to standards version 3.7.2
* Update versioned Build-Depends on debhelper to >= 5
* Add debian/watch file
* Relax versioned Build-Depends on libcvsservice0-dev
* Rename kdevelop3 to kdevelop (Closes: #312705, #322422)
* Drop htdig cron job and debconf questions (Closes: #296867, #258382,
  #168113, #316252)
* Fix typo in kdevelop-data description (Closes: #364139)
* Fix debian/copyright
* Move misplaced plugins from /usr/lib to /usr/lib/kde3
* Update to standards version 3.7.0
* Add icon in XPM format for kdevelop
* New upstream release
* Add Italian debconf translations (Closes: #358163, #349345)
* New upstream release
- fix code completion for external libraries (Closes: #355444, #351290)
* Build-Depends on automake1.9, not automaken
* Fix KOffice part C++ template (Closes: #345279)
* Suppress debugging output (Closes: #349878)
* Add Suggests on exuberant-ctags (Closes: #178793)
* Make kdevelop3-dev architecture 'any' due to .la files
* Move some .la files back to kdevelop3, these are for plugins
* New upstream release, build against KDE 3.5 (Closes: #347862)
* Add Jeremy Lainé to maintainers, acknowledge NMU fixes (Closes: #274966,
  #295659, #302133, #304203, #304419, #306485, #309351, #311153, #312160,
  #312161, #315170, #326883, #326929, #327710, #327730, #330037, #330038,
  #331346, #336094, #341990)
* Switch to Debian Qt/KDE team's CDBS scripts
* Update Suggests and README.Debian regarding SVN integration
* Remove explicit Build-Depends on g++-3.4 (Closes: #342991)
* Remove patches/qmake_new_class_fix.diff, included upstream
* Move development .la and .so files to kdevelop3-dev (Closes: #327904)
* Non-maintainer upload
* Remove obsolete Build-Depends on libdb4.1-dev, add libdb4.3-dev
* Update versioned Build-Depends on libcvsservice-dev
* Fix crash when disabling plugins (Closes: #306485)
* Fix cron.weekly when package is removed but not purged (Closes: #302133)
* Non-maintainer upload
* Rebuild against kdelibs4c2a (Closes: #341990)
* Add a note about SVN integration in README.Debian (Closes: #295659)
* Remove obsolete Build-Depends on libdb4.0-dev
* Fix KDevelop documentation browsing (correct DocPath in *.desktop)
* Non-maintainer upload
* Make sure kdevelop3 and kdevelop3-plugins have the same version
  (Closes: #336094)
* Non-maintainer upload
* Remove hardcoded Depends on debconf, let dh_installdebconf
  handle it by using ${misc:Depends} (Closes: #327730)
* Add Swedish debconf translation (Closes: #331346)
* Remove obsolete Build-Depends on libsvn0-dev
* Switch to Python 2.4
* Non-maintainer upload.
* work around gcc-4.0 FTBFS on some architectures
* Non-maintainer upload
* Fix kdevdesigner crash on start (Closes: #309351)
* Fix kdevassistant crash on start (Closes: #274966)
* Fix file permissions of Python/Qt examples (Closes: #330037, #330038)
* Non-maintainer upload
* New upstream release (Closes: #326883)
* Build against new Qt / KDE libraries (Closes: #326929)
* Fix lintian warnings:
 - Update to Standards-Version 3.6.2
 - Replace possible bashism "-a" by "&&" in debian/config
* Add Suggests on kdesdk-misc to provide kio_svn files
* Translation fixes:
 - Fix debian/templates.master, run debconf-updatepo (Closes: #312161)
 - Add Vietnamese debconf translation (Closes: #312160)
 - Update Brazilian translation (Closes: #304419)
* Fix adding new classes to qmake projects (Closes: #315170)
* Remove X-KDE-KDevelopIDE category from .desktop entries
* Add --disable-rpath to configure flags (Closes: #327710)
* Fix debian/menu , package is 'kdevelop3' not 'kdevelop' (Closes: #311153)
* Fix some references to 'kdevelop' in .desktop files (Closes: #304203)
* Add missing Depends on debconf (Closes: #327730)
* Fixed up the creation and removal of the symlinks for kio_svn
  files (Closes: #310684)
* Added the debconf translations back (Closes: #305276)
* Removed kpaint from the suggests field for kdevelop3
  (Closes: #308198)
* Fixed icon path (Closes: #299522)
* Added pt_BR debconf translation (Closes: #304419)
* Moved the kio_svn files out of the way. Symlinks are created for
  them if they are not already there. (Closes: #309379)
* New upstream release
* updated to released version
* reverted the Makefile changes, modified the sourcecode instead
* current cvs version
* not an offical debian version, so changed the maintainer
* had to replace the profilesdatadir in the Makefiles*
* Fixed up the problem with linking a shared library with a static
  one (Closes: #296511)
* Now the VIM editor part can no longer be loaded (Closes: #286884, #291814)
* KDevelop 2.x is not yet phased out.
* Upload to get the latest upstream version into Debian
* Added the Czech Debconf translation (Closes: #289456)
* Fix building on amd64 (Closes: #287096)
* New upstream release
* KDevelop 2.x is now phased out, the kdevelop packages now contain
  KDevelop 3.x
* Added libsvn0-dev to the build dependencies (Closes: #285873)
* Fixed the search path for the images (Closes: #236111)
* Added a versioned dependency to libcvsservice-dev 3.3.0
  (Closes: #284626)
* Changed the icon entry in kdevelop3.desktop to refer to the
  kdevelop3 icon (Closes: #239028)
* Now symbolic links are created that are named kdevelop3.mo and
  point to the kdevelop.mo files from the kde-i18n-* packages
  (Closes: #280794, #257076, #251475)
* New upstream release
* Modified debconf phrase to use a question mark (Closes: #274019)
* Changed the directory that is searched for the license headers
  (Closes: #279255)
* Changed the configure options that are used. Now all languages,
  and project types are enabled.
* Modified vcs/cvsservice/cvspartimpl.cpp to support the version of
  libcvsservice currently in Debian
* Added libcvsservice-dev to the build-dependencies (Closes: #273681)
* Added the German debconf translation (Closes: #273998)
* Added qt3-apps-dev to the build-dependencies (Closes: #273534)
* New upstream release
* Added the Japanese Debconf translation (Closes: #255057)
* Added ctags to the recommends field of the kdevelop3 package
  (Closes: #265742)
* Changed the local copy of BDB to compile with the -fPIC flag. Required
  for compiling on AMD64.
* Now the kdevelop3 package depends on automaken, rather than listing each
  version of automake, same for the build-dependencies
* Added a diversion for the file
  /usr/share/icons/hicolor/22x22/actions/save_all.png
  (Closes: #258383)
* Now libdb4.2-dev can satisfy the libdb*-dev build-dependency
* Updated the French translation (Closes: #255414)
* New upstream release
* Rewrote the kdevelop3 postinst script in Perl
* Now the global documentation index is generated in the background
  (Closes: #247123)
* Updated the menu file (Closes: #254651)
* Updated the depends field for kdevelop3 to accept automake1.8 as the
  automake package to use (Closes: #249624)
* Added libtool to the recommends field for kdevelop3 (Closes: #250597)
* New upstream release
* Removed the /usr/lib/lib*.la files from the kdevelop3-dev package
  (Closes: #243981)
* Moved the *.la files from kdevelop3-dev to kdevelop3 (Closes: #234824)
* Added the Dutch translation provided by Frans Pop <email address hidden>
  (Closes: #237817)
* New upstream release
* Added a French debconf translation provided by Eric <email address hidden>
  (Closes: #236299)
* Now the update_doc_index.sh script and the config script will only accept
  the installed version of ht://Dig if it is version 3.2.x (Closes: #234753)
* Updated the configure options so that the Qt documentation is detected
* Cleaned up the dependencies and suggests fields for all of the packages
  (Closes: #235105)
* Fixed the debconf templates using the patch from Denis Barbier
  (Closes: #234825)
* Changed the description for the kdevelop3-dev package to make it clear
  that this package is only needed for writing KDevelop plugins
  (Closes: #235248)
* New upstream release
* Updated the configure options
# The cron job no longer uses debconf
* Updated to the 3.0.0 release
* Update debian/update_doc_index.sh
  - Updated to work with the htdig 3.2.x packages
* Fixed the documentation search dialog
* Updated the htdig suggestion to htdig 3.2
* Added a debconf question to see if the global documentation index should
  be created
* Updated CVS sources
* Update debian/update_doc_index.sh
  - Will not try to compare package versions for documentation packages that
    are not installed
* Updated CVS sources
* Added the 'noopt' option to use the --enable-debug=full to configure
  option. Patch supplied by Chris Halls.
* Updated CVS sources
* Change the package names again to kdevelop3*
  - Now KDevelop 3 and KDevelop 2 can be installed at the same time
* Updated CVS sources
* Changed the packages to kdevelop* rather than gideon*
* The packages now conflict with the gideon packages
* The kdevelop package now contains all lib*.so.* and lib*.so files in
  /usr/lib
* The kdevelop-dev package now contains all lib*.la files in /usr/lib
* Updated CVS sources
* Updated the gideon-doc package to include the gideon HTML documentation
* Removed the x-pascal.desktop file from gideon-data
* Updated CVS sources
* Added the libraries without a package to the gideon package
* Updated CVS sources
* Updated CVS sources
* Updated CVS sources
* Updated the build-depends and suggests fields
  - Removed obsolete packages
* Updated CVS sources
* Added some extra arguments for when configure is run
  + Enabled all of the language support options
* Added python2.2-dev / python2.3-dev to the build depends
* Updated CVS sources
* Built against KDE 3.1.3
* Fixed to compile with GCC 3.3
* Updated CVS sources
* Updated the Debian menu entry to use the name KDevelop 3.0
* Added the Gideon icon to the Debian menu entry
* Updated CVS sources
* Updated CVS sources
* Added the URL for KDevelop to the package descriptions
* Updated CVS sources
* Updated CVS sources
* The package gideon-plugins had two dependencies on the package gideon,
  removed one of them.
* Now gideon's postinst and postrm scripts will call update-menus and
  ldconfig
* Updated CVS sources
* Added the wxwin2.4 packages to the suggests field
* Updated CVS sources
* Updated CVS sources
* Updated CVS sources
* Updated CVS sources
* Cleaned up debian/rules
* Updated CVS sources
* Fixed up debian/rules to work with the new admin/debianrules file
* Updated CVS sources
* Added the prefix to debian/rules and debian/buld-gideon
* Added stl-manual to the suggests field for gideon-doc
* Fixed up the path to the kdevelop manual
* Updated CVS sources
* Added the documentation files to the gideon-doc package
* Added the antlr header files to the gideon-dev package
* Updated CVS sources
* Fixed up the configure options for the file "debian/build-gideon"
* Moved the script update_doc_index.sh to /usr/share/gideon
* Updated CVS sources
* Added automake1.7 to the build depends and gideon depends fields
* Fixed up the update_doc_index.sh script
* Updated CVS sources
* Created a new package gideon-plugins
* Fixed up the build dependencies
* Corrected path to htsearch
* Corrected configure options in admin/debianrules
* Now creates a global documentation index on installation
* Added a weekly cron job to update the global documentation index
* Modified to support a global documentation index if there is one
* Added support for building with java support (off by default)
* Woody rebuild on KDE_3_1_BRANCH
* Fixed for KDE3.
* Removed java support as <email address hidden> suggests.
* updated configure args
* configured multiple debian doc packages for gideon doc browser
* everything except scripting support turned on.
* Initial release of development version
* Added gideon-doc.files and gideon-doc.links
* Suggest stl-manual and symlink to it
* Renamed debian doc-base entries to standard ones.
* New release
* don't compress tip database
* small fix to find kdelibs docs in setup wizard
* split into binary, doc and data packages
* added graphviz to suggests
* Updated the build-depends field
* Suggests sgmltools-lite instead of sgmltools (Closes: #96274)
* Change Maintainer (Closes: #90814)
* No longer installs extractrc (Closes: #93012)
* Suggests kdesdk-scripts
* NMU
* Fixing build-depends (Closes: #92190)
* Change Maintainer
* More upstream fixes while I'm at it
* Removed non en docs as they are provided in kde-i18n now
* Cleaned up source based off of current CVS branch
* Fix desktop file (Closes: #87802)
* Update Build-Depends
* If you install qt-doc and not qt2.2-doc this works (Closes: #88185)
* New upstream release
* Fix kde-i18n conflicts (Closes: #87381)
* New upstream cvs pull
* New upload to Debian with permission of Raphael Bossek who did the ITP
* Updating for potato/woody/sid
* New upstream release
* Updating for potato/woody/sid
* New upstream release
* Recommend kdelibs-doc
* Don't include Makefiles
* Back to old configure arguments
* Mentioned debugger in control file,
  made kdebase a dependency
* New upstream version: 1.1beta2
* Use --prefix in configure, set kde_confdir, kde_htmldir explicitly
  because of new autoconf framework
* New upstream version: 1.0
* New upstream changes
* Disabled debug - is stripped anyway
* Added further manuals to doc-base
* Call ldconfig in postinst
* configure with flag --enable-kdoc2
* configure with flag --enable-docbase
* install kdlgloader into the correct directories
* Fixed a competing problem between kderules and dh_installdocs
* New upstream changes
* Aiiiiiiiiiie!! Fixed the broken kderules file
* New upstream CVS version
* New kderules script
* Migrated from man-pages format to undocumented format
* Changed changelog versioning to fit the rest of the KDE package versioning
* Use DESTDIR mechanism instead of --with-install-root
* Do not install subdirectories of doc-base
* Initial Release

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.