lp:iptables-persistent

Created by Jonathan Wiltshire on 2010-12-30 and last modified on 2013-01-04
Get this branch:
bzr branch lp:iptables-persistent

Related bugs

Related blueprints

Branch information

Owner:
Jonathan Wiltshire
Project:
iptables-persistent
Status:
Development

Import details

Import Status: Failed

This branch is an import of the HEAD branch of the Git repository at git://robin.powdarrmonkey.net/git/iptables-persistent.

The import has been suspended because it failed 5 or more times in succession.

Last successful import was on 2014-01-12.

Import started on 2014-01-16 on pear and finished on 2014-01-16 taking 30 seconds — see the log
Import started on 2014-01-14 on pear and finished on 2014-01-14 taking 25 seconds — see the log
Import started on 2014-01-13 on pear and finished on 2014-01-13 taking 20 seconds — see the log
Import started on 2014-01-13 on pear and finished on 2014-01-13 taking 20 seconds — see the log

Recent revisions

74. By Jonathan Wiltshire on 2013-01-04

Changelog entries for 0.5.7

73. By Jonathan Wiltshire on 2013-01-04

Fix bashism in debian/iptables-persistent.init

Closes: #683789
Thanks: Andreas Rütten

72. By Andreas Rütten on 2012-08-20

Imported Debian version 0.5.6

71. By Jonathan Wiltshire on 2012-06-30

Changelog entries for 0.5.5

70. By Jonathan Wiltshire on 2012-06-30

Guard against moving rules files around in preinst/abort-upgrade

69. By Andreas Rütten on 2012-06-30

Removing Pre-Depends on dpkg

After removing dpkg-maintscript-helper from the maintainer scripts there is no need for a Pre-Depends: dpkg any more

68. By Jonathan Wiltshire on 2012-06-30

Changelog entries for 0.5.4

67. By Andreas Rütten on 2012-06-30

Fix insserv issue if upgrading from <=0.5.2

Between version 0.5.2 and 0.5.3 was a change to the runlevel configuration (#65001).
This leads to a problem for insserv during an upgrade from a version <= 0.5.2 to version 0.5.3 and above.
To fix this remove the old runlevel configuration during preinst so that the upgrade could create the new intended one during postinst.

Closes: #665814

66. By Andreas Rütten on 2012-06-30

Replace the utilisation of dpkg-maintscript-helper by a simple mv

dpkg-maintscript-helper is written to deal with conffiles and not with
configuration files
Neither the old rules file nor the new rules.v4 file are conffiles so
dpkg-maintscript-helper wouldn't handle the renaming properly

Thanks to Neil Wilson and Raphaël Hertzog for the discussion on Launchpad
Bugs #967018 #985508 to figure this out

Closes: #665813

65. By Andreas Rütten on 2012-06-30

Bump Standards-Version to 3.9.3, no changes needed

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.