Code review comment for lp:~jon-hill/spud/mac_port

Revision history for this message
Patrick Farrell (pefarrell) wrote :

a) Get rid of the print statements in diamond/bin/diamond.

b) I don't like the name "MacOS_Resources". Does it have to be called that? I'd prefer "macosx" (like "debian").

c) In diamond/bin/diamond:

-#!/usr/bin/env python

That's never going to be merged :-)

d) Logofile: can't you just put the diamond_path, "..", "diamond.png" first in the list of possible logofiles, and then unify the loop? I don't like the hard-coding special cases for Darwin when I don't think it's necessary.

e) Can you explain why you changed the input_schemafile logic?

f) Can diamond/ please live in the MacOS specific directory?

g) Again, I don't like hardcoding sys.platform == "darwin" in the plugins bit. Just add the directory to the search list; it will find it if it's there, and will skip it if it's not.

review: Needs Fixing

« Back to merge proposal