~jgrimm/ubuntu/+source/openvpn:merge-zesty-2.4.0-3ubuntu1

Last commit made on 2017-02-03
Get this branch:
git clone -b merge-zesty-2.4.0-3ubuntu1 https://git.launchpad.net/~jgrimm/ubuntu/+source/openvpn
Only Jon Grimm can upload to this branch. If you are Jon Grimm please log in for upload directions.

Branch merges

Branch information

Name:
merge-zesty-2.4.0-3ubuntu1
Repository:
lp:~jgrimm/ubuntu/+source/openvpn

Recent commits

f5d2db9... by Jon Grimm on 2017-02-03

update-maintainer

1762426... by Jon Grimm on 2017-02-03

reconstruct-changelog

cb4f5ec... by Jon Grimm on 2017-02-03

merge-changelogs

6f7894e... by Jon Grimm on 2017-02-03

Drop -* debian/control: Actually drop the initscripts dependency.
    (Closes: #804968)

Already fixed in Debian.

82e9870... by Jon Grimm on 2017-02-03

- Demote easy-rsa to Suggests (universe package).

04bcb7a... by Jon Grimm on 2017-02-03

- debian/openvpn@.service: Add "--script-security 2" similar to what got
  added to debian/openvpn.init.d ages ago (see LP: #260291).

5383df5... by Alberto Gonzalez Iniesta <email address hidden> on 2016-12-29

Import patches-unapplied version 2.4.0-3 to debian/sid

Imported using usd-importer.

Publish parent: 40192baa98d75408f105e328212d876d9bea2d39

New changelog entries:
  * You shall run debdiff even when the change is only a word, or you may find
    out the word was not there...
  * Add liblz4-dev to Build-Depends. (Closing: #849563 for real)

40192ba... by Alberto Gonzalez Iniesta <email address hidden> on 2016-12-28

Import patches-unapplied version 2.4.0-2 to debian/sid

Imported using usd-importer.

Publish parent: a893e4bbaed28557bb075d58e8dbc377980983b0

New changelog entries:
  * Enable lz4 compression (Closes: #849563).
    Thanks Laurent Bigonville for noticing.

a893e4b... by Alberto Gonzalez Iniesta <email address hidden> on 2016-12-27

Import patches-unapplied version 2.4.0-1 to debian/sid

Imported using usd-importer.

Publish parent: ced614198fbb1e40f335e8cfb7e75224cb0bbd40

New changelog entries:
  * New upstream release.
  * Refresh debian/patches to new upstream coding style.
  * debian/NEWS.Debian. Add note on removed tls-remote option
    (Closes: #848062)

ced6141... by Alberto Gonzalez Iniesta <email address hidden> on 2016-12-12

Import patches-unapplied version 2.4~rc1-2 to debian/sid

Imported using usd-importer.

Publish parent: 7b262480200a191538cad3d3cc5f518ddf5c10e2

New changelog entries:
  * Make lintian happy:
    - Update debian/watch
    - Remove .gitignore file from samples
    - Add Depends on lsb-base
    - Move bash completion file to /usr/share
    - Remove unneeded dot in manpage
    - Bump Standards-Version
  * debian/patches/kfreebsd_support: Update patch for 2.4 series.