Merge lp:~jelmer/launchpad/stacked-code-imports-newer-bzr into lp:launchpad

Proposed by Jelmer Vernooij
Status: Work in progress
Proposed branch: lp:~jelmer/launchpad/stacked-code-imports-newer-bzr
Merge into: lp:launchpad
Prerequisite: lp:~jelmer/launchpad/stacked-code-imports
Diff against target: 12 lines (+1/-1)
1 file modified
versions.cfg (+1/-1)
To merge this branch: bzr merge lp:~jelmer/launchpad/stacked-code-imports-newer-bzr
Reviewer Review Type Date Requested Status
Benji York (community) code Approve
Review via email: mp+79538@code.launchpad.net

Commit message

[r=benji][bug=485932] Support stacking code imports.

Description of the change

Update bzr to a newer snapshot, to fix a compatibility issue with the version of bzr-git in lp:~jelmer/launchpad/stacked-code-imports. This came up during QA of said branch.

To post a comment you must log in.
Benji York (benji) wrote :

This looks like a fine thing to do to me.

review: Approve (code)
Jelmer Vernooij (jelmer) wrote :

This will need some more work, since this version of bzr deprecated Branch.revision_history(), which Launchpad uses in anger.

Unmerged revisions

14037. By Jelmer Vernooij on 2011-10-17

Update bzr to newer version.

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== modified file 'versions.cfg'
2--- versions.cfg 2011-10-14 13:44:06 +0000
3+++ versions.cfg 2011-10-17 11:05:23 +0000
4@@ -7,7 +7,7 @@
5 ampoule = 0.2.0
6 amqplib = 0.6.1
7 BeautifulSoup = 3.1.0.1
8-bzr = 2.5.0dev2-r6152
9+bzr = 2.5.0dev3-r6220
10 Chameleon = 2.4.0
11 ClientForm = 0.2.10
12 cssutils = 0.9.6