lp:~jderose/kungfu/dvdsrc

Created by Jason Gerard DeRose on 2006-11-18 and last modified on 2006-11-18

This is my rewrite of the GStreamer dvdreadsrc element. It started as my work to fix a bug in the dvdreadsrc element (see http://bugzilla.gnome.org/show_bug.cgi?id=372797). But to really get the element in shape, I'm doing a rewrite from scratch. My goal is to improve the readability of the code (it had *way* too many goto's before) and to write a rigorous self-test so that it's easy to verify that the code works for a given DVD.

Get this branch:
bzr branch lp:~jderose/kungfu/dvdsrc
Only Jason Gerard DeRose can upload to this branch. If you are Jason Gerard DeRose please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Jason Gerard DeRose
Project:
KungFu
Status:
Development

Recent revisions

58. By Jason Gerard DeRose on 2006-12-08

Some cleanups, disable vmg/vts chapter number match (breaks some DVDs)

57. By Jason Gerard DeRose on 2006-12-04

redo dvdsrc_audit_dvd, use macro to improve readabilty

56. By Jason Gerard DeRose on 2006-12-04

slight improvement of dvdsrc_seekto_time()

55. By Jason Gerard DeRose on 2006-12-03

started rewrite of audit to work with all gstTime

54. By Jason Gerard DeRose on 2006-12-03

dvdsrc_close_cell should set src->sector = -1

53. By Jason Gerard DeRose on 2006-12-03

dvdsrc_close_cell should set src->sector = -1

52. By Jason Gerard DeRose on 2006-12-03

add assertion in dvdsrc_open_chapter that title is already open

51. By Jason Gerard DeRose on 2006-12-03

rename pending_clut_event,pending_lang_event to title_langEvent,chapter_clutEvent

50. By Jason Gerard DeRose on 2006-12-03

cleanup initialization and deallocation

49. By Jason Gerard DeRose on 2006-12-03

rename all src->prop_* to src->arg_*

This branch contains Public information 
Everyone can see this information.

Subscribers