Merge lp:~jbicha/unity-gtk-module/dont-depend-on-gtk2 into lp:unity-gtk-module

Proposed by Jeremy Bicha
Status: Merged
Approved by: Jeremy Bicha
Approved revision: 349
Merged at revision: 349
Proposed branch: lp:~jbicha/unity-gtk-module/dont-depend-on-gtk2
Merge into: lp:unity-gtk-module
Diff against target: 24 lines (+4/-2)
2 files modified
debian/control (+1/-2)
debian/rules (+3/-0)
To merge this branch: bzr merge lp:~jbicha/unity-gtk-module/dont-depend-on-gtk2
Reviewer Review Type Date Requested Status
Indicator Applet Developers Pending
Review via email: mp+334627@code.launchpad.net

Commit message

Don't depend on GTK+ 2 to allow these GTK+ 2 modules to be pre-installed without requiring GTK+ 2 to be installed too

To post a comment you must log in.

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== modified file 'debian/control'
2--- debian/control 2017-06-19 09:25:35 +0000
3+++ debian/control 2017-12-02 03:23:55 +0000
4@@ -33,8 +33,7 @@
5 Pre-Depends: ${misc:Pre-Depends},
6 dpkg (>= 1.15.7.2),
7 Depends: ${shlibs:Depends},
8- ${misc:Depends},
9- libgtk2.0-0 (>= 2.24.0),
10+ ${misc:Depends}
11 Description: GtkMenuShell to GMenuModel parser
12 This library converts GtkMenuShells into GMenuModels.
13
14
15=== modified file 'debian/rules'
16--- debian/rules 2013-04-30 16:41:33 +0000
17+++ debian/rules 2017-12-02 03:23:55 +0000
18@@ -28,3 +28,6 @@
19 override_dh_install:
20 find debian/tmp -name \*.la -exec rm {} \;
21 dh_install --fail-missing
22+
23+override_dh_shlibdeps:
24+ dh_shlibdeps -- -xlibgtk2.0-0

Subscribers

People subscribed via source and target branches