~janisozaur/openloco/+git/debian:optional

Last commit made on 2021-03-24
Get this branch:
git clone -b optional https://git.launchpad.net/~janisozaur/openloco/+git/debian

Branch merges

Branch information

Name:
optional
Repository:
lp:~janisozaur/openloco/+git/debian

Recent commits

265ab11... by Aaron

Update src/OpenLoco/Core/Optional.hpp

2b80a90... by =?utf-8?q?Micha=C5=82_Janiszewski?= <email address hidden>

Use __has_include for <optional> detection

d05b492... by YetiWiz <email address hidden>

Disable scenery interaction when hidden and update flag names (#787)

67f2c05... by Duncan <email address hidden>

Fix mistake in rebase and orderskip (#811)

a44a9e3... by =?utf-8?b?zrZlaCBNYXR0?= <email address hidden>

Use std::pair for pair in Audio code (#808)

5c90cdb... by Aaron

Centralise ownership of gameSpeed variable in OpenLoco.cpp (#806)

f5fd3c3... by Duncan <email address hidden>

Vehicle update2 Part 1a: Water motion update (#758)

* Implement updateWaterMotion

* Prevent npe's

* Actually use the defined flags

* use surface helper function

* Fix speed bug and rebase issues

* Fix calc

* Fix crash

* Split off move

* Fix targeting of vehicle

* Use correct acceleration and fix rebase issues

* Use reference as we are modifying the tile

7518897... by Duncan <email address hidden>

Fix speed based vehicle animations such as hydrofoils (#807)

When the vehicle reaches its top speed an invalid value for the animation would be set.
Mistake was made during implementation.

b3d68cf... by Duncan <email address hidden>

Vehicle update2 Part 1b: Order functions (#747)

* Implement checkIfAtOrderStation

* Implement advanceNextRoutableOrder

* Allow conversion to station base

* Switch to a cyclic order table

* Keep ci's happy

* Definitions on the move again

c9f1444... by Peter Gaal <email address hidden>

Implement 0x004B6572 - vehicle rename game command (#792)

* Implement 0x004B6572 - vehicle rename game command

* Rename variables and add lookup table

* Add default string ID map depending on vehicle type

Also use string_id types for string ID variables

* Use 2 arrays and copy data with memcpy to string

Also get rid of memory bound array (the memory location is not accessed in different function)

* Make renameStringBuffer and stringFormatBuffer local

* Rename stringFormatBuffer to existingVehicleName

* Removed address comments, replaced 0 with StringIds::empty

Also added documentation on a function with explanation of registers.

* Add documentation for return value

Co-authored-by: Duncan <email address hidden>