Merge lp:~james-w/python-oops-tools/restfulclient-cert into lp:python-oops-tools

Proposed by James Westby on 2012-12-06
Status: Merged
Approved by: James Westby on 2012-12-06
Approved revision: 53
Merged at revision: 52
Proposed branch: lp:~james-w/python-oops-tools/restfulclient-cert
Merge into: lp:python-oops-tools
Diff against target: 0 lines
To merge this branch: bzr merge lp:~james-w/python-oops-tools/restfulclient-cert
Reviewer Review Type Date Requested Status
James Westby (community) Approve on 2012-12-06
Review via email: mp+138572@code.launchpad.net

Commit message

Set the version of lazr.restfulclient to pick up the cert fixes.

Description of the change

Hi,

In order to fix the prune script we need to use the latest lazr.restfulclient
that includes my fix to force the system CA certs. This ensures we are using
that version.

Thanks,

James

To post a comment you must log in.
James Westby (james-w) wrote :

Calling this trivial.

Thanks,

James

review: Approve
Launchpad PQM Bot (launchpad-pqm) wrote :

The attempt to merge lp:~james-w/python-oops-tools/restfulclient-cert into lp:python-oops-tools failed.Below is the output from the failed tests.

find . -type f -name '*.py[co]' -exec rm -f {} \;
rm -f bin/buildout
rm -f src/oopstools/settings.py
bzr clean-tree --unknown --force
bzr up download-cache
python bootstrap.py \
  --setup-source=download-cache/ez_setup.py \
  --download-base=download-cache/dist --eggs=eggs
Download error: [Errno 111] Connection refused -- Some packages may not be found!
Download error: [Errno 111] Connection refused -- Some packages may not be found!
Generated script '/home/pqm/pqm-workdir/oops-tools/bin/buildout'.
bin/buildout configuration:db-port=5433
Develop: '/home/pqm/pqm-workdir/oops-tools/.'
Getting distribution for 'lazr.restfulclient==1.13.2'.

W: line 4 [buildbot-staging]: Deprecated key 'location' used
I: This option will be removed in the future; please update your configuration
W: line 2 [pqm]: Deprecated key 'location' used
I: This option will be removed in the future; please update your configuration
W: line 3 [pqm-oops-tools]: Deprecated key 'location' used
I: This option will be removed in the future; please update your configuration
W: line 1 [precise]: Deprecated key 'location' used
I: This option will be removed in the future; please update your configuration
I: [pqm-oops-tools chroot] Running command: "cd /home/pqm/pqm-workdir/oops-tools && make check"
Nothing to delete.
+N dist/django-openid-auth_0.4.tar.gz
+N dist/lazr.restful-0.19.10.tar.gz
+N dist/lazr.restfulclient-0.13.2.tar.gz
All changes applied successfully.
Updated to revision 533 of branch http://bazaar.launchpad.net/~launchpad/lp-source-dependencies/trunk
While:
  Installing.
  Getting section filetemplates.
  Initializing part filetemplates.
  Getting distribution for 'lazr.restfulclient==1.13.2'.
Error: Couldn't find a distribution for 'lazr.restfulclient==1.13.2'.
make: *** [bin/buildout] Error 1

53. By James Westby on 2012-12-06

Fix the version number.

James Westby (james-w) wrote :

Err, it's trivial but I typoed the version number.

Thanks,

James

review: Approve

Preview Diff

Empty

Subscribers

People subscribed via source and target branches

to all changes: