Code review comment for lp:~jameinel/bzr/1.16-bencode-compat-385212

John A Meinel (jameinel) wrote :

This adds a backwards compatibility code with deprecation for "bzrlib.util.bencode"

It is a small helper for both bzr-gtk and the MySQL plugin that used bzrlib.util.bencode directly.

Importing the function raises the deprecation warning. The other possibility was to manually wrap all the imported objects with deprecations, but I thought this would be easier.

« Back to merge proposal