lp:~ignacio-nin/percona-server/5.5-rpm-obsoletes

Created by Ignacio Nin on 2013-10-15 and last modified on 2013-10-16
Get this branch:
bzr branch lp:~ignacio-nin/percona-server/5.5-rpm-obsoletes
Only Ignacio Nin can upload to this branch. If you are Ignacio Nin please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Recent revisions

559. By Ignacio Nin on 2013-10-16

Remove the Obsoletes: lines from the shared package

Due to every version of Percona Server (5.1, 5.5, 5.6 and PXC) having a
shared library package that Obsoletes: mysql-libs, upgrading from a
mysql-libs installation would use any available version to obsolete
mysql-libs, when in fact the intended package to replace it is the 5.0
version for CentOS 5 and the 5.1 version for CentOS 6.

After installing the percona repository, a yum upgrade would try to
replace mysql-libs with Percona-XtraDB-Cluster-shared-compat, which
would confuse users.

Solve this by removing all the Obsoletes: lines from the packages that
are not intended to replace mysql-libs *except when explicitely
installed*, and in the correct packages only Obsolete: for the correct
versions of CentOS.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:percona-server/5.6
This branch contains Public information 
Everyone can see this information.

Subscribers