Code review comment for lp:~humpolec-team/humpolec/UbuntuInstaller-ota

Revision history for this message
Yuan-Chen Cheng (ycheng-twn) wrote :

line 35: why not move BUSYBOX=busybox up and
        cd `${BUSYBOX} dirname $1`

line 104: what's "user's data" did you mean ?
        user data that android create, user data that ubuntu user create or ?

line 335: will it better to name something like IS_UBUNTU_UPGRADABLE
        instead of UPGRADE_UBUNTU

line 425: can you add comment on the logic ? like
        As working dir in /data, blalal
        As working dir in /cache, blalal

line 1140: please also add comment like line 425. (or refer to it)

line 1082, "getApplication()." can be removed.

line 1034: UbuntuInstallService.isUpgradeable
        check command file against /cache works in this case, but it
        does not necessary means upgradable (it might means some
        error on internal status keeping) since normal install
        could have command file in /cache if the apk is installed
        in ROM.

        should we rename this function to something else ?

Maybe we should stop adding new code and try to document the state machine.
Maybe more re-factor then.

review: Needs Fixing

« Back to merge proposal