Merge lp:~hopem/charms/trusty/glance/lp1499435 into lp:~openstack-charmers-archive/charms/trusty/glance/next

Proposed by Edward Hope-Morley on 2015-09-24
Status: Merged
Merged at revision: 141
Proposed branch: lp:~hopem/charms/trusty/glance/lp1499435
Merge into: lp:~openstack-charmers-archive/charms/trusty/glance/next
Diff against target: 20 lines (+5/-6)
1 file modified
hooks/glance_utils.py (+5/-6)
To merge this branch: bzr merge lp:~hopem/charms/trusty/glance/lp1499435
Reviewer Review Type Date Requested Status
Liam Young 2015-09-24 Approve on 2015-09-25
Review via email: mp+272290@code.launchpad.net
To post a comment you must log in.

charm_lint_check #10690 glance-next for hopem mp272290
    LINT OK: passed

Build: http://10.245.162.77:8080/job/charm_lint_check/10690/

charm_unit_test #9873 glance-next for hopem mp272290
    UNIT OK: passed

Build: http://10.245.162.77:8080/job/charm_unit_test/9873/

charm_amulet_test #6750 glance-next for hopem mp272290
    AMULET OK: passed

Build: http://10.245.162.77:8080/job/charm_amulet_test/6750/

charm_amulet_test #6763 glance-next for hopem mp272290
    AMULET OK: passed

Build: http://10.245.162.77:8080/job/charm_amulet_test/6763/

Liam Young (gnuoy) wrote :

Approve

review: Approve

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== modified file 'hooks/glance_utils.py'
2--- hooks/glance_utils.py 2015-09-22 13:39:12 +0000
3+++ hooks/glance_utils.py 2015-09-24 16:42:24 +0000
4@@ -305,12 +305,11 @@
5 raise Exception("IPv6 is not supported in the charms for Ubuntu "
6 "versions less than Trusty 14.04")
7
8- # NOTE(xianghui): Need to install haproxy(1.5.3) from trusty-backports
9- # to support ipv6 address, so check is required to make sure not
10- # breaking other versions, IPv6 only support for >= Trusty
11- if ubuntu_rel == 'trusty':
12- add_source('deb http://archive.ubuntu.com/ubuntu trusty-backports'
13- ' main')
14+ # Need haproxy >= 1.5.3 for ipv6 so for Trusty if we are <= Kilo we need to
15+ # use trusty-backports otherwise we can use the UCA.
16+ if ubuntu_rel == 'trusty' and os_release('glance') < 'liberty':
17+ add_source('deb http://archive.ubuntu.com/ubuntu trusty-backports '
18+ 'main')
19 apt_update()
20 apt_install('haproxy/trusty-backports', fatal=True)
21

Subscribers

People subscribed via source and target branches