Code review comment for lp:~heirecka/inkscape/use-pkg_prog_pkg_config

Revision history for this message
jazzynico (jazzynico) wrote :

Tested successfully with gtkspell-2 on Xubuntu 15.10, Inkscape trunk rev. 14674.

Unfortunately, it doesn't work with gtkspell-3 (--enable-gtk3-experimental configure option) due to an incorrect package name (gtkspell-3.0 doesn't exist). To fix it, I had to use the following code:

if pkg-config --exists gtkspell3-3.0; then
 ink_spell_pkg=gtkspell3-3.0

I have just checked with other Gnu/Linux distros, and it seems the gtkspell3-3.0 package name is consistent.

review: Needs Fixing

« Back to merge proposal