Code review comment for lp:~hasselmm/appmenu-gtk/gtk3

Revision history for this message
Michael Terry (mterry) wrote :

Looks great. I have two comments:

1) Do we really need --with-gtk3? Seems like --with-gtk2 is enough.

2) You need to add the following in src/bridge.c:

+#if GTK_CHECK_VERSION(3, 0, 0)
+#include <libdbusmenu-gtk3/menuitem.h>
+#include <libdbusmenu-gtk3/parser.h>
+#else
 #include <libdbusmenu-gtk/menuitem.h>
 #include <libdbusmenu-gtk/parser.h>
+#endif

Unfortunately (and this is my fault), the headers use different directories for gtk2/gtk3.

review: Needs Fixing

« Back to merge proposal