Merge lp:~gpiccoli/britney/hints-ubuntu into lp:britney

Proposed by Guilherme G. Piccoli on 2019-08-19
Status: Needs review
Proposed branch: lp:~gpiccoli/britney/hints-ubuntu
Merge into: lp:britney
Diff against target: 603 lines (+560/-0)
7 files modified
adconrad (+62/-0)
apw (+49/-0)
laney (+31/-0)
pitti (+42/-0)
sil2100 (+8/-0)
ubuntu-release (+301/-0)
vorlon (+67/-0)
To merge this branch: bzr merge lp:~gpiccoli/britney/hints-ubuntu
Reviewer Review Type Date Requested Status
Guilherme G. Piccoli (community) Approve on 2019-08-20
Ubuntu Release Team 2019-08-19 Pending
Review via email: mp+371479@code.launchpad.net

Description of the change

Adding makedumpfile as badtest for ppc64el, according to LP #1681909.

To post a comment you must log in.
Guilherme G. Piccoli (gpiccoli) wrote :

This was already merged, package was released! Thanks vorlon/slashd for all the help

review: Approve

Unmerged revisions

3810. By Guilherme G. Piccoli on 2019-08-19

badtest makedumpfile (ppc64el)

3809. By Steve Langasek on 2019-08-19

bump linux hint

3808. By Steve Langasek on 2019-08-16

bump statsmodels/armhf hint

3807. By Andy Whitcroft on 2019-08-15

kernels: release copy-forward kernel in step with primaries

Signed-off-by: Andy Whitcroft <email address hidden>

3806. By Andy Whitcroft on 2019-08-15

gcc-9/binutils -- remaining failures are kernel related

The issues here are related to missmatch of dkms package versions with
the kernel. We should skip that part of the test (but currently do not).
There are no other failures for these packages for force-skiptest then.

Signed-off-by: Andy Whitcroft <email address hidden>

3805. By Steve Langasek on 2019-08-15

Merge lp:~rbalint/britney/autopkgtest-eoan-hints

3804. By Steve Langasek on 2019-08-15

Merge lp:~rbalint/britney/autopkgtest-eoan-hints

3803. By Steve Langasek on 2019-08-15

badtest prometheus-blackbox-exporter/i386

3802. By Steve Langasek on 2019-08-15

badtest golang-github-jaytaylor-html2text-dev

3801. By Steve Langasek on 2019-08-14

bump mothur hint

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== added file 'adconrad'
2--- adconrad 1970-01-01 00:00:00 +0000
3+++ adconrad 2019-08-19 19:43:36 +0000
4@@ -0,0 +1,62 @@
5+# Regressed in release pocket:
6+force-badtest node-platform/1.3.5-1/s390x
7+force-badtest node-yargs/10.0.3-2
8+# These tests fail now that s390x provides isolation-machine:
9+force-badtest dahdi-linux/all/s390x
10+# Depends on x86-only libngs-java
11+force-badtest beagle/all/armhf beagle/all/ppc64el beagle/all/s390x
12+force-badtest fastqc/all/armhf fastqc/all/ppc64el fastqc/all/s390x
13+# Depends on stuff no longer built:
14+force-badtest libcatmandu-store-mongodb-perl/all/i386
15+force-badtest roary/all/armhf roary/all/s390x
16+force-badtest pbgenomicconsensus/all/i386
17+# Not built on i386, the test might not work:
18+force-badtest pbh5tools/all/i386
19+# Mysteriously passed once, and never again:
20+force-badtest vagrant-libvirt/0.0.45-2/amd64 vagrant-libvirt/0.0.45-2/s390x
21+# debootstrap's tests are a flaming heap in containers:
22+force-badtest debootstrap/all/s390x
23+# fails only on lxc hosts
24+force-badtest sbuild/all/armhf
25+# The libreoffice failures are clearly not kio's fault:
26+force-skiptest kio/5.53.0-0ubuntu1
27+# Upstream ticket filed: https://github.com/citusdata/postgresql-hll/issues/67
28+force-badtest postgresql-hll/2.12-3
29+# Beta unblocks:
30+unblock ukui-greeter/1.1.8-0ubuntu1
31+# Release unblocks:
32+unblock mozjs60/60.2.3-3
33+unblock multipath-tools/0.7.4-2ubuntu8
34+unblock gst-plugins-base1.0/1.15.90-1
35+unblock gst-plugins-ugly1.0/1.15.90-1
36+unblock gst-python1.0/1.15.90-1
37+unblock gst-rtsp-server1.0/1.15.90-1
38+unblock gstreamer-editing-services1.0/1.15.90-1
39+unblock gstreamer-vaapi/1.15.90-1
40+unblock gstreamer1.0/1.15.90-1ubuntu1
41+unblock sip4/4.19.15+dfsg-1ubuntu1
42+unblock gst-libav1.0/1.15.90-1
43+unblock gst-plugins-bad1.0/1.15.90-1ubuntu1
44+unblock gst-plugins-good1.0/1.15.90-1ubuntu1
45+unblock ubuntukylin-meta/0.36
46+unblock linux-restricted-modules/5.0.0-13.14
47+unblock linux-signed/5.0.0-13.14
48+unblock linux-meta/5.0.0.13.14
49+unblock linux/5.0.0-13.14
50+unblock parted/3.2-25
51+unblock unattended-upgrades/1.10ubuntu5
52+unblock apparmor/2.13.2-9ubuntu6
53+unblock debian-installer/20101020ubuntu570
54+unblock base-files/10.1ubuntu9
55+unblock thunar/1.8.4-1ubuntu1
56+unblock gnome-shell-extension-ubuntu-dock/64ubuntu7
57+unblock ukui-control-center/1.1.7.1-0ubuntu1
58+unblock pulseaudio/1:12.2-2ubuntu3
59+force-skiptest pulseaudio/1:12.2-2ubuntu3
60+unblock libxslt/1.1.32-2ubuntu0.1
61+force-skiptest libxslt/1.1.32-2ubuntu0.1
62+# Remaining failures are not apparmor's fault:
63+force-skiptest apparmor/2.13.2-9ubuntu6
64+# vim and debootstrap have nothing to do with docker's lack of lxd images:
65+force-skiptest vim/2:8.1.0320-1ubuntu4
66+force-skiptest debootstrap/1.0.114ubuntu1
67
68=== added file 'apw'
69--- apw 1970-01-01 00:00:00 +0000
70+++ apw 2019-08-19 19:43:36 +0000
71@@ -0,0 +1,49 @@
72+# Easy hint to migrate kernels, or to check what is missing
73+easy debian-installer/20101020ubuntu577 linux/5.0.0-20.21 linux-meta/5.0.0.20.21 linux-signed/5.0.0-20.21 linux-restricted-modules/5.0.0-20.21
74+
75+# While copying kernels forward from xenial it rather too easy for linux
76+# to slip out without the testing being fully reviewed. As britney is not
77+# able to track previous failures correctly for kernels.
78+#block linux
79+block linux-aws
80+block linux-azure
81+block linux-gcp
82+block linux-kvm
83+block linux-oem
84+block linux-oem-osp1
85+block linux-oracle
86+block linux-raspi2
87+block linux-snapdragon
88+
89+# Development kernel unblocks:
90+#unblock linux/5.0.0-20.21
91+unblock linux-aws/5.0.0-1012.13
92+unblock linux-azure/5.0.0-1014.14
93+unblock linux-gcp/5.0.0-1013.13
94+unblock linux-kvm/5.0.0-1013.14
95+unblock linux-oem/4.15.0-1050.57
96+unblock linux-oem-osp1/5.0.0-1018.20
97+unblock linux-oracle/4.15.0-1018.20
98+unblock linux-raspi2/5.0.0-1014.14
99+unblock linux-snapdragon/5.0.0-1018.19
100+
101+# linux-raspi on arm64 fails in such a way that it is not identified as a failure. Therefore
102+# the tests never complete and the package can never migrate. skiptest this once the armhf
103+# testing is complete and good.
104+force-skiptest linux-meta-raspi2/4.18.0.1005.2
105+
106+#
107+# arm* removed in zesty-proposed hint in-progress tests against them.
108+force-badtest sunpy/all/armhf
109+
110+# python-pysam does not (and never has) built on armhf and i386
111+force-badtest python-pysam/all/armhf python-pysam/all/i386
112+
113+# 14-feb-2017: armhf test non-installable
114+force-badtest python-cobra/all/armhf
115+
116+# linux-gcp/armhf -- does not even build here, so tests here cannot be relevant
117+force-badtest linux-gcp/all/armhf
118+
119+# Skip an unrelated linux/s390x test failure.
120+force-skiptest gcc-7/7.3.0-29ubuntu1
121
122=== added file 'arges'
123=== added file 'brian-murray'
124=== added file 'freeze'
125=== added file 'laney'
126--- laney 1970-01-01 00:00:00 +0000
127+++ laney 2019-08-19 19:43:36 +0000
128@@ -0,0 +1,31 @@
129+# remaining failures (network-manager/amd64 oss4/x86)
130+force-skiptest glib2.0/2.61.1-2
131+
132+# seems broken in release & for a while
133+force-badtest gerris/20131206+dfsg-18build2/armhf
134+
135+# ditto, not leaks but something to do with SVGs
136+force-badtest php-imagick/3.4.3~rc2-2ubuntu6
137+
138+# isolation-machine, needs thunderbird which isn't available
139+force-badtest firejail/all/s390x
140+
141+# passed once by fluke on armhf it seems
142+
143+force-badtest ostree/all/armhf
144+
145+# mongo isn't built for armhf/i386 any more
146+force-badtest flask-mongoengine/all/i386
147+force-badtest mongodb/all/i386
148+force-badtest flask-mongoengine/all/armhf
149+force-badtest mongodb/all/armhf
150+
151+# FTBFS, no package on this arch, unclear how it passed(!)
152+force-badtest python-fitsio/all/armhf
153+
154+# Field3D only supports Ogawa-backed files on little-endian systems.
155+force-badtest field3d/all/s390x
156+
157+# bad test which fails if the test runner can't reach the public Internet.
158+# LP: #1427982
159+force-badtest libtest-requiresinternet-perl/0.05-2
160
161=== added file 'pitti'
162--- pitti 1970-01-01 00:00:00 +0000
163+++ pitti 2019-08-19 19:43:36 +0000
164@@ -0,0 +1,42 @@
165+# new PEP-8 errors with zesty's newer pep8 tool; don't bump!
166+force-badtest rpmlint/1.9-6
167+
168+# segfaults on 32 bit
169+force-badtest baloo-kf5/all/i386 baloo-kf5/all/armhf
170+
171+# started failing with move to lxd on armhf
172+force-badtest pbuilder/all/armhf
173+
174+#
175+# blacklisted for test runs as they kill testbeds
176+#
177+#
178+force-badtest stress-ng/blacklisted/ppc64el
179+
180+#
181+# flaky, universe, nobody cares in Ubuntu
182+#
183+#
184+force-badtest beets/all/s390x
185+# times out
186+force-badtest c2esp/all/armhf
187+force-badtest elasticsearch-curator/5.2.0-1
188+# takes painfully long, times out on armhf, testing on x86 is enough
189+force-badtest epson-inkjet-printer-escpr/all/armhf
190+force-badtest gjs/all/s390x
191+force-badtest libcgi-application-plugin-captcha-perl/0.04-2
192+# flaky on s390x, alwaysfail on others
193+force-badtest palabos/s390x/all
194+force-badtest pdns/all
195+force-badtest php-horde-http/2.1.7-3
196+force-badtest php-horde-icalendar/all/armhf php-horde-icalendar/all/i386
197+force-badtest python-publicsuffix/1.1.0-2
198+force-badtest pyzmq/all/s390x pyzmq/all/armhf
199+force-badtest rexical/1.0.5-2build1
200+force-badtest ruby-amq-protocol/all/s390x
201+force-badtest ruby-augeas/1:0.5.0-3build6
202+# Debian #816161
203+force-badtest ruby-minitest-excludes/2.0.0-1
204+force-badtest ruby-mixlib-shellout/2.2.6-1
205+force-badtest ruby-sshkit/all/s390x
206+force-badtest zodb/1:3.10.7-1build1/ppc64el zodb/1:3.10.7-1build1/s390x
207
208=== added file 'racb'
209=== added file 'raof'
210=== added file 'sil2100'
211--- sil2100 1970-01-01 00:00:00 +0000
212+++ sil2100 2019-08-19 19:43:36 +0000
213@@ -0,0 +1,8 @@
214+# Some more R badtests that are failing, some of which basically from the start
215+force-badtest r-cran-memoise/1.1.0-2/armhf
216+
217+# Temporarily badtest the current release puppet as now it's failing due to a deprecation warning printed out to stderr. This is fixed in the -proposed puppet but that one still needs some work to be migrate-able.
218+force-badtest puppet/5.4.0-2ubuntu3
219+
220+# virtualbox stopped providing its binary package on i386, on which the ext-pack tests depend on.
221+force-badtest virtualbox-ext-pack/all/i386
222
223=== added file 'stefanor'
224=== added file 'stgraber'
225=== added file 'tjaalton'
226=== added file 'ubuntu-release'
227--- ubuntu-release 1970-01-01 00:00:00 +0000
228+++ ubuntu-release 2019-08-19 19:43:36 +0000
229@@ -0,0 +1,301 @@
230+# https://trello.com/c/ogFUzPsO/33-cant-install-snaps-in-autopkgtest-lxd-containers
231+force-badtest kopano-webapp/all/armhf
232+
233+# passed previously in containers, now fails everywhere
234+force-badtest ruby-fakeweb/1.3.0+git20170806+dfsg1-1.1
235+
236+# regressed in release
237+force-badtest adequate/0.15.1ubuntu5
238+force-badtest apt-clone/0.4.1ubuntu2
239+force-badtest casync/2+20180321-2.1
240+force-badtest colord/1.4.3-4/i386
241+force-badtest colord/1.4.3-4
242+force-badtest cryfs/0.9.10-2/i386
243+force-badtest debci/2.0
244+## fails to build on armhf: https://github.com/codahale/bcrypt-ruby/issues/201
245+force-badtest diaspora-installer/0.7.6.1+debian1/ppc64el diaspora-installer/0.7.6.1+debian1/armhf
246+##
247+force-badtest fdroidserver/1.1.1-1ubuntu1
248+## regressed due to iproute2 5.1.0
249+force-badtest firewalld/0.6.3-5ubuntu4
250+## behaves the same as 0.5.0-1 under linux 4.15 and 5.0 with old and new fuse:
251+force-badtest fuse-zip/0.6.0-0ubuntu1
252+## requires netstat without dependency
253+force-badtest gitlab-workhorse/7.6.0+debian-1
254+## broken with linux 5.2.0 headers
255+force-badtest glibc/2.29-0ubuntu3
256+##
257+force-badtest htslib/1.9-10/i386
258+force-badtest kpatch/0.5.0-0ubuntu2/amd64
259+force-badtest kservice/5.60.0-0ubuntu1/s390x
260+force-badtest libfile-userconfig-perl/0.06-4/i386
261+force-badtest libterm-filter-perl/0.03-2/arm64 libterm-filter-perl/0.03-2/i386
262+force-badtest libtest-valgrind-perl/1.19-1/ppc64el
263+## broken handling of zfs-linux download from the archive
264+force-badtest linux/5.2.0-8.9 linux/5.2.0-10.11
265+## broken with new gcc, needs rebase on 5.2
266+force-badtest linux-kvm/5.0.0-1011.12 linux-kvm/5.0.0-1013.14
267+##
268+force-badtest node-gulp-coffee/2.3.4-1/arm64
269+force-badtest mira/4.9.6-4build1/ppc64el
270+force-badtest mothur/1.41.21-1/i386 mothur/1.42.1-1/i386
271+##
272+force-badtest octave-image/2.10.0-2/amd64 octave-image/2.10.0-2/i386 octave-image/2.10.0-2/ppc64el
273+force-badtest packer/1.0.4+dfsg-1
274+## autopkgtest depends on procenv not being ftbfs, procenv regressed due to toolchain changes
275+force-badtest pbuilder/0.230.4
276+##
277+force-badtest php-horde-exception/2.0.8-2ubuntu1
278+force-badtest php-horde-util/2.5.8-1ubuntu1
279+force-badtest php-horde-serialize/2.0.5-3ubuntu1
280+force-badtest php-horde-support/2.2.0-1ubuntu1
281+force-badtest php-horde-view/2.0.6-3ubuntu1
282+force-badtest php-pimple/3.0.2-2ubuntu1
283+force-badtest php-text-password/1.2.1-2
284+force-badtest profnet/1.0.22-6
285+force-badtest prometheus/2.7.1+ds-3
286+# uninstallable
287+force-badtest prometheus-blackbox-exporter/0.13.0+ds-2/i386
288+force-badtest qbzr/0.23.2-6/ppc64el qbzr/0.23.2-6/s390x qbzr/0.23.2-6/i386
289+force-badtest reprotest/0.7.8/i386
290+force-badtest ruby-encryptor/3.0.0-2
291+force-badtest ruby-jquery-rails/4.3.3-1
292+force-badtest ruby-rack/2.0.6-3
293+force-badtest ruby-rails-assets-blueimp-gallery/2.33.0-1
294+force-badtest ruby-rails-assets-diaspora-jsxc/0.1.5+dfsg2~develop.7-3
295+force-badtest ruby-rspec-puppet/2.6.1-1
296+## autopkgtest depends on procenv not being ftbfs, procenv regressed due to toolchain changes
297+force-badtest sbuild/0.78.1-2ubuntu1
298+##
299+force-badtest sextractor/2.19.5+dfsg-6/amd64
300+force-badtest sfepy/2018.1-4ubuntu1/armhf
301+force-badtest spice/0.14.2-0ubuntu2/ppc64el
302+force-badtest svgpp/1.2.3+dfsg1-6/s390x
303+## https://twistedmatrix.com/trac/ticket/9495
304+force-badtest twisted/18.9.0-3
305+##
306+force-badtest ubuntu-make/18.09+disco1
307+force-badtest unrar-free/1:0.0.1+cvs20140707-4/ppc64el
308+## cloud image seems to be tainted and contains old, incompatible kernel headers; hint should be dropped once fixed
309+force-badtest v4l2loopback/0.12.1-1ubuntu1/i386
310+## video pre-dependencies dropped from s390x kernel
311+force-badtest v4l2loopback/all/s390x
312+##
313+force-badtest vagrant-lxc/1.4.3-1/amd64
314+force-badtest vuls/0.6.1-1
315+## toolchain-triggered build regression
316+force-badtest webcamoid/8.5.0+dfsg-2/ppc64el webcamoid/8.6.1+dfsg-2/ppc64el
317+##
318+force-badtest yorick/2.2.04+dfsg1-10
319+
320+# skip tests that fail now that s390x has full VMs
321+force-badtest vagrant-lxc/1.4.3-1/s390x
322+force-badtest python-docker/3.4.1-4/s390x
323+force-badtest libdata-uuid-libuuid-perl/0.05-3build2/s390x
324+# Was skipped in lxc, never passed in a vm, questionable usefulness on s390x/ppc64el given it tests usb camera...
325+force-badtest gvfs/all/s390x
326+
327+# flaky due to dependency on network resources
328+force-badtest vagrant-mutate/1.2.0-4/armhf
329+
330+# Only "passed" because of an exit 0 on 32-bits, now fails to install test deps:
331+force-badtest zfs-linux/all/i386 zfs-linux/all/armhf
332+
333+# tests broken with proxy
334+force-badtest golang-github-hashicorp-atlas-go/0.0~git20170808.8261ea0-3
335+force-badtest ruby-webmock/3.4.2-1
336+
337+# primer3 builds binary-all package but binary-arch package removed on architecture
338+force-badtest primer3/2.4.0-2/s390x
339+# build binary-all packages but binary-arch package removed on architecture
340+force-badtest barrnap/all/i386
341+force-badtest camitk/all/armhf camitk/all/arm64 camitk/all/ppc64el camitk/all/s390x
342+force-badtest roary/all/i386
343+
344+# flaky
345+force-badtest bambam/1.0.1+dfsg-1/s390x
346+force-badtest bdfproxy/0.3.9-3/amd64
347+force-badtest jsurf-alggeo/0.4.1+ds-3
348+force-badtest saods9/8.0.1+repack-2/arm64 saods9/8.0.1+repack-2/amd64
349+## possibly borderline memory usage; may benefit from huge_packages treatment
350+force-badtest scikit-learn/0.20.2+dfsg-6/amd64
351+## races the launch of an X window
352+force-badtest xmobar/0.29.4-2
353+
354+# passed once as a fluke
355+force-badtest aptdaemon/1.1.1+bzr982-0ubuntu28/arm64
356+force-badtest barrnap/0.9+dfsg-1/armhf
357+force-badtest dask.distributed/1.25.0+ds.1-1/s390x
358+force-badtest libgd2/2.2.5-5.2/amd64
359+force-badtest makedumpfile/all/s390x
360+
361+# never passed, previously neutral, now failing
362+force-badtest mysql-connector-c++/1.1.12-4ubuntu1/arm64 mysql-connector-c++/1.1.12-4ubuntu1/s390x
363+
364+# architectures not available; tests never should have passed
365+force-badtest nanopolish/all/arm64 nanopolish/all/armhf nanopolish/all/ppc64el nanopolish/all/s390x
366+
367+# superseded by python-ldap
368+force-badtest python-pyldap/all
369+
370+# this is seemingly always-failed from the history we can see but is reporting
371+# regression at least on patch. Hint this until it is investigated.
372+force-badtest nvidia-graphics-drivers-340/all/armhf
373+
374+# fails to start if it cannot bind to [::]:53, which conflicts with systemd-resolved; LP: #1764327
375+force-badtest gdnsd/2.4.2-1
376+
377+# only doc package on these archs
378+force-badtest julia/all/i386
379+force-badtest pyfai/all/ppc64el pyfai/all/s390x
380+force-badtest pymca/all/ppc64el pymca/all/s390x
381+force-badtest kicad/all/ppc64el
382+
383+# binaries removed on arch
384+force-badtest trnascan-se/all/arm64 trnascan-se/all/armhf trnascan-se/all/ppc64el trnascan-se/all/s390x
385+force-badtest gudhi/all/arm64
386+force-badtest libnanomsg-raw-perl/all/armhf
387+force-badtest golang-github-go-debos-fakemachine/all/arm64 golang-github-go-debos-fakemachine/all/i386
388+force-badtest macsyfinder/1.0.5-2/arm64 macsyfinder/1.0.5-2/armhf macsyfinder/1.0.5-2/ppc64el macsyfinder/1.0.5-2/s390x macsyfinder/1.0.5-3/arm64 macsyfinder/1.0.5-3/armhf macsyfinder/1.0.5-3/ppc64el macsyfinder/1.0.5-3/s390x
389+
390+# assumes /etc/init.d/networking
391+force-badtest pcs/0.10.1-2
392+
393+# flaky / test timeouts
394+force-badtest mercurial/4.8.2-1ubuntu4/arm64
395+
396+# Custom kernels can never pass tests, as the right meta is not
397+# included, and some of these may not even run in scalingstack These
398+# are therefore false-regressions, as triggered by e.g. pciutils -- xnox
399+force-badtest linux-aws/all
400+force-badtest linux-azure/all
401+force-badtest linux-gcp/all
402+force-badtest linux-gke/all
403+force-badtest linux-oem/all
404+# fails rebuild test due to timeouts, but linux/arm64 passes
405+force-badtest linux-snapdragon/all
406+
407+# regressed in release due to missing python deps and changed transitive dependencies
408+force-badtest snapcraft/2.43.1+18.10
409+
410+# Was skipped in lxc, never passed in a vm, not supported on big-endian
411+# https://github.com/markfasheh/ocfs2-tools/issues/22
412+force-badtest ocfs2-tools/1.8.5-7build1/s390x ocfs2-tools/1.8.6-1/s390x
413+
414+# unsatisfiable test dep, should be ignored
415+force-badtest racket-mode/all/s390x
416+
417+# previous pass is from a version no longer in release pocket due to removal
418+force-badtest python-bayespy/0.5.18-1
419+
420+# test failure not reproducible locally or in Debian; not worth blocking on
421+force-badtest ack/3.0.2-1
422+
423+# bad proxy handling, how did this ever pass?
424+force-badtest r10k/3.1.0-1
425+
426+# was already broken but silently passing; failure now exposed thanks to the maintainer
427+force-badtest python-asdf/2.3.2-2/s390x
428+
429+# Test is flaky on all arches, it's a miracle it passed once:
430+force-badtest pglogical/2.2.1-4 pglogical/2.2.2-1
431+
432+# depends on ANAIS sagemath
433+force-badtest sagetex/all/armhf
434+
435+# new test exposing existing breakage
436+force-badtest dijitso/2018.1.1~git1-1/armhf dijitso/2019.1.0-2/armhf
437+
438+# depends on desktop components no longer built on s390x
439+force-badtest ubuntu-make/all/s390x
440+
441+# arch:all package adds test dep on unavailable package
442+force-badtest libmongodb-perl/all/s390x
443+force-badtest python-pbcommand/all/armhf python-pbcommand/all/i386 python-pbcommand/all/s390x
444+
445+# unsatisfiable indirect test dep on r-cran-v8, not available on these archs
446+force-badtest r-cran-rnexml/2.3.0-1/arm64 r-cran-rnexml/2.3.0-1/s390x
447+# test was previously skippable, now it fails with uninstallables because this package is x86-only
448+force-badtest beignet/all/arm64 beignet/all/armhf beignet/all/ppc64el beignet/all/s390x
449+
450+# bad tests in new version; mwhudson knows
451+force-badtest python-scipy/1.2.2-4/i386
452+# regressed on amd64 somewhere along the line
453+force-badtest python-scipy/1.2.2-4/amd64
454+
455+# broken by infra; remove badtest asap - LP: #1736390
456+force-badtest openvswitch/2.11.0-0ubuntu2/i386
457+
458+# test breaks with new clisp, but not reproducible locally
459+force-badtest cl-unicode/20180328-2/i386
460+
461+# never worked, was wrongly skipped before autopkgtest was upgraded.
462+force-badtest openjdk-8/8u222-b10-1ubuntu3
463+
464+# The "failure" is a progression in precision:
465+force-badtest cminpack/1.3.6-4
466+
467+# kernel testing issues:
468+# apparmor testing failure
469+force-skiptest gcc-7/7.4.0-8ubuntu1 gcc-8/8.3.0-4ubuntu1
470+# dkms missmatch failure
471+force-skiptest gcc-9/9.2.0-1ubuntu1
472+force-skiptest binutils/2.32.51.20190813-1ubuntu1
473+
474+# the whole test suite is horrible and flaky and blocks swaths of updates
475+force-badtest jekyll/3.8.3+dfsg-4 jekyll/3.8.3+dfsg-6
476+
477+# bad tests assume legacy eth0 as default interface; Debian bug #895342
478+force-badtest suricata/1:4.1.2-2ubuntu1
479+
480+# broken by removal of r-cran-lwgeom
481+force-badtest r-cran-sf/0.7-2+dfsg-1
482+
483+# something changed with loop device handling https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1814373
484+force-badtest systemd/240-6ubuntu9/ppc64el
485+
486+# broken with nodejs 10; this is a segfault in nodejs but only this package is broken and only on i386 so don't block the world for it.
487+force-badtest node-yarnpkg/1.13.0-1build1/i386
488+
489+# binaries removed on i386
490+force-badtest virtualbox/all/i386
491+
492+# picard-tools is now is arch-specific and builds only amd64
493+force-badtest picard-tools/all/i386
494+
495+# now failing with timeouts
496+force-badtest haveged/1.9.1-6ubuntu1/armhf
497+
498+# KalmanFilter gives wrong results on armhf (LP: #1819227)
499+force-badtest statsmodels/0.8.0-9/armhf statsmodels/0.8.0-9ubuntu1/armhf
500+
501+# only ever passed in a newer version that's been deleted from -proposed
502+force-badtest iptables/1.6.1-2ubuntu3
503+
504+# not a regression; new test that shows the existing package is broken
505+force-badtest dcfldd/1.3.4.1-13/i386 dcfldd/1.3.4.1-13/armhf
506+
507+# mis-tagged as a regression
508+force-badtest mailman/1:2.1.29-1/amd64
509+
510+# never passed, only skipped. rebuild test is broken for this package
511+force-badtest linux-oracle/all
512+
513+# how does someone write a tty-related test so bad that it passes in a container and fails in a VM?
514+force-badtest pinentry/1.1.0-3/amd64 pinentry/1.1.0-3/arm64 pinentry/1.1.0-3/s390x pinentry/1.1.0-3/i386
515+
516+# all failures of dkms packages are related to their incompatibility with the kernel.
517+force-skiptest dkms/2.7.1-1ubuntu2
518+
519+# 5.2 kernel broke it LP: #1838476
520+force-badtest conntrack-tools/1:1.4.5-2
521+
522+# part of the test was skipped, now if fails differently
523+# also this is being worked on in LPs: #1741860, #1681909
524+force-badtest makedumpfile/1:1.6.6-2ubuntu1/ppc64el
525+
526+# fixed in the next upload
527+force-badtest nodejs/10.15.2~dfsg-2/armhf nodejs/10.15.2~dfsg-2/s390x
528+
529+# removed package
530+force-badtest golang-github-jaytaylor-html2text-dev/0.0~git20170918.0.0ee88d3-4
531
532=== added file 'ubuntu-sru'
533=== added file 'vorlon'
534--- vorlon 1970-01-01 00:00:00 +0000
535+++ vorlon 2019-08-19 19:43:36 +0000
536@@ -0,0 +1,67 @@
537+# apache2 broken by perl+ssl.
538+force-skiptest curl/7.64.0-3ubuntu1
539+
540+force-badtest gist/all/armhf gist/all/s390x
541+force-badtest ruby-parallel/all/armhf ruby-parallel/all/s390x ruby-ferret/all/armhf
542+
543+# regressed with move to kvm
544+force-badtest coz-profiler/0.1.0-2
545+
546+# ANAIS
547+force-badtest ruby-mongo/all/i386
548+
549+# regressed in release
550+force-badtest ruby-httpclient/2.8.3-1ubuntu1
551+force-badtest ghub-plus-el/0.3-2/s390x
552+force-badtest node-sinon-chai/2.10.0-1
553+force-badtest libcoap/4.1.2-1/s390x
554+force-badtest zodb/1:3.10.7-1build1/amd64 zodb/1:3.10.7-1build1/i386
555+force-badtest reel/0.6.1-4
556+
557+# bad test, assumes that architecture has WiFi, urfkill, dhcp. previously it would SKIP on s390x, now it is run in nova-kvm and is treated as a regression rather than an always-failed
558+force-badtest network-manager/all/s390x
559+
560+# passed once as a fluke
561+force-badtest libanyevent-httpd-perl/0.93-5/ppc64el libanyevent-httpd-perl/all/s390x libanyevent-httpd-perl/all/armhf
562+
563+# regressed in release
564+force-badtest libpoe-component-client-dns-perl/1:1.054-1ubuntu1
565+
566+# The only test that is run is a rebuild test because the integration test doesn't work in a container; a kernel build takes 7h on armhf, the max a test is allowed to run on autopkgtest is 2h47m. Blacklist this until further notice.
567+force-badtest linux-raspi2/all linux/all/armhf
568+
569+# pandas no longer available on armhf
570+force-badtest lmfit-py/armhf/all
571+
572+# mongodb-server is not installable on armhf/i386; this tells us nothing of whether the client works
573+force-badtest python-motor/all/armhf python-motor/all/i386
574+
575+# test deps now unsatisfiable because of kde removals
576+force-badtest kopete/all/ppc64el kopete/all/s390x
577+force-badtest libkf5ksieve/all/ppc64el libkf5ksieve/all/s390x
578+force-badtest kf5-kdepim-apps-libs/all/ppc64el kf5-kdepim-apps-libs/all/s390x
579+force-badtest libkf5calendarsupport/all/ppc64el libkf5calendarsupport/all/s390x
580+force-badtest libkf5incidenceeditor/all/ppc64el libkf5incidenceeditor/all/s390x
581+force-badtest libkf5gravatar/all/ppc64el libkf5gravatar/all/s390x
582+force-badtest libkf5mailimporter/all/ppc64el libkf5mailimporter/all/s390x
583+force-badtest akonadi-calendar/all/ppc64el akonadi-calendar/all/s390x
584+force-badtest libkf5eventviews/all/ppc64el libkf5eventviews/all/s390x
585+force-badtest kdepim-addons/all/s390x
586+force-badtest kdepim-runtime/all/ppc64el kdepim-runtime/all/s390x
587+force-badtest parley/all/ppc64el parley/all/s390x
588+
589+# "blacklisted", self-explanatory.
590+force-badtest linux/blacklisted/i386 linux/blacklisted/amd64 linux/blacklisted/ppc64el
591+force-badtest stress-ng/blacklisted
592+
593+# As requested by yofel: testing needed to allow a xenial SRU.
594+force-badtest plasma-framework/all/s390x
595+
596+# bad test, but better to have this package in xenial and unblock things than leave it on the list
597+force-badtest guessit/0.11.0-2
598+
599+# sil2100: unreliable test-suite, we don't care about qt bindings on s390x
600+force-badtest python-qtpy/1.3.1-1build1/s390x
601+
602+# rbalint: arm64 testbed hard-reboots breaking shutdown test LP: #1748280
603+force-badtest unattended-upgrades/all/arm64

Subscribers

People subscribed via source and target branches

to all changes: