lp:~gandelman-a/ubuntu/precise/autopkgtest/purge_build_deps

Created by Adam Gandelman on 2013-06-28 and last modified on 2013-06-28
Get this branch:
bzr branch lp:~gandelman-a/ubuntu/precise/autopkgtest/purge_build_deps
Only Adam Gandelman can upload to this branch. If you are Adam Gandelman please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Adam Gandelman
Status:
Development

Recent revisions

31. By Adam Gandelman on 2013-06-28

Preliminary attempt at tracking installed build depends and purging after pkg build.

30. By Martin Pitt on 2012-04-16

runner/adt-run: Avoids quoting of filenames when copyup/copydown is
called. Fixes adt-run for packages like postgresql-common or aoeui.
Thanks to Jean-Baptiste Lallement for the patch! (Debian #648161)

29. By Colin Watson on 2012-04-03

Fix parsing of '@' dependencies in multi-binary packages. Forwarded to
Debian #667022.

28. By Martin Pitt on 2011-11-11

Fix hashbang lines to use python instead of python2.6, and update
debian/control to only depend on python (>= 2.6) instead of python2.6.
See Debian #644332.

27. By Martin Pitt on 2011-11-09

* adt-run: Fix "NameError: global name 'f' is not defined" crash. Forwarded
  to Debian #647882.
* adt-run: Clean up temporary apt configuration after running the tests.
  Forwarded to Debian #648142.
* adt-run: Skip configuring and running apt when running as non-root.
  Forwarded to Debian #648148.

26. By Ian Jackson on 2011-08-27

* Bugfixes:
  - Python backtrace (no method "bomb") on bad tests/control syntax.
  - Permit tests/control fields with medial capital letters.
  - Do not duplicate previous stanzas (closes: #637333).
  - Make adt-run --quiet work (closes: #637350).
  - Make "build-needed" restriction work (closes: #637353).
  - Fix a debugging message which was spuriously sent to stderr.
* Change Maintainer to the new list and move me to Uploaders.

25. By Sandro Tosi on 2010-01-12

* Non-maintainer upload, to drop Python 2.4; thanks to Luca Falavigna for the
  report and to Jakub Wilk for the patch; Closes: #562408
  - debian/control
    + Depends on 'python (>= 2.4)'
  - runner/adt-run, virt-subproc/adt-virt-*
    + uses the default Python interpreter instead of hard-coding python2.4;
    also Closes: #548985

24. By Scott Kitterman on 2009-03-11

Bump python depends to Python 2.6

23. By Ian Jackson on 2008-08-27

Packaging changes:
* autopkgtest-xenlvm depends on adns-tools | libadns1-bin,
  as the latter is renamed to the former in lenny. Closes:#490763.
* .bzrignore improvements.
* Maintainer is now Ian Jackson <email address hidden> -
  ie I am hijacking this package from my other hat, so to speak.

adt-xenlvm changes:
* support for swap, defaulting to 5G.
  This will break existing setups with insufficient LVM space.
* allow specification of LVM PVs to use.
* remove spurious mkdir of empty variable $snap.
* with-testbed: sleep 1 after xm destroy, as the latter is racy.

Configuration updates:
* hosts/magrathea/*: configuration as for pre-deployment tests
* adt-testreport-{cronjob,runloop}: new GO_ANYWAY arrangements
* adt-testreport-onepackage: default is not to upload (publish) sources

22. By Anibal Monsalve Salazar on 2008-07-23

* Non-maintainer upload
* Doesn't depend on libadns1-bin, depends on adns-tools;
  closes: #490763

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/saucy/autopkgtest
This branch contains Public information 
Everyone can see this information.

Subscribers