Merge ~flexiondotorg/ubuntu/+source/ubuntu-meta:ubuntu/groovy into ubuntu/+source/ubuntu-meta:ubuntu/groovy

Proposed by Martin Wimpress 
Status: Needs review
Proposed branch: ~flexiondotorg/ubuntu/+source/ubuntu-meta:ubuntu/groovy
Merge into: ubuntu/+source/ubuntu-meta:ubuntu/groovy
Diff against target: 54 lines (+25/-0)
2 files modified
debian/control (+23/-0)
metapackage-map (+2/-0)
Reviewer Review Type Date Requested Status
Dimitri John Ledkov (community) Approve
Iain Lane Pending
Ubuntu Server Dev import team Pending
Review via email: mp+390451@code.launchpad.net
To post a comment you must log in.
3a4727a... by Martin Wimpress 

Add Package: ubuntu-desktop-raspi and ubuntu-server-raspi

Revision history for this message
Dimitri John Ledkov (xnox) :
review: Approve

Unmerged commits

3a4727a... by Martin Wimpress 

Add Package: ubuntu-desktop-raspi and ubuntu-server-raspi

0751c40... by Martin Wimpress 

Add desktop-raspi and server-raspi to metapackage-map

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1diff --git a/debian/control b/debian/control
2index d94e913..5958fb4 100644
3--- a/debian/control
4+++ b/debian/control
5@@ -45,6 +45,18 @@ Description: The Ubuntu desktop minimal system
6 It is also used to help ensure proper upgrades, so it is recommended that
7 it not be removed.
8
9+Package: ubuntu-desktop-raspi
10+Architecture: arm64 armhf
11+Depends: ${misc:Depends}, ${germinate:Depends}
12+Recommends: ${germinate:Recommends}
13+Provides: packagekit-installer
14+Description: The Ubuntu desktop system for Raspiberry Pi
15+ This package depends on all of the packages in the Ubuntu desktop system
16+ for Raspyberry Pi.
17+ .
18+ It is also used to help ensure proper upgrades, so it is recommended that
19+ it not be removed.
20+
21 Package: ubuntu-desktop
22 Architecture: amd64 arm64 armhf ppc64el
23 Depends: ${misc:Depends}, ${germinate:Depends}
24@@ -66,6 +78,17 @@ Description: The Ubuntu Server system
25 It is also used to help ensure proper upgrades, so it is recommended that
26 it not be removed.
27
28+ Package: ubuntu-server-raspi
29+Architecture: arm64 armhf
30+Depends: ${misc:Depends}, ${germinate:Depends}
31+Recommends: ${germinate:Recommends}
32+Description: The Ubuntu Server system for Raspberry Pi
33+ This package depends on all of the packages in the Ubuntu Server system
34+ for Raspberry Pi.
35+ .
36+ It is also used to help ensure proper upgrades, so it is recommended that
37+ it not be removed.
38+
39 Package: ubuntu-wsl
40 Architecture: amd64 arm64
41 Depends: ${misc:Depends}, ${germinate:Depends}
42diff --git a/metapackage-map b/metapackage-map
43index b2dfab4..8a53f4b 100644
44--- a/metapackage-map
45+++ b/metapackage-map
46@@ -1,6 +1,8 @@
47 minimal ubuntu-minimal
48 standard ubuntu-standard
49 desktop-minimal ubuntu-desktop-minimal
50+desktop-raspi ubuntu-desktop-raspi
51 desktop ubuntu-desktop
52 server ubuntu-server
53+server-raspi ubuntu-server-raspi
54 wsl ubuntu-wsl

Subscribers

People subscribed via source and target branches