lp:~firmware-testing-team/fwts/master

Created by Chris Van Hoof on 2013-03-21 and last modified on 2021-01-19
Get this branch:
bzr branch lp:~firmware-testing-team/fwts/master

Related bugs

Related blueprints

Branch information

Owner:
Firmware Testing Team
Project:
Firmware Test Suite
Status:
Development

Import details

Import Status: Reviewed

This branch is an import of the HEAD branch of the Git repository at git://kernel.ubuntu.com/hwe/fwts.git.

The next import is scheduled to run in 1 hour.

Last successful import was 4 hours ago.

Import started 4 hours ago on alnitak and finished 4 hours ago taking 15 seconds — see the log
Import started 10 hours ago on alnitak and finished 10 hours ago taking 20 seconds — see the log
Import started 16 hours ago on izar and finished 16 hours ago taking 10 seconds — see the log
Import started 22 hours ago on alnitak and finished 22 hours ago taking 20 seconds — see the log
Import started on 2021-01-18 on izar and finished on 2021-01-18 taking 10 seconds — see the log
Import started on 2021-01-18 on izar and finished on 2021-01-18 taking 15 seconds — see the log
Import started on 2021-01-18 on izar and finished on 2021-01-18 taking 15 seconds — see the log
Import started on 2021-01-17 on alnitak and finished on 2021-01-17 taking 10 seconds — see the log
Import started on 2021-01-17 on izar and finished on 2021-01-17 taking 10 seconds — see the log
Import started on 2021-01-17 on alnitak and finished on 2021-01-17 taking 10 seconds — see the log

Recent revisions

4686. By Alex Hung 14 hours ago

acpi: shorten fwts_method_package_elements_type args by a macro

Signed-off-by: Alex Hung <email address hidden>
Acked-by: Ivan Hu <email address hidden>
Acked-by: Colin Ian King <email address hidden>

4685. By Alex Hung 14 hours ago

acpi: method: add a function to check type of sub-package elements

The function name is fwts_method_check_element_type

Signed-off-by: Alex Hung <email address hidden>
Acked-by: Colin Ian King <email address hidden>
Acked-by: Ivan Hu <email address hidden>

4684. By Alex Hung 14 hours ago

acpi: method: replace _GPE test by fwts_method_package_elements_type

Signed-off-by: Alex Hung <email address hidden>
Acked-by: Colin Ian King <email address hidden>
Acked-by: Ivan Hu <email address hidden>

4683. By Alex Hung 14 hours ago

acpi: method: add a function to check number of sub-package elements

The function name is fwts_method_subpackage_count_equal

Signed-off-by: Alex Hung <email address hidden>
Acked-by: Colin Ian King <email address hidden>
Acked-by: Ivan Hu <email address hidden>

4682. By Alex Hung 23 hours ago

lib: fix compile error for debian + gcc 8.3

Fixes: ffea02df09d3 ("add fwts_acpi_space_id_check to check GAS ...")

Reported-by: Rebecca Cran <email address hidden>
Signed-off-by: Alex Hung <email address hidden>
Acked-by: Colin Ian King <email address hidden>
Reviewed-by: Rebecca Cran <email address hidden>
Acked-by: Ivan Hu <email address hidden>

4681. By Colin Ian King 23 hours ago

kernelscan: fix variable shadowing warning

Cppcheck is warning about variable name shadowing. Fix this by
renaming the top level variable 'patterns' to 'klog_patterns'.

Cleans up cppcheck warning:
src/utilities/kernelscan.c:352:16: style: Local variable 'patterns'
shadows outer variable [shadowVariable]
 klog_pattern *patterns;

src/utilities/kernelscan.c:113:22: note: Shadowed declaration
 static klog_pattern *patterns;

src/utilities/kernelscan.c:352:16: note: Shadow variable
 klog_pattern *patterns;

Signed-off-by: Colin Ian King <email address hidden>
Acked-by: Alex Hung <email address hidden>
Acked-by: Ivan Hu <email address hidden>

4680. By Colin Ian King 23 hours ago

uefi: clean up a cppcheck style warning

Cppcheck is complaining because the structure capsuleheader
is being referenced but it is never used. It is probably a
good idea to zero this structure to silence this warning and
to ensure the referenced data does not contain garbage.

Cleans cppcheck warning:
src/uefi/uefirtmisc/uefirtmisc.c:102:21: style: Unused
variable: capsuleheader [unusedVariable]
 EFI_CAPSULE_HEADER capsuleheader

Signed-off-by: Colin Ian King <email address hidden>
Acked-by: Alex Hung <email address hidden>
Acked-by: Ivan Hu <email address hidden>

4679. By Colin Ian King 23 hours ago

tpmevlogdump: clean up some minor cppcheck style warnings

Reduce the scope of some variables. Cleans up the following
cppcheck style warnings:

src/tpm/tpmevlogdump/tpmevlogdump.c:377:8: style: The scope
of the variable 'str_info' can be reduced. [variableScope]
 char *str_info;

src/tpm/tpmevlogdump/tpmevlogdump.c:471:13: style: The scope
of the variable 'data' can be reduced. [variableScope]
 uint8_t *data;

Signed-off-by: Colin Ian King <email address hidden>
Acked-by: Alex Hung <email address hidden>
Acked-by: Ivan Hu <email address hidden>

4678. By Colin Ian King 23 hours ago

tpmevlog: clean up some minor cppcheck style warnings

Reduce teh scope of some variables and only initialize them
when really required. Cleans up the following cppcheck style
warnings:

src/tpm/tpmevlog/tpmevlog.c:156:11: style: The scope of the variable
'event_size' can be reduced. [variableScope]
 uint32_t event_size = 0;

src/tpm/tpmevlog/tpmevlog.c:442:13: style: The scope of the variable
'data' can be reduced. [variableScope]
   uint8_t *data;

src/tpm/tpmevlog/tpmevlog.c:155:20: style: Variable 'hash_size' is
assigned a value that is never used. [unreadVariable]
 uint8_t hash_size = 0;

src/tpm/tpmevlog/tpmevlog.c:156:22: style: Variable 'event_size' is
assigned a value that is never used. [unreadVariable]
 uint32_t event_size = 0;

src/tpm/tpmevlog/tpmevlog.c:340:10: style: Variable 'ret' is assigned a
value that is never used. [unreadVariable]
 int ret = FWTS_OK;

Signed-off-by: Colin Ian King <email address hidden>
Acked-by: Alex Hung <email address hidden>
Acked-by: Ivan Hu <email address hidden>

4677. By Colin Ian King 23 hours ago

uefi: add a helper to check for address overflow

Cppcheck found some code that indeed was being optimized out,
so add an inline helper function do to the overflow checking
in a way that actually works.

Fixes cppcheck warning:
src/uefi/securebootcert/securebootcert.c:274:49: warning: Invalid test
for overflow 'var_data_addr+siglist.SignatureListSize<var_data_addr';
pointer overflow is undefined behavior. Some mainstream compilers
remove such overflow tests when optimising the code and assume it's
always false. [invalidTestForOverflow]:

  if (var_data_addr + siglist.SignatureListSize < var_data_addr)

Signed-off-by: Colin Ian King <email address hidden>
Acked-by: Alex Hung <email address hidden>
Acked-by: Ivan Hu <email address hidden>

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.