~evarlast/ubuntu/+source/apache2:fix-60330

Last commit made on 2016-11-30
Get this branch:
git clone -b fix-60330 https://git.launchpad.net/~evarlast/ubuntu/+source/apache2
Only Jay R. Wren can upload to this branch. If you are Jay R. Wren please log in for upload directions.

Branch merges

Branch information

Name:
fix-60330
Repository:
lp:~evarlast/ubuntu/+source/apache2

Recent commits

238817e... by Jay R. Wren

rev changelog

c9263e5... by Jay R. Wren

debian/patches/fix-60330.patch

04349e4... by Marc Deslauriers

Import version 2.4.7-1ubuntu4.13 to ubuntu/trusty-updates

Imported using usd-importer.

e390156... by Marc Deslauriers

Import version 2.4.7-1ubuntu4.13 to ubuntu/trusty-security

Imported using usd-importer.

New changelog entries:
  * SECURITY UPDATE: proxy request header vulnerability (httpoxy)
    - debian/patches/CVE-2016-5387.patch: don't pass through HTTP_PROXY in
      server/util_script.c.
    - CVE-2016-5387
  * This update does _not_ contain the changes from (2.4.7-1ubuntu4.12) in
    trusty-proposed.

105fb95... by Christian Ehrhardt 

Import version 2.4.7-1ubuntu4.11 to ubuntu/trusty-updates

Imported using usd-importer.

292e4d4... by Christian Ehrhardt 

Import version 2.4.7-1ubuntu4.11 to ubuntu/trusty-proposed

Imported using usd-importer.

New changelog entries:
  * Fix hang until proxy timeout for Proxy responses with error status and
    "ProxyErrorOverride On" being set (LP: #1495988).

171e909... by Louis Bouchard

Import version 2.4.7-1ubuntu4.10 to ubuntu/trusty-updates

Imported using usd-importer.

bd23806... by Louis Bouchard

Import version 2.4.7-1ubuntu4.10 to ubuntu/trusty-proposed

Imported using usd-importer.

New changelog entries:
  * Add apache2 specific modification needed along with fix to
    libapache2-mpm-itk so it becomes installable again (LP: #1286882):
    - Removes warning on mpm_itk use
    - Removes conflicts on mpm_itk

595d9d2... by Dave Chiluk

Import version 2.4.7-1ubuntu4.9 to ubuntu/trusty-updates

Imported using usd-importer.

f295364... by Dave Chiluk

Import version 2.4.7-1ubuntu4.9 to ubuntu/trusty-proposed

Imported using usd-importer.

New changelog entries:
  * Force disablereuse on for mod_proxy_wstunnel. Fixes "Unable to connect to:
    ws://<maas IP>:/MAAS/ws" errors with maas, and other proxy applications.
    https://bz.apache.org/bugzilla/show_bug.cgi?id=55890
    (LP: #1484696).