Ubuntu

lp:~drizzle-developers/ubuntu/lucid/drizzle/lucid

Created by Monty Taylor on 2010-10-30 and last modified on 2011-02-04
Get this branch:
bzr branch lp:~drizzle-developers/ubuntu/lucid/drizzle/lucid
Members of Drizzle Developers can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Drizzle Developers
Status:
Development

Recent revisions

9. By Monty Taylor on 2011-02-04

* New upstream release.
* Updated the -Werror patch.
* Updated copyright file.
* Removed get-orig-source target which didn't work right.
* New upstream release.
* Removed csv and filesystem engine plugins.
* Removed now-unneeded CFLAGS override.
* Bumped haildb requirement to 2.3.2.
* Replaced gtest with boost::test in build deps.
* Removed -W from sphinx options until debian gets sphinx 1.0.
* Updated the copyright file.
* Disabled -W on sphinx-build.
* New upstream release.
* Merged in changes to copyright file from Lee.

8. By Monty Taylor on 2011-01-20

* Backport for PPA.
* Backport for Lucid PPA.
* Backport for lucid PPA.
* Modified for Lucid.
* Backported for lucid PPA.
* Backported to lucid.
* Fixed conflicting files.
* More symbols file fixes.
* Fixed a filename inclusion conflict.
* Fixed i386 symbols file.
* Backported to lucid.
* Changed the drizzle meta package relationship.
* Backported to Lucid.
* Backported to lucid.
* Made the tie between drizzle meta-package and
  drizzle-server/drizzle-client packages tighter.
* More init script fixes.
* When investigating drizzled options, we have to run drizzled as
  the drizzle user.
* Removed libdrizzlemessage from drizzle-plugin-dev.
* Backported for lucid.
* Made the tie between drizzle meta-package and
  drizzle-server/drizzle-client packages tighter.
* Backport for lucid.
* Fixed the libtokyocabinet depend.
* Fixed a preinst script.
* Fixed the libdrizzle depend.
* Backported build depends from trunk so that we can update machines
  easily.
* Turned off memcached-stats plugin.
* Added build-essential to drizzle-plugin-dev.
* Made drizzle-dev depend on drizzle-plugin-dev so I don't have to
  maintain two duplicate lists.
* Actually create the log dir.
* Moved location of the plugins.
* Fixed lintian-overrides for new plugin location.
* Added build depend on libboost-dev.
* Added build depend on libinnodb.
* Added build depend on libgcrypt.
* Removed build depend on libgnutls-dev.
* New upstream release.
* Backport for lucid PPA.
* New upstream release.
* Added information_schema result files into include-binaries.
* Added lintian-overrides. Upstream does not provide a changelog.
* Initial packaging (Closes: #492822)

7. By Monty Taylor on 2011-01-20

Disable intersphinx mappings. They break in the ubuntu builders.

6. By Monty Taylor on 2011-01-20

Merged builddeb config.

5. By Monty Taylor on 2011-01-20

* New upstream release.
* Fixed missing build depends.
* Added Lee to uploaders.
* Removed pbxt plugin - is disabled in tree upstream.
* Removed libnotifymm-dev from build depends and references to the
  errmsg-notify plugin. It causes build to not work on arm, and it's
  really not actually a very useful plugin anyway.
* New upstream release.
* Added libaio-dev build depend for InnoDB.
* Removed libpcre patch - applied upstream.
* Fixed how we were linking libpcre (LP: #688819)
* Turn on verbose build per request from doko.
* New upstream release.
* Remove preinst script - it was actually a bad idea.
* New upstream release.
* Turn off -Werror for packaging builds. (Closes: #602662)
* Update rules file to put datadir in the right place. (LP: #677121)
* Add migration script to fix fallout from 677121.
* New upstream release.
* Updated libgearman version depend.
* Fixed libreadline version requirement.
* Updated copyright file and added some missed files.
* Made patch headers follow DEP-3 format.
* New upstream release.
* drizzledump.1 manpage shipping in tarball now.
* Removed quilt patches for things applied upstream.
* Renamed drizzle-server to drizzle.
* Removed unused README.Maintainer.
* Modified for Natty.
* Added upstart script.
* Backport for Maverick.
* Maverick PPA pid-file fix.
* Maverick PPA.
* Merged in changes from Clint.
* Backported for maverick PPA.

4. By Monty Taylor on 2011-01-20

Removed now-unneeded CFLAGS override.

3. By Monty Taylor on 2011-01-20

Removed csv and filesystem engine plugins.

2. By Monty Taylor on 2011-01-20

New upstream release.

1. By Monty Taylor on 2011-01-20

* New upstream release.
* Merged in changes to copyright file from Lee.
* Fixed missing build depends.
* Added Lee to uploaders.
* New upstream release.
* Added libaio-dev build depend for InnoDB.
* Removed libnotifymm-dev from build depends and references to the
  errmsg-notify plugin. It causes build to not work on arm, and it's
  really not actually a very useful plugin anyway.
* Removed pbxt plugin - is disabled in tree upstream.
* New upstream release.
* New upstream release.
* Turn off -Werror for packaging builds. (Closes: #602662)
* Remove preinst script - it was actually a bad idea.
* Removed old unused build script.
* New upstream release.
* Updated libgearman version depend.
* Fixed libreadline version requirement.
* Updated copyright file and added some missed files.
* Made patch headers follow DEP-3 format.
* Update rules file to put datadir in the right place. (LP: #677121)
* Add migration script to fix fallout from 677121.
* New upstream release.
* drizzledump.1 manpage shipping in tarball now.
* Removed quilt patches for things applied upstream.
* Added support for RabbitMQ plugin.
* Added support for libnotify error message plugin.
* Added build depend on libboost-iostreams-dev.
* New upstream release.
* Modify mysql_protocol plugin build so that we can provide it in
  mysql_protocol package.
* Fixed a bug in pandora-plugin shown by making mysql_protocol non-static.
* Removed the no-upstream-changelogs lintian overrides - upstream now
  giveses us them.
* Fixed a double-free bug.
* Renamed drizzle-server to drizzle.
* Removed unused README.Maintainer.
* New upstream release.
* Removed libdrizzle-doc package since we don't have doxygen docs there
  anymore.
* Added compilation comment to mark this as a binary dist rather than a
  source one.
* Changed watch file to work around launchpad bug.
* Updated libdrizzle package based on new libdrizzle so bump.
* Added MySQL protocol plugin as an option plugin conflicting with MySQL.
* Put logging-stats back in drizzle-server.
* Put transaction-log back in drizzle-server.
* Split plugins out into their own packages.
* Depend on haildb 2.3.1 to allow haildb plugin to work.
* Turned off load_by_default for plugins that don't need it.
* Fixed a doc-base package typo. (Closes: #599750)
* Removed old libdrizzle-dev build-dep.
* New upstream release.
* Removed pid-file argument hack.
* Updated GPL-2 address to be new address.
* Directly copy in drizzledump.1 since debian doesn't have sphinx 1.0 yet.
* Link to jquery from libjs-jquery. Add it as a depend.
* Add drizzled.8 symlink to the install files.
* New upstream release.
* Removed libdrizzledmessage0.symbols for now - it's not stable enough and
  the platform tags seem to be behaving oddly.
* Edited init script to work around pid-file argument bug.
* debian/copyright: audited all UNKNOWN license files using licensecheck
  (LP: #649281)
* debian/control: added me to Uploaders
* New upstream release.
* Fixed file conflicts.
* Updated copyright file.
* Updated watch file.
* Support drizzle7 name change.
* New upstream release.
* Added build-depend on python-sphinx.
* Added sphinx docs to the doc base system.
* Added flex to build depeneds.
* Fixed a filename inclusion conflict.
* New upstream release.
* Started putting arch tags in the symbols file.
* Hopefully fixed symbols versioning rules to deal with libdrizzle now.
* Collapsed some rules in debian/rules.
* Added in libdrizzle packages.
* New upstream release.
* Added build-depends on three more boost libs.
* Added build-depends on haildb.
* Edit po/Makefile.in.in - we do not care about missing .po files.
* New upstream release. (Closes: #578834, #581754)
* Updated to Standards Version 3.9.1.
* Removed reference to /usr/share/common-licenses/BSD.
* Added intltool depends.
* Merged in changes from trunk.
* Turned off intltool POTFILE.in sanity checking since .pc dir breaks it.
* Added Boost.Thread build/dev dep.
* New upstream release. (Closes: #578834, #581754, #580993, #577959)
* Updated init script to check for a running drizzle or mysql first. This
  should ease installation for people who want to install alongside of
  MySQL. (Closes: #581699)
* Added a timeout to init script stop similar to how the the start option
  works. (Closes: #581000)
* Added build and dev depend on pandora-build.
* Remove libdrizzlemessage.so from drizzle-plugin-dev.
* When investigating drizzled options, we have to run drizzled as
  the drizzle user.
* New upstream release.
* Moved location of the plugins.
* Fixed lintian-overrides for new plugin location.
* Added build depend on libboost-dev.
* Added build depend on libinnodb.
* Added build depend on libgcrypt.
* Removed build depend on libgnutls-dev.
* Added version to the libmemcached depend.
* Added build-essential to drizzle-plugin-dev.
* Made drizzle-dev depend on drizzle-plugin-dev so I don't have to
  maintain two duplicate lists.
* Actually create the log dir.
* Add libtokyocabinet to drizzle-dev.
* Added two pbxt files to include-binaries.
* Added build-dep on libboost-program-options-dev.
* Added system-tap-sdt to build depends.
* Added libdrizzledmessage packages.
* Branched for maverick.
* New upstream release.
* Added information_schema result files into include-binaries.
* Added lintian-overrides. Upstream does not provide a changelog.
* Initial packaging (Closes: #492822)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/drizzle
This branch contains Public information 
Everyone can see this information.