plank:master

Last commit made on 2021-02-22
Get this branch:
git clone -b master https://git.launchpad.net/plank
Members of Docky Core can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
master
Repository:
lp:plank

Recent commits

21d15e7... by Rico Tzschichholz on 2021-02-22

Reference of [GtkChild] field is handled by GtkBuilder, type must be unowned

20c16a0... by Rico Tzschichholz on 2020-07-05

build: Update git-version-gen to latest upstream

From commit 8a09003664733eb6bef031f56ef9cd575e403023 of
https://git.savannah.gnu.org/cgit/autoconf.git/tree/build-aux/git-version-gen

2ae156a... by Rico Tzschichholz on 2020-07-05

Back to development

469240e... by Rico Tzschichholz on 2020-05-31

po: Update translations

5967798... by Rico Tzschichholz on 2020-05-27

applications: Properly handle possible error of GMenu.Tree.load_sync()

Prevent crash on "g_mutex_clear() called on uninitialised or locked mutex"

248cc4a... by Rico Tzschichholz on 2019-09-01

build: Allow building with gettext ≥ 0.20

The use of AM_GNU_GETTEXT_VERSION in configure.ac instructs autopoint to
copy po/Makefile.in.in from the exact gettext version. It is fine if the
version of gettext installed on the system has the same minor version
number with the requested version, but it fails if you have a newer
version of gettext because of the mismatch between autoconf macros and
Makefile.in.in.

  *** error: gettext infrastructure mismatch: using a Makefile.in.in
  from gettext version 0.19 but the autoconf macros are from gettext
  version 0.20

Instead of specifying the exact version with AM_GNU_GETTEXT_VERSION, we
can use AM_GNU_GETTEXT_REQUIRE_VERSION to ask autopoint to simply use
the gettext version installed on the system to prevent the mismatch.

27c7863... by Rico Tzschichholz on 2019-08-19

Prepare 0.11.89 release

226a0a2... by Rico Tzschichholz on 2019-08-19

windowcontrol: Don't call center_and_focus_window() twice with targetWindow

96bbb1d... by Adam Bieńkowski on 2019-04-30

theme: Add "BadgeColor" option

If not set to "black" then this color will use as background color
for the badge instead of a color based on active GTK theme.

fb624c2... by Rico Tzschichholz on 2019-03-18

Constructors of abstract classes should not be public