Merge lp:~didrocks/ubiquity/take-libindicator-abi-change into lp:ubiquity

Proposed by Didier Roche on 2010-09-22
Status: Merged
Merged at revision: 4399
Proposed branch: lp:~didrocks/ubiquity/take-libindicator-abi-change
Merge into: lp:ubiquity
Diff against target: 46 lines (+6/-2)
3 files modified
d-i/update-control (+1/-1)
debian/changelog (+4/-0)
debian/control (+1/-1)
To merge this branch: bzr merge lp:~didrocks/ubiquity/take-libindicator-abi-change
Reviewer Review Type Date Requested Status
Ubuntu Installer Team 2010-09-22 Pending
Review via email: mp+36274@code.launchpad.net

This proposal supersedes a proposal from 2010-09-22.

Description of the change

rebuild with latest libindicator-dev for ABI change

To post a comment you must log in.
Colin Watson (cjwatson) wrote : Posted in a previous version of this proposal

ubiquity's Build-Depends are autogenerated, so this change needs to be
made in d-i/update-control too.

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
=== modified file 'd-i/update-control'
--- d-i/update-control 2010-08-20 14:42:59 +0000
+++ d-i/update-control 2010-09-22 10:17:09 +0000
@@ -39,7 +39,7 @@
39 'libglib2.0-dev',39 'libglib2.0-dev',
40 'libgstreamer-plugins-base0.10-dev (>= 0.10.23)',40 'libgstreamer-plugins-base0.10-dev (>= 0.10.23)',
41 'libgtk2.0-dev',41 'libgtk2.0-dev',
42 'libindicator-dev',42 'libindicator-dev (>= 0.3.14)',
43 'pkg-config',43 'pkg-config',
44 'po-debconf (>= 1.0)',44 'po-debconf (>= 1.0)',
45 'python-all-dev (>= 2.6)',45 'python-all-dev (>= 2.6)',
4646
=== modified file 'debian/changelog'
--- debian/changelog 2010-09-21 18:02:43 +0000
+++ debian/changelog 2010-09-22 10:17:09 +0000
@@ -1,5 +1,6 @@
1ubiquity (2.4.1) UNRELEASED; urgency=low1ubiquity (2.4.1) UNRELEASED; urgency=low
22
3 [ Evan Dandrea ]
3 * Fix the installer window growing and shrinking when typing in the4 * Fix the installer window growing and shrinking when typing in the
4 boxes on the user setup page.5 boxes on the user setup page.
5 * Do not show the prepare page by means of hiding the language page6 * Do not show the prepare page by means of hiding the language page
@@ -11,6 +12,9 @@
11 * Also tail syslog in the installer details pane, since that's where12 * Also tail syslog in the installer details pane, since that's where
12 the action is.13 the action is.
1314
15 [ Didier Roche ]
16 * depends on latest libindicator-dev for ABI change (LP: #637692)
17
14 -- Evan Dandrea <evand@ubuntu.com> Tue, 21 Sep 2010 15:51:27 +010018 -- Evan Dandrea <evand@ubuntu.com> Tue, 21 Sep 2010 15:51:27 +0100
1519
16ubiquity (2.4.0) maverick; urgency=low20ubiquity (2.4.0) maverick; urgency=low
1721
=== modified file 'debian/control'
--- debian/control 2010-09-17 10:21:01 +0000
+++ debian/control 2010-09-22 10:17:09 +0000
@@ -3,7 +3,7 @@
3Priority: optional3Priority: optional
4Maintainer: Ubuntu Installer Team <ubuntu-installer@lists.ubuntu.com>4Maintainer: Ubuntu Installer Team <ubuntu-installer@lists.ubuntu.com>
5Uploaders: Colin Watson <cjwatson@ubuntu.com>, Evan Dandrea <evand@ubuntu.com>5Uploaders: Colin Watson <cjwatson@ubuntu.com>, Evan Dandrea <evand@ubuntu.com>
6Build-Depends: apt, bf-utf-source, dash, dctrl-tools, debconf (>= 0.5.0), debhelper (>= 7.4.0), dh-di (>= 3), dpkg-dev (>= 1.14.4), intltool (>= 0.40.0), intltool-debian (>= 0.30+20040212), iso-codes, isoquery, keymapper (>= 0.5.3-7), libbogl-dev, libcheese-gtk-dev, libdebconfclient0-dev (>= 0.68), libdebian-installer4-dev (>= 0.76), libglib2.0-dev, libgstreamer-plugins-base0.10-dev (>= 0.10.23), libgtk2.0-dev, libindicator-dev, libiw-dev (>= 27+28pre9), libparted0-dev (>= 2.2), libxml2-dev (>= 2.6.24), locales, pkg-config, po-debconf (>= 1.0), python-all-dev (>= 2.6), python-central (>= 0.5), python-gobject-dev, python-gtk2-dev, tzdata, wget, xkb-data (>= 0.9), xkb-data-i18n6Build-Depends: apt, bf-utf-source, dash, dctrl-tools, debconf (>= 0.5.0), debhelper (>= 7.4.0), dh-di (>= 3), dpkg-dev (>= 1.14.4), intltool (>= 0.40.0), intltool-debian (>= 0.30+20040212), iso-codes, isoquery, keymapper (>= 0.5.3-7), libbogl-dev, libcheese-gtk-dev, libdebconfclient0-dev (>= 0.68), libdebian-installer4-dev (>= 0.76), libglib2.0-dev, libgstreamer-plugins-base0.10-dev (>= 0.10.23), libgtk2.0-dev, libindicator-dev (>= 0.3.14), libiw-dev (>= 27+28pre9), libparted0-dev (>= 2.2), libxml2-dev (>= 2.6.24), locales, pkg-config, po-debconf (>= 1.0), python-all-dev (>= 2.6), python-central (>= 0.5), python-gobject-dev, python-gtk2-dev, tzdata, wget, xkb-data (>= 0.9), xkb-data-i18n
7Standards-Version: 3.6.2.17Standards-Version: 3.6.2.1
8XS-Python-Version: current, >= 2.68XS-Python-Version: current, >= 2.6
9Vcs-Bzr: http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk9Vcs-Bzr: http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk

Subscribers

People subscribed via source and target branches

to status/vote changes: